当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 求助声卡问题!
帖子发表于 : 2005-09-14 20:50 

注册: 2005-09-14 20:46
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
我的系统原来是magic linux的,在终端中运行alsaconfi就可以正确识别出声卡,现在换成了ubuntu我发现系统中没这个命令,系统又无法正确识别出我的声卡.请问在ubuntu中有没有类似的工具.


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2005-09-14 21:33 

注册: 2005-09-14 20:46
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
声卡识别出来却没有声音这是为什么
udi = '/org/freedesktop/Hal/devices/BIOS/Handle_0x0A02'
bios.description = 'Crystal 4236b Audio' (string)
bios.status = 'Enabled' (string)
bios.type = 'Sound' (string)
bios.on_board_device_information = 'true' (string)
info.product = 'On Board Device' (string)
info.capabilities = 'linux.sysinfo' (string)
info.parent = '/org/freedesktop/Hal/devices/BIOS' (string)
info.bus = 'unknown' (string)


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-09-22 15:18 

注册: 2005-09-20 11:18
帖子: 46
送出感谢: 0 次
接收感谢: 0 次
我也遇到了这个问题。
我是用lspci命令查询出来的。我的声卡是创新的。
但MP3放不了。昨天问了一天没有人可以告诉我为什么。
LINUXSIR的人按照DEBIAN的方法给我回答的。我一点办法没有。

ALSACONF在班图中没有,但是APT-GET INSTALL alsaconf 提示已经是最新版,证明还是安装了。FIND ALSACONF 命令没有!


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2005-09-22 15:59 
论坛管理员

注册: 2005-03-27 0:06
帖子: 10116
系统: Ubuntu 12.04
送出感谢: 7
接收感谢: 128
系统 -> 首选项 -> 音效 关闭音效服务器试试?


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2005-09-22 22:59 

注册: 2005-09-20 11:18
帖子: 46
送出感谢: 0 次
接收感谢: 0 次
谢谢楼上的兄弟,没有多大用。
看了点文章发现有三种不同的声音系统。分别在multimedia systems selector中
班图系统用的是那一种阿?
我改成那一个都不解决我的问题。
这三种分别是:ALAS/ESD/OSS
点击测试按钮后。错误框中提示:“Failed to construct test pipeline for 'ALSA - Advanced Linux Sound Architecture'”

lspci 结果如下:
==========
nios@ubuntu:~$ lspci
0000:00:00.0 Host bridge: Intel Corp. 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
0000:00:02.0 VGA compatible controller: Intel Corp. 82865G Integrated Graphics Device (rev 02)
0000:00:1d.0 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #1 (rev 02)
0000:00:1d.1 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #2 (rev 02)
0000:00:1d.3 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #4 (rev 02)
0000:00:1d.7 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
0000:00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev c2)
0000:00:1f.0 ISA bridge: Intel Corp. 82801EB/ER (ICH5/ICH5R) LPC Bridge (rev 02)0000:00:1f.1 IDE interface: Intel Corp. 82801EB/ER (ICH5/ICH5R) Ultra ATA 100 Storage Controller (rev 02)
0000:00:1f.2 IDE interface: Intel Corp. 82801EB (ICH5) Serial ATA 150 Storage Controller (rev 02)
0000:00:1f.3 SMBus: Intel Corp. 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
0000:01:00.0 Multimedia audio controller: Creative Labs SB Audigy LS---在这里我的声卡是认了
0000:01:08.0 Ethernet controller: Intel Corp. 82562EZ 10/100 Ethernet Controller (rev 02)
==============
还有老兄说模块加载没有?我的lsmod后的情况
===============
nios@ubuntu:~$ lsmod
Module Size Used by
proc_intf 4100 0
freq_table 4100 0
cpufreq_userspace 4572 0
cpufreq_ondemand 6172 0
cpufreq_powersave 1920 0
i915 18304 1
drm 59412 2 i915
video 16260 0
sony_acpi 6280 0
pcc_acpi 11264 0
button 6800 0
battery 10244 0
container 4608 0
ac 4996 0
ipv6 229376 11
e100 32384 0
mii 4736 1 e100
i2c_i801 8076 0
i2c_core 21264 1 i2c_i801
ata_piix 8836 0
libata 44548 1 ata_piix
scsi_mod 119936 1 libata
hw_random 5524 0
pci_hotplug 30512 0
ehci_hcd 29444 0
uhci_hcd 30224 0
usbcore 107384 3 ehci_hcd,uhci_hcd
intel_mch_agp 10000 0
intel_agp 20636 1
agpgart 31784 4 drm,intel_mch_agp,intel_agp
floppy 54864 0
rtc 12216 0
pcspkr 3816 0
md 43856 0
evdev 9088 0
dm_mod 53116 1
tsdev 7488 0
capability 5000 0
commoncap 7808 1 capability
psmouse 19336 0
mousedev 11160 1
parport_pc 34372 1
lp 10792 0
parport 33480 2 parport_pc,lp
ide_cd 38532 0
cdrom 36508 1 ide_cd
ext3 120968 1
jbd 54168 1 ext3
ide_generic 1664 0
piix 9988 1
ide_disk 18176 3
ide_core 118988 4 ide_cd,ide_generic,piix,ide_disk
unix 26164 828
thermal 13576 0
processor 22708 1 thermal
fan 4612 0
fbcon 34048 0
font 8448 1 fbcon
bitblit 5120 1 fbcon
vesafb 6948 0
cfbcopyarea 3968 1 vesafb
cfbimgblt 3072 1 vesafb
cfbfillrect 3584 1 vesafb
==========================
好像没有哦,我也不知道模块加载后是什么名字。请各位帮帮忙给看一下。如果没有加载我该怎么办??


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2005-09-22 23:25 

注册: 2005-09-20 11:18
帖子: 46
送出感谢: 0 次
接收感谢: 0 次
请看一下我的声卡硬件参数:
截图如下:


附件:
Screenshot-2.png
Screenshot-2.png [ 73.32 KiB | 被浏览 1228 次 ]

页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2005-09-23 10:37 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
看硬件参数,可没有那个水平。

多媒体系统选择器。这里可以测试一下。难道都不通过?音效那里一般应该没问题。只是一个乱开关。

你的lspci是对的。lsmod好像少了。驱动模块没有。
我的有这些。
~$ lsmod|grep sound
soundcore 10016 3 snd
exp@eexpress-ubuntu-office:~$ lsmod|grep snd
snd_intel8x0 32352 2
snd_ac97_codec 74144 1 snd_intel8x0
snd_pcm_oss 52132 1
snd_mixer_oss 19680 2 snd_pcm_oss
snd_pcm 94696 3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer 25060 1 snd_pcm
snd 55012 6 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore 10016 3 snd
snd_page_alloc 9732 2 snd_intel8x0,snd_pcm
你看,混音的也有。


_________________
● 鸣学


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2005-09-23 20:24 

注册: 2005-09-20 11:18
帖子: 46
送出感谢: 0 次
接收感谢: 0 次
eexpress 写道:
看硬件参数,可没有那个水平。

多媒体系统选择器。这里可以测试一下。难道都不通过?音效那里一般应该没问题。只是一个乱开关。

你的lspci是对的。lsmod好像少了。驱动模块没有。
我的有这些。
~$ lsmod|grep sound
soundcore 10016 3 snd
exp@eexpress-ubuntu-office:~$ lsmod|grep snd
snd_intel8x0 32352 2
snd_ac97_codec 74144 1 snd_intel8x0
snd_pcm_oss 52132 1
snd_mixer_oss 19680 2 snd_pcm_oss
snd_pcm 94696 3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer 25060 1 snd_pcm
snd 55012 6 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore 10016 3 snd
snd_page_alloc 9732 2 snd_intel8x0,snd_pcm
你看,混音的也有。



怎样才能加到模块里啊?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译