请教如何设置xorg.conf文件支持1024*768 60Hz

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
xuchuangfa
帖子: 27
注册时间: 2010-02-12 10:52
送出感谢: 0
接收感谢: 0

请教如何设置xorg.conf文件支持1024*768 60Hz

#1

帖子 xuchuangfa » 2010-09-24 13:35

请问怎么设置支持1024*768 60Hz的显示样式啊,我的xorg.conf文件是这样的:

说明:我的是14‘的液晶显示器,支持1024*768 60Hz

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@palmer) Fri Apr 9 10:35:18 UTC 2010

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30.0 - 100.0
VertRefresh 50.0 - 120.0
Option "DPMS"
# HorizSync source: builtin, VertRefresh source: builtin
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
Option "TwinView" "0"
Option "metamodes"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Module"
Load "glx"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
# generated from default
EndSection

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Device"
Identifier "Device0"
VendorName "NVIDIA Corporation"
BoardName "GeForce 8500 GT"
Driver "nvidia"
Option "NoLogo" "True"
EndSection

但是开机显示:

Cannot Display This Video Mode
Optimum resolution 1024x768 60Hz
上次由 xuchuangfa 在 2010-09-24 16:07,总共编辑 1 次。
happy!收到了ubuntu 9.04、9.10、10.04的光盘了,收藏...呵呵,收藏了不少了
xuchuangfa
帖子: 27
注册时间: 2010-02-12 10:52
送出感谢: 0
接收感谢: 0

Re: 请教如何设置xorg.conf文件支持1024*768 60Hz

#2

帖子 xuchuangfa » 2010-09-24 16:05

唉,现在论坛上的人才都去挣钱生活了阿,我发了许多帖都是被人只看不回复的,搞定了,乱搞搞定的, :em11

改成这样了:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@palmer) Fri Apr 9 10:35:18 UTC 2010

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder75) Thu Apr 22 11:44:23 PDT 2010

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "CRT-1"
HorizSync 28.0 - 50.0
VertRefresh 43.0 - 78.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 8500 GT"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "NoLogo" "True"
Option "TwinView" "0"
Option "metamodes" "1024x768_60 +0+0"

SubSection "Display"
Depth 24
EndSubSection
EndSection
happy!收到了ubuntu 9.04、9.10、10.04的光盘了,收藏...呵呵,收藏了不少了
头像
dingamao
帖子: 228
注册时间: 2006-01-05 10:50
送出感谢: 0
接收感谢: 0

Re: 请教如何设置xorg.conf文件支持1024*768 60Hz

#3

帖子 dingamao » 2010-09-25 13:14

其实有一个很简单方法 nvdia 显卡设置里高级模式强行设置成1024*768,然后写入xconf. 再编辑xconf

把HorizSync 28.0 - 50.0 两行设置成你显示器支持的行频 重启x就可以了.
VertRefresh 43.0 - 78.0
xuchuangfa
帖子: 27
注册时间: 2010-02-12 10:52
送出感谢: 0
接收感谢: 0

Re: 请教如何设置xorg.conf文件支持1024*768 60Hz

#4

帖子 xuchuangfa » 2010-09-25 20:41

dingamao 写了:其实有一个很简单方法 nvdia 显卡设置里高级模式强行设置成1024*768,然后写入xconf. 再编辑xconf

把HorizSync 28.0 - 50.0 两行设置成你显示器支持的行频 重启x就可以了.
VertRefresh 43.0 - 78.0
不行的,我试过了,结果还是那样的结果。 :em06
happy!收到了ubuntu 9.04、9.10、10.04的光盘了,收藏...呵呵,收藏了不少了
头像
dingamao
帖子: 228
注册时间: 2006-01-05 10:50
送出感谢: 0
接收感谢: 0

Re: 请教如何设置xorg.conf文件支持1024*768 60Hz

#5

帖子 dingamao » 2010-09-25 20:46

楼上的,你操作有误啦,这是最简单的方法,不管在啥机器上,只要是nv的显卡就可以这样设置.
xuchuangfa
帖子: 27
注册时间: 2010-02-12 10:52
送出感谢: 0
接收感谢: 0

Re: 请教如何设置xorg.conf文件支持1024*768 60Hz

#6

帖子 xuchuangfa » 2010-09-26 9:06

dingamao 写了:楼上的,你操作有误啦,这是最简单的方法,不管在啥机器上,只要是nv的显卡就可以这样设置.
但是在我的机子上就是不行,有60HZ没有1024*768
happy!收到了ubuntu 9.04、9.10、10.04的光盘了,收藏...呵呵,收藏了不少了
回复

回到 “常用硬件支持”