声卡问题!有外音但是用耳机没声音

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
mtzheng1706
帖子: 3
注册时间: 2010-10-17 8:47
送出感谢: 0
接收感谢: 0

声卡问题!有外音但是用耳机没声音

#1

帖子 mtzheng1706 » 2010-10-27 17:36

声卡问题!有外音但是用耳机没声音,插入耳机的时候外音没有了
声卡型号:~$ lspci |grep -i audio
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
~$ sudo gedit /proc/asound/card0/codec#?
Codec: Conexant CX20549 (Venice)
Address: 0
Function Id: 0x2
Vendor Id: 0x14f15045
Subsystem Id: 0x152d0755
Revision Id: 0x100100
Modem Function Group: 0x2
Default PCM:
rates [0x140]: 48000 96000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Default Amp-In caps: N/A
Default Amp-Out caps: N/A
GPIO: io=0, o=0, i=0, unsolicited=0, wake=0
Node 0x10 [Pin Complex] wcaps 0x40058d: Stereo Amp-Out
Amp-Out caps: ofs=0x2b, nsteps=0x2b, stepsize=0x05, mute=1
Amp-Out vals: [0x2b 0x2b] [0x00 0x00]
Pincap 0x00010014: OUT EAPD Detect
EAPD 0x2: EAPD
Pin Default 0x961001f0: [Fixed] Speaker at Int Bottom
Conn = Unknown, Color = Unknown
DefAssociation = 0xf, Sequence = 0x0
Misc = NO_PRESENCE
Pin-ctls: 0x40: OUT
Unsolicited: tag=00, enabled=0
Power states: D0 D1 D2 D3
Power: setting=D0, actual=D0
Connection: 2
0x19 0x17*
Node 0x11 [Pin Complex] wcaps 0x40058d: Stereo Amp-Out
Amp-Out caps: ofs=0x2b, nsteps=0x2b, stepsize=0x05, mute=1
Amp-Out vals: [0x2b 0x2b] [0x00 0x00]
Pincap 0x0000113c: IN OUT HP Detect
Vref caps: HIZ 80
Pin Default 0x598001f1: [N/A] Line In at Int ATAPI
Conn = Unknown, Color = Unknown
DefAssociation = 0xf, Sequence = 0x1
Misc = NO_PRESENCE
Pin-ctls: 0xc0: OUT HP VREF_HIZ
Unsolicited: tag=37, enabled=1
Power states: D0 D1 D2 D3
Power: setting=D0, actual=D0
Connection: 2
0x19 0x17*
Node 0x12 [Pin Complex] wcaps 0x40058d: Stereo Amp-Out
Amp-Out caps: ofs=0x2b, nsteps=0x2b, stepsize=0x05, mute=1
Amp-Out vals: [0xab 0xab] [0x00 0x00]
Pincap 0x0000113c: IN OUT HP Detect
Vref caps: HIZ 80
Pin Default 0x02a1101e: [Jack] Mic at Ext Front
Conn = 1/8, Color = Black
DefAssociation = 0x1, Sequence = 0xe
Pin-ctls: 0x24: IN VREF_80
Unsolicited: tag=38, enabled=1
Power states: D0 D1 D2 D3
Power: setting=D0, actual=D0
Connection: 2
0x19* 0x17
Node 0x13 [Pin Complex] wcaps 0x400301: Stereo Digital
Pincap 0x00000010: OUT
Pin Default 0x024111f0: [Jack] SPDIF Out at Ext Front
Conn = 1/8, Color = Black
DefAssociation = 0xf, Sequence = 0x0
Misc = NO_PRESENCE
Pin-ctls: 0x40: OUT
Connection: 1
0x18
Node 0x14 [Pin Complex] wcaps 0x400081: Stereo
Pincap 0x00001124: IN Detect
Vref caps: HIZ 80
Pin Default 0x92a00110: [Fixed] Mic at Int Front
Conn = Unknown, Color = Unknown
DefAssociation = 0x1, Sequence = 0x0
Misc = NO_PRESENCE
Pin-ctls: 0x24: IN VREF_80
Unsolicited: tag=00, enabled=0
Node 0x15 [Pin Complex] wcaps 0x400001: Stereo
Pincap 0x00000020: IN
Pin Default 0x593300f0: [N/A] CD at Int ATAPI
Conn = ATAPI, Color = Unknown
DefAssociation = 0xf, Sequence = 0x0
Pin-ctls: 0x00:
Node 0x16 [Beep Generator Widget] wcaps 0x70000c: Mono Amp-Out
Amp-Out caps: ofs=0x07, nsteps=0x07, stepsize=0x0b, mute=1
Amp-Out vals: [0x06]
Node 0x17 [Audio Mixer] wcaps 0x20050b: Stereo Amp-In
Control: name="PCM Playback Volume", index=0, device=0
ControlAmp: chs=3, dir=In, idx=0, ofs=0
Control: name="PCM Playback Switch", index=0, device=0
ControlAmp: chs=3, dir=In, idx=0, ofs=0
Control: name="Int Mic Playback Volume", index=0, device=0
ControlAmp: chs=3, dir=In, idx=1, ofs=0
Control: name="Int Mic Playback Switch", index=0, device=0
ControlAmp: chs=3, dir=In, idx=1, ofs=0
Control: name="Ext Mic Playback Volume", index=0, device=0
ControlAmp: chs=3, dir=In, idx=2, ofs=0
Control: name="Ext Mic Playback Switch", index=0, device=0
ControlAmp: chs=3, dir=In, idx=2, ofs=0
Amp-In caps: ofs=0x14, nsteps=0x2b, stepsize=0x05, mute=1
Amp-In vals: [0x17 0x17] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80]
Power states: D0 D1 D2 D3
Power: setting=D0, actual=D0
Connection: 5
0x19 0x14 0x12 0x11 0x15
Node 0x18 [Audio Output] wcaps 0x211: Stereo Digital
Control: name="IEC958 Playback Con Mask", index=0, device=0
Control: name="IEC958 Playback Pro Mask", index=0, device=0
Control: name="IEC958 Playback Default", index=0, device=0
Control: name="IEC958 Playback Switch", index=0, device=0
Control: name="IEC958 Default PCM Playback Switch", index=0, device=0
Device: name="Conexant Digital", type="SPDIF", device=1
Converter: stream=0, channel=0
Digital:
Digital category: 0x0
PCM:
rates [0x40]: 48000
bits [0x6]: 16 20
formats [0x5]: PCM AC3
Node 0x19 [Audio Output] wcaps 0xc11: Stereo R/L
Device: name="CONEXANT Analog", type="Audio", device=0
Converter: stream=0, channel=0
PCM:
rates [0x540]: 48000 96000 192000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Power states: D0 D1 D2 D3
Power: setting=D0, actual=D0
Node 0x1a [Audio Input] wcaps 0x100d0b: Stereo Amp-In R/L
Control: name="Int Mic Capture Volume", index=0, device=0
ControlAmp: chs=3, dir=In, idx=1, ofs=0
Control: name="Int Mic Capture Switch", index=0, device=0
ControlAmp: chs=3, dir=In, idx=1, ofs=0
Control: name="Ext Mic Capture Volume", index=0, device=0
ControlAmp: chs=3, dir=In, idx=2, ofs=0
Control: name="Ext Mic Capture Switch", index=0, device=0
ControlAmp: chs=3, dir=In, idx=2, ofs=0
Device: name="CONEXANT Analog", type="Audio", device=0
Amp-In caps: ofs=0x00, nsteps=0x17, stepsize=0x05, mute=1
Amp-In vals: [0x17 0x17] [0x00 0x00] [0x00 0x00] [0x00 0x00] [0x00 0x00]
Converter: stream=0, channel=0
SDI-Select: 0
Power states: D0 D1 D2 D3
Power: setting=D0, actual=D0
Connection: 5
0x17 0x14* 0x12 0x11 0x15
Node 0x1b [Vendor Defined Widget] wcaps 0xf00000: Mono
mtzheng1706
帖子: 3
注册时间: 2010-10-17 8:47
送出感谢: 0
接收感谢: 0

Re: 声卡问题!有外音但是用耳机没声音

#2

帖子 mtzheng1706 » 2010-10-28 11:18

怎么没人回复呀,高手过来看看阿 :em20
rouijn
帖子: 6
注册时间: 2008-11-04 15:18
送出感谢: 0
接收感谢: 0

Re: 声卡问题!有外音但是用耳机没声音

#3

帖子 rouijn » 2010-10-30 11:23

同没有声音啊,求高手
xumeng
帖子: 2
注册时间: 2010-11-03 18:16
送出感谢: 0
接收感谢: 0

Re: 声卡问题!有外音但是用耳机没声音

#4

帖子 xumeng » 2010-11-03 18:21

viewtopic.php?f=42&t=301032

按此操作,祝你成功
yaoyao1220
帖子: 4
注册时间: 2010-08-09 9:52
送出感谢: 0
接收感谢: 0

Re: 声卡问题!有外音但是用耳机没声音

#5

帖子 yaoyao1220 » 2010-11-08 14:29

俺都看的头晕了。。。
Musoy
帖子: 12
注册时间: 2010-05-20 12:10
送出感谢: 0
接收感谢: 0

Re: 声卡问题!有外音但是用耳机没声音

#6

帖子 Musoy » 2010-11-08 21:55

回复

回到 “常用硬件支持”