我很纳闷,为什么同样的驱动同样的电影,ubuntu下面会卡但windows很流畅。

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
ctc88haha
帖子: 2
注册时间: 2010-06-04 21:08
送出感谢: 0
接收感谢: 0

我很纳闷,为什么同样的驱动同样的电影,ubuntu下面会卡但windows很流畅。

#1

帖子 ctc88haha » 2010-11-14 21:25

我想问下各位大大,我本本显卡是ati hd3470的,电脑上双系统,一个ubuntu10.10,一个windows7,但是,我一直很困扰。
为什么同样的1080p的电影,在windows下面解码很顺畅。在ubuntu下面就很卡,我起先一直怀疑是赔硬件解码,但是,我怎么查找教程,尝试了好多方法,但是问题依旧。之后我用vlc播放,默认开启硬件解码,而且貌似ati官网上说支持vlc最新版本硬件解码,但是效果没啥变化。
所以想问各位牛人,这是什么原因呢?有没有具体的解决方法呢。。。。
谢谢啦~
头像
tenzu
论坛版主
帖子: 36913
注册时间: 2008-11-21 20:26
送出感谢: 0
接收感谢: 21 次

Re: 我很纳闷,为什么同样的驱动同样的电影,ubuntu下面会卡但windows很流畅。

#2

帖子 tenzu » 2010-11-14 21:28

可能是显卡驱动的问题
ctc88haha
帖子: 2
注册时间: 2010-06-04 21:08
送出感谢: 0
接收感谢: 0

Re: 我很纳闷,为什么同样的驱动同样的电影,ubuntu下面会卡但windows很流畅。

#3

帖子 ctc88haha » 2010-11-14 21:32

ls的,我装的貌似是amd光放提供的驱动,系统是ubuntu 10.10 64位,,所以我很纳闷
头像
daf3707
论坛版主
帖子: 12673
注册时间: 2007-06-13 15:57
来自: 在他乡
送出感谢: 49 次
接收感谢: 85 次

Re: 我很纳闷,为什么同样的驱动同样的电影,ubuntu下面会卡但windows很流畅。

#4

帖子 daf3707 » 2010-11-14 21:51

即便是官方的驱动也有效率方面的差异
头像
jepen
帖子: 221
注册时间: 2010-06-14 1:08
送出感谢: 0
接收感谢: 3 次

Re: 我很纳闷,为什么同样的驱动同样的电影,ubuntu下面会卡但windows很流畅。

#5

帖子 jepen » 2010-11-22 19:06

系统环境不一样 , 驱动怎么可能一样 ,windows上的驱动要完善很多。 要问为什么,也许跟利益挂钩 !
我现在也用vlc 感觉问题比较少 那个h.264硬解 我真当他是试验的 没放心里去 :em01 (估计说的是在win下的实现的,没去了解)
我个人认为 CPU不是太弱的机子 看高清还是软解的好 不在乎那点占用 :em11
头像
luojie-dune
帖子: 22033
注册时间: 2007-07-30 18:28
系统: Linux
来自: 空气中
送出感谢: 9 次
接收感谢: 61 次

Re: 我很纳闷,为什么同样的驱动同样的电影,ubuntu下面会卡但windows很流畅。

#6

帖子 luojie-dune » 2010-11-22 19:28

ATi 一向是以跟着微软走为设计方案的。
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议
头像
acer4740
帖子: 1404
注册时间: 2010-09-13 19:04
来自: 0xFF00EE
送出感谢: 1 次
接收感谢: 3 次

Re: 我很纳闷,为什么同样的驱动同样的电影,ubuntu下面会卡但windows很流畅。

#7

帖子 acer4740 » 2010-11-22 19:52

和xorg的效率问题也有关
dongfanglu
帖子: 523
注册时间: 2007-12-13 23:34
送出感谢: 0
接收感谢: 0
联系:

Re: 我很纳闷,为什么同样的驱动同样的电影,ubuntu下面会卡但windows很流畅。

#8

帖子 dongfanglu » 2010-11-26 19:27

确实linux桌面就是感觉闭windows慢半拍
头像
jarryson
帖子: 4002
注册时间: 2005-08-14 19:53
送出感谢: 1 次
接收感谢: 2 次
联系:

Re: 我很纳闷,为什么同样的驱动同样的电影,ubuntu下面会卡但windows很流畅。

#9

帖子 jarryson » 2010-11-27 2:25

1080p软解也不会要求特别高。看看你的mplayer视频输出选的是不是xv,选x11不是原始尺寸播放就会需要靠cpu缩放,很占用cpu。显卡驱动是否安装好了
black
帖子: 169
注册时间: 2007-01-19 13:02
送出感谢: 0
接收感谢: 1 次

Re: 我很纳闷,为什么同样的驱动同样的电影,ubuntu下面会卡但windows很流畅。

#10

帖子 black » 2010-11-27 9:47

不用纳闷,99%是amd for linux 驱动的问题,amd linux驱动和win驱动比那可是一个在地下一个在天上,还有hd3xxx官方驱动视频输出,还是用gl吧,官方驱动没有xv加速的。还要把催化剂面板垂直刷新调到最高质量然后软解。硬解UVD+ 的hd3xxx还不在amd for linux支持范围内 :em09 :em09 。xvba支持的是UVD2 :em09 ,不过还是很多bug。
这些都是几年的问题了。如果chrome os 没有很大的反响的话,还是耐心等开源驱动支持硬解高清加速。
头像
jarryson
帖子: 4002
注册时间: 2005-08-14 19:53
送出感谢: 1 次
接收感谢: 2 次
联系:

Re: 我很纳闷,为什么同样的驱动同样的电影,ubuntu下面会卡但windows很流畅。

#11

帖子 jarryson » 2010-11-27 12:51

ls的确定吗?闭源驱动没有xv加速?这怎么可能

你确定驱动成功安装了?有xv输出是驱动正确安装的一个标志之一

xorg.0.log里面有UVD2字样就是说明有UVD2支持。
lijiwe24
帖子: 206
注册时间: 2010-07-27 9:44
送出感谢: 0
接收感谢: 0

Re: 我很纳闷,为什么同样的驱动同样的电影,ubuntu下面会卡但windows很流畅。

#12

帖子 lijiwe24 » 2010-11-27 13:35

vlc有部分解码器有很大问题,效率低下,用smplayer试试
ubuntu 10.10 + RedOffice + Firefox + thunderbird
black
帖子: 169
注册时间: 2007-01-19 13:02
送出感谢: 0
接收感谢: 1 次

Re: 我很纳闷,为什么同样的驱动同样的电影,ubuntu下面会卡但windows很流畅。

#13

帖子 black » 2010-11-27 15:10

jarryson 写了:ls的确定吗?闭源驱动没有xv加速?这怎么可能

你确定驱动成功安装了?有xv输出是驱动正确安装的一个标志之一

xorg.0.log里面有UVD2字样就是说明有UVD2支持。
xv加速问题"phoronix.com骂了n久了,官方驱动xv软解比开源驱动cpu会高些,我这里还会有画面撕裂。a卡用 vaapi推荐
For OpenGL rendering (specifically for the XvBA backend):
$ ./mplayer -vo vaapi:gl -va vaapi <URI>

uvd这里只是开个冷笑话,amd官方说xvba就是支持uvd2,虽然说有的uvd也说work的,hd4xxx以后才是硬件支持uvd2。
回复

回到 “常用硬件支持”