当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 怎么折腾就是没有声音!ubuntu
帖子发表于 : 2010-11-16 9:57 

注册: 2010-11-15 20:56
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
在win 7 下用wubi安装的,安装包是直接在官方网站下载的桌面版本!安装完成后就没有声音!

后来参考
“1、查看cat /proc/asound/version
ubuntu10.04版本的是:Advanced Linux Sound Architecture Driver Version 1.0.21

2、安装alsa模块:
sudo apt-get install build-essential linux-headers-$(uname -r) module-assistant alsa-source


3、使用speaker-test
speaker-test -Dplug:front -c2
提示错误:重播设备是plug:front
流参数是 48000Hz,S16_LE,2 频道
正使用朋克噪声16个8音度
重播打开错误: -16,设备或资源忙
重播打开错误: -16,设备或资源忙
重播打开错误: -16,设备或资源忙
重播打开错误: -16,设备或资源忙
重播打开错误: -16,设备或资源忙
重播打开错误: -16,设备或资源忙

呵呵,别急,看下面:

4、alsa测试5.1声道
speaker-test -Dplug:surround51 -c6 -twav


speaker-test -Dplug:front -c6 -twav


speaker-test -Dplug:dmix -c6 -twav

以上应该都测试正常。

最后,惊喜来了,重新测试“speaker-test -Dplug:front -c2“,保证测试正常,不会出现第一次出现的错误!然后重启系统。重启后你就会听到系统开机音乐了。信不信由你。

这里确实看不出什么添加或更改了什么文件,但是我确实是这么弄好的。信不信由你。


参考的这个,最后测试正常重启还是不行!

电脑硬件:I3 530 2G 技嘉到H55M-S2 显卡七彩虹9800GT 别的无关紧要来...

另外绝对没有静音,还有哪个帖子上说到把用户加到audio组,我怎么加不进去



页首
 用户资料  
 
2 楼 
 文章标题 : Re: 怎么折腾就是没有声音!ubuntu
帖子发表于 : 2010-11-16 10:29 
头像

注册: 2008-11-21 20:26
帖子: 36913
送出感谢: 1
接收感谢: 36
如果驱动没问题的话,alsamixer能打开么?PCM音量多大?


_________________
讨厌我的人可以试着点一下
浏览全部ubuntu技巧


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译