当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 13 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : ubuntu10.10无法屏蔽nouveau
帖子发表于 : 2010-12-03 19:55 

注册: 2010-12-02 20:21
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
如题,各种方法都不行(blacklist 、grub2),通过自带的安装nvidia-current,在启动界面停止。两个问题,怎么竟系统,怎么屏蔽nouveau :em20


页首
 用户资料  
 
2 楼 
 文章标题 : Re: ubuntu10.10无法屏蔽nouveau
帖子发表于 : 2010-12-06 9:41 

注册: 2009-05-31 0:44
帖子: 98
送出感谢: 0 次
接收感谢: 0 次
10.10貌似blacklist确实不行了,不过grub2是可以的....
我是换成nvidia-current了,不折腾了,话说nvidia-current也很顺滑~~~


_________________
一座城市,一片荒芜。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: ubuntu10.10无法屏蔽nouveau
帖子发表于 : 2010-12-14 15:07 

注册: 2010-12-02 20:21
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
老是提示nouveau in use,如何禁止内核加载nouveau?


页首
 用户资料  
 
4 楼 
 文章标题 : Re: ubuntu10.10无法屏蔽nouveau
帖子发表于 : 2010-12-14 15:16 

注册: 2009-01-27 2:40
帖子: 84
送出感谢: 0 次
接收感谢: 0 次
用官方驱动安装,将驱动拷到主文件夹,然后按Ctrl+Alt+F1退到终端并登录,sudo /etc/init.d/gdm stop,然后运行sudo sh ./Nv.......(驱动软件名),它会提示nouveau在使用,然后会问你是否建立一个文件来禁止nnouveau,选择Yes,一直点下去,会退出到终端界面,sudo reboot重新启动到GDM桌面,然后按Ctrl+Alt+F1退到终端,并登录,sudo /etc/init.d/gdm stop,退掉X桌面,再次运行sudo sh ./Nv.......(驱动软件名),就会正常安装驱动了,安装完sudo reboot,完成。

32位10.04,10.10安装官方NVIDIA-Linux-x86-260.19.21.run全部成功,并禁止掉nouveau


_________________
Mode:联想G450A-TSI(H)
CPU:Intel T6600
GPU:Nvidia G210M
MEM:8G(南亚易胜DDR3-1333 4GB*2)
Harddisk:Intel X25-M G2 120G
OS:Ubuntu 10.10(开启PAE)


页首
 用户资料  
 
5 楼 
 文章标题 : Re: ubuntu10.10无法屏蔽nouveau
帖子发表于 : 2010-12-20 16:47 

注册: 2010-12-02 20:21
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
还是无法禁止,应该是内核加载来nouveau,但是在10.10中不知道怎么禁止内核加载其他服务和程序。


页首
 用户资料  
 
6 楼 
 文章标题 : Re: ubuntu10.10无法屏蔽nouveau
帖子发表于 : 2010-12-23 11:30 

注册: 2009-09-06 10:24
帖子: 24
送出感谢: 0 次
接收感谢: 0 次
在grub.cfg的linux参数上加nouveau.modeset=0


页首
 用户资料  
 
7 楼 
 文章标题 : Re: ubuntu10.10无法屏蔽nouveau
帖子发表于 : 2010-12-23 11:37 
头像

注册: 2010-09-13 19:04
帖子: 1404
地址: 0xFF00EE
送出感谢: 1
接收感谢: 3
stardreamsx 写道:
用官方驱动安装,将驱动拷到主文件夹,然后按Ctrl+Alt+F1退到终端并登录,sudo /etc/init.d/gdm stop,然后运行sudo sh ./Nv.......(驱动软件名),它会提示nouveau在使用,然后会问你是否建立一个文件来禁止nnouveau,选择Yes,一直点下去,会退出到终端界面,sudo reboot重新启动到GDM桌面,然后按Ctrl+Alt+F1退到终端,并登录,sudo /etc/init.d/gdm stop,退掉X桌面,再次运行sudo sh ./Nv.......(驱动软件名),就会正常安装驱动了,安装完sudo reboot,完成。

32位10.04,10.10安装官方NVIDIA-Linux-x86-260.19.21.run全部成功,并禁止掉nouveau


4楼是正确的我的mandriva也是这样安装成功的


_________________
qq旋风离线空间下载程序
漂亮的fcitx皮肤
Fcitx皮肤合集


页首
 用户资料  
 
8 楼 
 文章标题 : Re: ubuntu10.10无法屏蔽nouveau
帖子发表于 : 2010-12-24 10:30 

注册: 2010-12-02 20:21
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
我的照这个方法还是不行,我用喀纳斯中文定制版10.10,应该修改的不是太多吧。


页首
 用户资料  
 
9 楼 
 文章标题 : Re: ubuntu10.10无法屏蔽nouveau
帖子发表于 : 2010-12-24 10:53 
头像

注册: 2010-09-13 19:04
帖子: 1404
地址: 0xFF00EE
送出感谢: 1
接收感谢: 3
我看了一下是生成乐下面的文件:

/etc/modprobe.d/nvidia-installer-disable-nouveau.conf

代码:
# generated by nvidia-installer
blacklist nouveau
options nouveau modeset=0


这样就能屏蔽nouveau了


_________________
qq旋风离线空间下载程序
漂亮的fcitx皮肤
Fcitx皮肤合集


页首
 用户资料  
 
10 楼 
 文章标题 : Re: ubuntu10.10无法屏蔽nouveau
帖子发表于 : 2010-12-31 8:40 

注册: 2010-12-02 20:21
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
/etc/modprobe.d/nvidia-installer-disable-nouveau.conf
已经生成,但是还是加载nouveau,应该是内核加载没有禁用


页首
 用户资料  
 
11 楼 
 文章标题 : Re: ubuntu10.10无法屏蔽nouveau
帖子发表于 : 2011-02-09 23:53 

注册: 2010-11-06 20:33
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
按照4楼的方式生成"/etc/modprobe.d/nvidia-installer-disable-nouveau.conf"文件并reboot后依然无法屏蔽nouveau。安装驱动时还是显示:please correctly disable the Nouveau kernel driver.....If you have rebooted, then Nouveau may be enable for other reasons.
有哪位大侠知道这个 "other reasons" 吗?????

我事后一发飙,直接卸载:xserver-xorg-video-nouveau 都不能阻止这个该死的nouveau启动阿。。。。 :em20
难道从此10.10以及之后的版本都不能安装官方驱动了吗?? :em06


页首
 用户资料  
 
12 楼 
 文章标题 : Re: ubuntu10.10无法屏蔽nouveau
帖子发表于 : 2011-02-28 17:10 

注册: 2008-09-18 0:06
帖子: 25
送出感谢: 0 次
接收感谢: 0 次
ubuntu 10.10 64bit 我装 260.19.36 的时候,是安装程序问我是否要屏蔽 NOUVEAU 我选择是,重新启动再安装就可以了。


页首
 用户资料  
 
13 楼 
 文章标题 : Re: ubuntu10.10无法屏蔽nouveau
帖子发表于 : 2011-06-27 23:38 
头像

注册: 2010-12-28 19:12
帖子: 128
地址: Nanjing, Jiangsu, China
送出感谢: 1
接收感谢: 2
生成"/etc/modprobe.d/nvidia-installer-disable-nouveau.conf"文件后,要运行
代码:
update-initramfs

代码:
update-grub

:em11


_________________
# whoami
古风派;Linux爱好者;吟风弄月者;爱装可爱者;Geek;应试教育的受害者。

# cat /etc/issue
本人一般每周六才能玩电脑,所以平时会偷偷地用那台“云媒体电视”上论坛,不过操作很麻烦,就一个遥控器。有时无法换行,无法发表情&正常使用BBCode;浏览器很破,相当于Firefox<3.0,不支持Javascript等……(>_<)……So, 如果本人发的文字出现了格式错误,请多多包涵。谢啦~


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 13 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译