ubuntu10.10前置耳机没有声音

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
scorpiopapa
帖子: 7
注册时间: 2010-10-24 22:49
送出感谢: 0
接收感谢: 0

ubuntu10.10前置耳机没有声音

#1

帖子 scorpiopapa » 2010-12-28 21:12

各位前辈来看看啊,这几天郁闷死我了。

我电脑是今年在电子城配的兼容机,装完ubuntu10.10后,音箱有声音,耳机怎么都没有声音。
我的是华硕主板,集成声卡。
第一次装ubuntu的事后前后音频输出都有声音,后来又重装了两次,前边的耳机插口就没声了,杯具啊~~
在声音里边设置
这是我的声卡配置Analog Headphones后,机箱没声了,耳机也没声。
运行alsamixer命令,发现Headphone一项声音放到最大也没有用,另外我发现还有一项Front一直是MM状态,调成最大也没用。另外还有一项是Smart5.1,也是MM,不能调,不知道干啥的。
我的声卡是VIA VT1708S,看了不少帖子,可是我的声卡在HD-Audio-Models.txt里找不到对应的模块名字啊,太杯具了~~
如下
/usr/share/doc/alsa-base/driver$ zless HD-Audio-Models.txt.gz | grep VT
什么都查不到

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: VT1708S Analog [VT1708S Analog]
Subdevices: 2/2
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1

加载的模块
lsmod | grep snd
snd_hda_codec_via 51755 1
snd_hda_intel 22203 2
snd_hda_codec 87552 2 snd_hda_codec_via,snd_hda_intel
snd_hwdep 5040 1 snd_hda_codec
snd_pcm 71603 2 snd_hda_intel,snd_hda_codec
snd_seq_midi 4588 0
snd_rawmidi 17783 1 snd_seq_midi
snd_seq_midi_event 6047 1 snd_seq_midi
snd_seq 47174 2 snd_seq_midi,snd_seq_midi_event
snd_timer 19067 2 snd_pcm,snd_seq
snd_seq_device 5744 3 snd_seq_midi,snd_rawmidi,snd_seq
snd 49038 13 snd_hda_codec_via,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_p

各位大虾帮我看看啊,感激不尽
wxg4net
帖子: 82
注册时间: 2011-03-01 16:07
送出感谢: 2 次
接收感谢: 4 次

Re: ubuntu10.10前置耳机没有声音

#2

帖子 wxg4net » 2011-05-17 23:58

遇到类似问题!
scorpiopapa
帖子: 7
注册时间: 2010-10-24 22:49
送出感谢: 0
接收感谢: 0

Re: ubuntu10.10前置耳机没有声音

#3

帖子 scorpiopapa » 2011-06-05 22:38

终于解决了!在主板设置中把前置面板声音由HD Audio 改成AC97.
不过耳机和音箱同时发声,不过这个问题可以忽略啦
kivenjustin
帖子: 7
注册时间: 2007-12-29 2:35
送出感谢: 0
接收感谢: 0

Re: ubuntu10.10前置耳机没有声音

#4

帖子 kivenjustin » 2012-02-11 18:17

哈哈!楼上正解!ubuntu11.10版的zless /usr/share/doc/alsa-base/driver/HD-Audio-Models.txt.gz的最后一行能查到VIA VT1708S的,但是只有一个auto :em06
还是得在主板bios里改!前面板就有声了!折腾了许久的问题终于搞定,感谢lz!
CcHsiao
帖子: 2
注册时间: 2011-11-30 15:14
送出感谢: 0
接收感谢: 0

Re: ubuntu10.10前置耳机没有声音

#5

帖子 CcHsiao » 2012-03-09 16:15

这个问题好像非常普遍,解决方法,sound settings -> output -> Connector,改为Analog Speakers。Analog Headphones 没有声音,原因不详……
回复

回到 “常用硬件支持”