当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 105 篇帖子 ]  前往页数 1, 2, 3, 4, 5 ... 7  下一页
作者 内容
1 楼 
 文章标题 : [转帖] VIA/S3G UniChrome Pro IGP显卡驱动总结(给各位被集成显卡闪烁的眼泪直流的兄弟们)
帖子发表于 : 2006-11-13 18:45 

注册: 2006-11-04 13:49
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
内容如下,我在我的ubuntu下测试成功,不过屏幕有点被拉升了。
原文连接:
http://www.linux-ren.org/modules/newbb/ ... 56fa47eb41

=======================================

废话就不说了,切入正题。VIA K8M800系列 VIA/S3G UniChrome Pro IGP显卡驱动安装有以下几种途径:

1、威盛官方源驱动,下载:http://www.viaarena.com/Driver/linux-fbdev-kernel-src_20050726.tgz
在Eeverest0.2中试过了无法编译,真可惜。

2、威盛官方K8M890的BIN驱动,cjacker向Via要的。下载:http://mirror1.linux-ren.org/pub/everest/K8M890CEXF40073.rar
优点:安装方便。
缺点:没有3D加速,显示不如vesa清晰。
安装步骤:解压后运行K8M890CEXF40073.run;编辑/usr/share/config/kdm/kdmrc中有-dpi 96一行,加上-ignoreABI;重启kdm。
如果要命令行运行X测试,记得加上-ignoreABI参数。

3、sf.net上的xf86-video-unichrome开源驱动,下载:http://unichrome.sourceforge.net/
优点:有3D加速。
缺点:显示较白、较模糊,非威盛官方。
安装步骤:正常编译安装(略),复制/usr/local/lib/xorg/modules/drivers/via*.*至/usr/lib/xorg/modules/drivers。

4、openchrome.org的unichrome驱动,我现在用的就是这个,下载:svn co http://svn.openchrome.org/svn/trunk openchrome
优点:有3D加速。
缺点:非威盛官方。

安装步骤:
1)openchrome官方步骤:
svn co http://svn.openchrome.org/svn/trunk openchrome
cd openchrome
./autogen.sh
configure
make
make install

2)复制/usr/local/lib/xorg/modules/drivers/via*.*至/usr/lib/xorg/modules/drivers,复制/usr/local/lib/libvia*.*到/usr/lib。

3) 安装DRM(Direct Rendering Manager):
cvs -z3 -d:pserver:anonymous@dri.freedesktop.org:/cvs/dri login
#(密码为空,直接回车)
cvs -z3 -d:pserver:anonymous@dri.freedesktop.org:/cvs/dri co drm
#安装libdrm
cd drm
./autogen.sh
make
make install
#安装 kernel module
cd linux-core
make LINUXDIR=/lib/modules/`uname -r`/build DRM_MODULES=via
cp *.ko /lib/modules/`uname -r`/kernel/drivers/char/drm/
depmod -ae


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-11-13 19:01 

注册: 2006-11-04 13:49
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
忘了提醒大家,上面的安装方法需要一些库的支持,具体那些我也不适很清楚,不过可以去上面提到的网站上面找到,基本上需要工具如下:
subversion build-essential automake1.9 libtool pkg-config xserver-xorg-dev libxvmc-dev
x11proto-gl-dev libglu1-mesa-dev x11proto-core-dev libxvmc-dev xserver-xorg-dev x11proto-gl-dev libgl1-mesa-dev cvs

还有一些欠缺的我也不怎么清楚了,应该主要是xserver-xorg-×××


页首
 用户资料  
 
3 楼 
 文章标题 : km400
帖子发表于 : 2006-11-23 23:51 
头像

注册: 2006-04-18 21:08
帖子: 119
送出感谢: 0 次
接收感谢: 0 次
yang@super:~$ glxgears
libGL warning: 3D driver claims to not support visual 0x46
是什么问题?


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-11-25 9:04 

注册: 2006-11-12 9:39
帖子: 82
地址: 湖南祁阳
送出感谢: 0 次
接收感谢: 0 次
看的好累,真的不明白,K8M800和你的890有区别吗,一样可以装?


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-11-25 9:08 

注册: 2006-11-12 9:39
帖子: 82
地址: 湖南祁阳
送出感谢: 0 次
接收感谢: 0 次
官方发布的页面好像没有支持UBUNTU的哟,版本不对吧~


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-12-04 9:27 

注册: 2006-11-04 13:49
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
很久没有过来看,非常抱歉,没注意到各位的问题。
以上说的是4种不同的方法,不过我本人是按照第4种方法来安装的,其实可以去上面提到的主页看看。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-12-05 11:47 

注册: 2006-11-12 9:39
帖子: 82
地址: 湖南祁阳
送出感谢: 0 次
接收感谢: 0 次
好像我从6。06直接升级过来到6。10,现在3D也有了哟,本来没有的,呵,有3D加速也没什么的呀,集成显卡,难道还能装3D桌面?感觉6。10识别能力强点,速度快了不少~


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-12-07 12:51 
头像

注册: 2006-11-21 21:25
帖子: 424
送出感谢: 0 次
接收感谢: 0 次
我试了第四种方法,不行。只好强迫自己在60Hz的刷新率下了。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2006-12-07 17:43 
头像

注册: 2006-11-21 21:25
帖子: 424
送出感谢: 0 次
接收感谢: 0 次
想问一下,为什么我输入svn co http://svn.openchrome.org/svn/trunk openchrome后回车会出现
bash: svn: command not found的提示?我该怎么办?svn又是什么意思?


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2006-12-07 17:48 
头像

注册: 2005-06-11 14:03
帖子: 6226
地址: 不明真相的群众
送出感谢: 0 次
接收感谢: 0 次
说明你没有安装svn

sudo apt-get install subversion


_________________
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2006-12-07 18:31 
头像

注册: 2006-11-21 21:25
帖子: 424
送出感谢: 0 次
接收感谢: 0 次
刚刚安装了svn服务后,前几句命令可以执行了,可是到了这一句./autogen.sh又不行了,提示./autogen.sh: 9: autoreconf: not found
又是怎么回事啊?


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2006-12-07 22:15 
头像

注册: 2006-11-21 21:25
帖子: 424
送出感谢: 0 次
接收感谢: 0 次
现在我一步步进行到了configure这一步了,可是出现以下提示
checking for XORG... configure: error: Package requirements (xorg-server xproto xvmc fontsproto libdrm randrproto renderproto xextproto x11 xextproto videoproto) were not met:

No package 'randrproto' found
No package 'renderproto' found

这两个randrproto和renderproto在立新得软件包管理器里面找不到啊,怎么办啊


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2006-12-08 11:42 
头像

注册: 2006-11-21 21:25
帖子: 424
送出感谢: 0 次
接收感谢: 0 次
真的非常非常感谢这个帖子和以上帮助我的人,我终于把显卡驱动安装成功了,并把屏幕调到1024*768*85了。为了屏幕刷新率的问题,我差点要放弃ubuntu了。


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2006-12-09 15:50 
头像

注册: 2006-11-21 21:25
帖子: 424
送出感谢: 0 次
接收感谢: 0 次
我装好这个显卡驱动后,用dpkg-reconfigure xserver-xorg将vesa改为via后,屏幕再也不闪了,但是多了一个问题:我在播放一些视频文件时,会出现花屏(仅仅指播放器的画面,显示器显示正常),比如Examples目录下的Experience ubuntu.ogg视频文件(就是那段说明ubuntu精神涵义的视频),但我在装完驱动后还没把vesa改成via时,这段视频可以正常播放的(我特意做了测试的),还有一些其它的视频文件也会出现“花屏”,即使安装了相应的解码器也是这样。
但并不是所有的视频文件都这样,有的还是可以正常播放的,比如我播放魔兽争霸的过场动画(类型为mpq,安装了相应的解码器)。
我怀疑这和该显卡驱动有关,请问楼主有这样的问题吗?


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2006-12-10 14:35 
头像

注册: 2006-11-21 21:25
帖子: 424
送出感谢: 0 次
接收感谢: 0 次
现在装了xine及w32codecs还有xine的codec之后,可以用xine正常播放.ogg这段视频了,但GStreamer还是不行,不知道为什么?不管了,反正可以用xine就行了。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 105 篇帖子 ]  前往页数 1, 2, 3, 4, 5 ... 7  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译