求助;笔记本电脑耳机没有声音。。

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
nipingfu
帖子: 3
注册时间: 2009-01-08 16:10
送出感谢: 0
接收感谢: 0

求助;笔记本电脑耳机没有声音。。

#1

帖子 nipingfu » 2011-01-10 20:19

安装好系统,有声音,就是耳机没有,声卡是HD INTEL的芯片。参照晚上的做法都试了,但是还是不行,
现在想问如果升级到11.4 或者降到10.4能否解决这个问题?在windows下声卡的驱动conexant cx20671 smart audio HD
联想G460的笔记本
liong333
帖子: 11
注册时间: 2009-02-16 11:11
送出感谢: 0
接收感谢: 0

Re: 求助;笔记本电脑耳机没有声音。。

#2

帖子 liong333 » 2011-01-10 23:45

太晕了,我是耳机有声音,笔记本的喇叭没有声音。。。。换到win7都是正常的,救命啊~华硕K42JC,还有UBUNTU里面触摸板不知怎么关闭,声音和亮度又可以用FN功能关闭,好郁闷,如果UBUNTU能解决这些问题就好了,以后都不用WINDOWS
nipingfu
帖子: 3
注册时间: 2009-01-08 16:10
送出感谢: 0
接收感谢: 0

Re: 求助;笔记本电脑耳机没有声音。。

#3

帖子 nipingfu » 2011-01-11 19:00

ubuntu 本本的触摸屏关闭

默认分类 2010-12-05 00:04:40 阅读30 评论0 字号:大中小 订阅
代码:
sudo gedit ~/psmouse


复制以下内容:
代码:
#/bin/sh
echo "==================================="
echo "============触摸板管理程序============"
echo "====sudo modprobe -r psmouse======="
echo "==== sudo modprobe psmouse ========"
echo "=============Author:Changhe========"
echo "=====E-mail:xuwu125@gmail.com======"
echo "==================================="
# 如果要加为开机启动则把下面两行前面的#号去掉
#sudo modprobe -r psmouse
#echo "触摸板已经关闭"
while [ "$yn" != "x" ]
do
read -p "是否开启触摸板?(开启/关闭/退出)(y/n/x):" yn
echo "你输入的参数为:$yn"
if [ "$yn" = "y" ] || [ "$yn" = "Y" ]
then
echo "你选择了开启触摸板"
sudo modprobe psmouse
echo "触摸板已经开启"
elif [ "$yn" = "n" ] || [ "$yn" = "N" ]
then
echo "你选择了关闭"
sudo modprobe -r psmouse
echo "触摸板已经关闭"
else
if [ "$yn" = "x" ]
then
echo "程序退出,祝使用愉快!"
else
echo "无效参数退出"
fi
exit
fi
done

加载执行权限,该文件一定要有ROOT权限。
代码:
sudo chmod +x ~/psmouse

然后执行它:
代码:
sudo sh ~/psmouse


根据提示来操作就可以了,如果需要每次开机就关掉的话,就把第10行和11行前面的#号去掉,然后把文件复制到
/etc/init.d/ 下面,让UBUNTU每次开机就执行。
到次结束,我附上我写的文件。
执行效果如下:
代码:
$ sudo sh psmouse
[sudo] password for xuwu:
===================================
============触摸板管理程序============
====sudo modprobe -r psmouse=======
==== sudo modprobe psmouse ========
=============Author:Changhe========
=====E-mail:xuwu125@gmail.com======
===================================
是否开启触摸板?(开启/关闭/退出)(y/n/x):y
你输入的参数为:y
你选择了开启触摸板
触摸板已经开启
是否开启触摸板?(开启/关闭/退出)(y/n/x):n
你输入的参数为:n
你选择了关闭
x触摸板已经关闭
是否开启触摸板?(开启/关闭/退出)(y/n/x):
你输入的参数为:x
程序退出,祝使用愉快!
tang1949
帖子: 104
注册时间: 2009-03-19 11:51
送出感谢: 0
接收感谢: 2 次

Re: 求助;笔记本电脑耳机没有声音。。

#4

帖子 tang1949 » 2011-01-12 15:06

楼主,你插上耳机,重新启动。是不是变为耳机响,喇叭不响了?
liong333
帖子: 11
注册时间: 2009-02-16 11:11
送出感谢: 0
接收感谢: 0

Re: 求助;笔记本电脑耳机没有声音。。

#5

帖子 liong333 » 2011-01-20 15:28

tang1949 写了:楼主,你插上耳机,重新启动。是不是变为耳机响,喇叭不响了?
这个没注意,反正喇叭一直是没有响的,插上耳机才能听到声音
liong333
帖子: 11
注册时间: 2009-02-16 11:11
送出感谢: 0
接收感谢: 0

Re: 求助;笔记本电脑耳机没有声音。。

#6

帖子 liong333 » 2011-01-20 15:32

nipingfu 写了:ubuntu 本本的触摸屏关闭

默认分类 2010-12-05 00:04:40 阅读30 评论0 字号:大中小 订阅
代码:
sudo gedit ~/psmouse


复制以下内容:
代码:
#/bin/sh
echo "==================================="
echo "============触摸板管理程序============"
echo "====sudo modprobe -r psmouse======="
echo "==== sudo modprobe psmouse ========"
echo "=============Author:Changhe========"
echo "=====E-mail:xuwu125@gmail.com======"
echo "==================================="
# 如果要加为开机启动则把下面两行前面的#号去掉
#sudo modprobe -r psmouse
#echo "触摸板已经关闭"
while [ "$yn" != "x" ]
do
read -p "是否开启触摸板?(开启/关闭/退出)(y/n/x):" yn
echo "你输入的参数为:$yn"
if [ "$yn" = "y" ] || [ "$yn" = "Y" ]
then
echo "你选择了开启触摸板"
sudo modprobe psmouse
echo "触摸板已经开启"
elif [ "$yn" = "n" ] || [ "$yn" = "N" ]
then
echo "你选择了关闭"
sudo modprobe -r psmouse
echo "触摸板已经关闭"
else
if [ "$yn" = "x" ]
then
echo "程序退出,祝使用愉快!"
else
echo "无效参数退出"
fi
exit
fi
done

加载执行权限,该文件一定要有ROOT权限。
代码:
sudo chmod +x ~/psmouse

然后执行它:
代码:
sudo sh ~/psmouse


根据提示来操作就可以了,如果需要每次开机就关掉的话,就把第10行和11行前面的#号去掉,然后把文件复制到
/etc/init.d/ 下面,让UBUNTU每次开机就执行。
到次结束,我附上我写的文件。
执行效果如下:
代码:
$ sudo sh psmouse
[sudo] password for xuwu:
===================================
============触摸板管理程序============
====sudo modprobe -r psmouse=======
==== sudo modprobe psmouse ========
=============Author:Changhe========
=====E-mail:xuwu125@gmail.com======
===================================
是否开启触摸板?(开启/关闭/退出)(y/n/x):y
你输入的参数为:y
你选择了开启触摸板
触摸板已经开启
是否开启触摸板?(开启/关闭/退出)(y/n/x):n
你输入的参数为:n
你选择了关闭
x触摸板已经关闭
是否开启触摸板?(开启/关闭/退出)(y/n/x):
你输入的参数为:x
程序退出,祝使用愉快!
谢谢!但是我最关心的是笔记本喇叭的声音,没声音就不想用UBUNTU了,太没意思了啊,我现在都很久没用UBUNTU了,等有解决方法的时候再看看吧
头像
iceblue_sky
帖子: 9
注册时间: 2009-09-07 15:44
送出感谢: 0
接收感谢: 0

Re: 求助;笔记本电脑耳机没有声音。。

#7

帖子 iceblue_sky » 2011-01-22 2:13

我的ideapad也是这个问题哦,下面这篇文章的解决办法可行,希望你试试看, :em01
http://www.yeezi.org/2011/01/solve-snd- ... oblem.html
头像
xc1427
帖子: 276
注册时间: 2008-10-11 4:11
来自: 瑞金无线电学校
送出感谢: 0
接收感谢: 0
联系:

Re: 求助;笔记本电脑耳机没有声音。。

#8

帖子 xc1427 » 2011-01-23 23:27

liong333 写了:太晕了,我是耳机有声音,笔记本的喇叭没有声音。。。。换到win7都是正常的,救命啊~华硕K42JC,还有UBUNTU里面触摸板不知怎么关闭,声音和亮度又可以用FN功能关闭,好郁闷,如果UBUNTU能解决这些问题就好了,以后都不用WINDOWS
Hey! Second floor fellow! I have the same no-sound-problem with you(华硕, 耳机有声音,笔记本的喇叭没有声音). And finally I got the problem solved. Another similar post is viewtopic.php?f=42&t=309174.

I promise you there is nothing complicated in my solution. I cannot type Chinese and sorry for my poor English.

I install Ubuntu 10.04 i386 on my notebook. This notebook is also a ASUS, but A42J series. It is equipped with 2 sound cards. Here you can see:

代码: 全选

xc1427@xc1427-laptop$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 3: ATI HDMI [ATI HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
And the alsa version is 1.0.21.That is, the original version in Ubuntu. I didn't update it. Here you can see:

代码: 全选

xc1427@xc1427-laptop:/proc/asound$ cat version
Advanced Linux Sound Architecture Driver Version 1.0.21.


Here is the solution:
I. Go to System -> References -> Sound. Under the label "Hardware", you find your 2 sound cards.
sound preferences.png
Choose the first one "Internal Audio". (The second one is rather helpless, as far as I can tell you. Don't try to configure it.)

Below it, you find "Settings for the selected device". Here you can select a profile (configuration) for the last chose device. On my ubuntu, I have the following options:
  • Off
    Analog Stereo Input
    Analog Surround 4.0 Output
    Analog Surround 4.0 Output + Analog Stereo Input
    Analog Stereo Output
    Analog Stereo Duplex
Choose either "Analog Surround 4.0 Output + Analog Stereo Input" or "Analog Stereo Duplex".
"Analog Surround 4.0 Output" and "Analog Stereo Output" are also OK, however, you will not get any Input devices by choosing these two.

Right now go to "Output" label. BE SURE to choose "Internal Audio Analog Stereo".
Output label.png
In the "Connector" area, BE SURE to choose "Analog Speakers", otherwise we may have only the earphone working, but not the speaker, just like user "liong333".



2. Right now you may have all your sound devices working. If so, congratulation. If not, continue with me.

Open your alsamixer, (In terminal, type "alsamixer"):
alsamixer.png
You should be able to see that "00" or "MM" at the bottom of some columns. "00" means "Not Mute". So it is OK. But "MM" means "Mute". SO BE SURE to change it to "00" by pressing "<" and ">" on your keyboard. Press "up" and "down" on your keyboard to adjust volume. I suggest you get it maximum.

3. It is possible that your sound card still cannot work correctly. You can try modifying the BIOS settings related to sound. I enable the post sound, while refering to this http://blogold.chinaunix.net/u2/72485/s ... id=2354042

4. By the above 3 steps, I got both my earphone and speaker working perfectly. Actually, I am annoyed by this problem for longtime. I have searched in Baidu Google and this forum for any possible solutions.

I have also tried some other complicated approaches. e.g., Install alsa drive 1.0.23.
I tried work around in viewtopic.php?f=42&t=269230 and http://forum.ubuntu-fr.org/viewtopic.php?id=391377But it makes things worse....(I reinstalled Ubuntu..).

If my solution doesn't work on you, you can try a new verion alsa drive, as it really solve the problem on some other people. But you should be very careful as it makes changes to your linux kernel. Once you update it. it is hard to roll back.

5. Other work-around:
viewtopic.php?f=42&t=90653 this may be helpful, in spite of being an old case.
http://blog.ubuntu.org.cn/~uqzcpo/conte ... 8%E3%80%82 Adding "options snd-hda-intel model=xxx" can be a good attempt, whenever you find you sound card model in the file "HD-Audio-Models.txt".
You never know if you don't try
duolon
帖子: 55
注册时间: 2008-11-10 19:12
送出感谢: 0
接收感谢: 3 次

Re: 求助;笔记本电脑耳机没有声音。。

#9

帖子 duolon » 2011-02-01 16:16

liong333 写了:太晕了,我是耳机有声音,笔记本的喇叭没有声音。。。。换到win7都是正常的,救命啊~华硕K42JC,还有UBUNTU里面触摸板不知怎么关闭,声音和亮度又可以用FN功能关闭,好郁闷,如果UBUNTU能解决这些问题就好了,以后都不用WINDOWS
我K52D目前一切正常,各种问题的解决办法点我签名 :em04
回复

回到 “常用硬件支持”