Ubuntu10.10无法识别u盘

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
windyvictor
帖子: 123
注册时间: 2010-08-22 20:59
送出感谢: 0
接收感谢: 0

Ubuntu10.10无法识别u盘

#1

帖子 windyvictor » 2011-01-21 10:06

我有个512m的u盘,win下可以正常识别,Ubuntu10.10下插入电脑没有任何反应,插其他的u盘,移动硬盘都正常,不知道怎么回事?
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

Re: Ubuntu10.10无法识别u盘

#2

帖子 eexpress » 2011-01-21 10:17

lsusb
或者
dmesg -tail

看下。

win下,喜欢搞阉割盘,伪造假冒容量盘,等。
● 鸣学
windyvictor
帖子: 123
注册时间: 2010-08-22 20:59
送出感谢: 0
接收感谢: 0

Re: Ubuntu10.10无法识别u盘

#3

帖子 windyvictor » 2011-01-21 11:15

lsusb后是下面的信息
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 002: ID 03f0:171d Hewlett-Packard Wireless (Bluetooth + WLAN) Interface [Integrated Module]
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 5986:0137 Acer, Inc
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
不懂何意啊!
头像
0xff
帖子: 415
注册时间: 2008-08-12 14:24
送出感谢: 2 次
接收感谢: 0
联系:

Re: Ubuntu10.10无法识别u盘

#4

帖子 0xff » 2011-01-25 12:50

sudo fdisk -l

看看最后列出你的U盘没
windyvictor
帖子: 123
注册时间: 2010-08-22 20:59
送出感谢: 0
接收感谢: 0

Re: Ubuntu10.10无法识别u盘

#5

帖子 windyvictor » 2011-01-26 10:37

看了一下,没有列出,又该怎么办呢?
8500
帖子: 1
注册时间: 2010-07-30 20:18
送出感谢: 0
接收感谢: 0

Re: Ubuntu10.10无法识别u盘

#6

帖子 8500 » 2011-01-27 22:21

我的Ubuntu10.04 LTS 有这个问题还不知道怎么办
8GB的金邦U盘接到 PC上没反应 lsusb后没发现设备
在 windowsXP下使用正常
双系统


在另外一台PC上 Ubuntu10.10系统下 有时可以识别.有时不行 windowsXP下使用正常
Konoha_M
帖子: 11
注册时间: 2010-12-07 20:31
送出感谢: 0
接收感谢: 0

Re: Ubuntu10.10无法识别u盘

#7

帖子 Konoha_M » 2011-02-12 18:04

我有同样的问题,我是在lsusb中可以找到我的U盘:

代码: 全选

Bus 002 Device 017: ID 13fe:3800 Kingston Technology Company Inc.  //Here!!
Bus 002 Device 007: ID 093a:2510 Pixart Imaging, Inc. Optical Mouse
Bus 002 Device 005: ID 04f2:b098 Chicony Electronics Co., Ltd 
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0bda:0138 Realtek Semiconductor Corp. 
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
但是fdisk -l的时候就一直卡在扫描过程那里,列表中也没有U盘的分区信息,但是一拔出U盘马上就好了,同求解决方案~
玄原
帖子: 92
注册时间: 2007-12-16 21:59
送出感谢: 0
接收感谢: 0

Re: Ubuntu10.10无法识别u盘

#8

帖子 玄原 » 2011-06-04 20:08

我也有一样的问题:
sudo lsusb

Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

sudo dmesg
[ 1043.648797] cfg80211: Current regulatory domain updated by AP to: CN
[ 1043.648802] (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 1043.648810] (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[ 1054.440088] wlan0: no IPv6 routers present
[ 1078.501064] No probe response from AP 00:23:cd:33:b9:44 after 500ms, disconnecting.
[ 1080.303349] wlan0: direct probe to AP 00:23:cd:33:b9:44 (try 1)
[ 1080.305924] wlan0: direct probe responded
[ 1080.305933] wlan0: authenticate with AP 00:23:cd:33:b9:44 (try 1)
[ 1080.307765] wlan0: authenticated
[ 1080.307810] wlan0: associate with AP 00:23:cd:33:b9:44 (try 1)
[ 1080.310085] wlan0: RX AssocResp from 00:23:cd:33:b9:44 (capab=0x431 status=0 aid=2)
[ 1080.310093] wlan0: associated


fdisk -l 没有列出我的设备 !


==========================
我怀疑这是一个BUG,因为之前都是没有问题的,后来我全部删除了compiz之后就出现了这个问题..... 说不定是什么东东被删除了,或者什么东东没有运行造成的问题
头像
iamfbi
帖子: 1081
注册时间: 2009-02-06 9:18
来自: 小僧乃吐蕃国大雪山大轮寺护国法师座下四大护法之西域妖僧是也
送出感谢: 0
接收感谢: 11 次

Re: Ubuntu10.10无法识别u盘

#9

帖子 iamfbi » 2011-06-04 20:14

我的U盘也是,不过我的U盘是自己量产过的,在WIN下是一个光驱一个U盘,但是UB里识别不了盘符,把USB设备分配到虚拟机里可以用。。。
Laptop: i5-460m hm55 4g 320g hd5470 14'led 2.3kg (acer 4738g)
Windows XP 7 8 all in one partition.
Ubuntu 10.04 LTS
Mac OS X 10.6.7
折腾笔记
论坛随手记
玄原
帖子: 92
注册时间: 2007-12-16 21:59
送出感谢: 0
接收感谢: 0

Re: Ubuntu10.10无法识别u盘

#10

帖子 玄原 » 2011-06-04 22:14

谁知道怎么办
头像
bigsun
帖子: 301
注册时间: 2009-01-11 16:05
送出感谢: 2 次
接收感谢: 11 次

Re: Ubuntu10.10无法识别u盘

#11

帖子 bigsun » 2011-10-23 11:37

kernel问题
Device Drivers -->
SCSI device support -->
Probe all LUNs on each SCSI device

CONFIG_SCSI_MULTI_LUN: │
│ │
│ Some devices support more than one LUN (Logical Unit Number) in order │
│ to allow access to several media, e.g. CD jukebox, USB card reader, │
│ mobile phone in mass storage mode. This option forces the kernel to │
│ probe for all LUNs by default. This setting can be overriden by │
│ max_luns boot/module parameter. Note that this option does not affect │
│ devices conforming to SCSI-3 or higher as they can explicitely report │
│ their number of LUNs. It is safe to say Y here unless you have one of │
│ those rare devices which reacts in an unexpected way when probed for │
│ multiple LUNs.
我量产的U盘也不能识别,原来搞过,忘记了,
这次发贴备忘.
这些用户感谢了作者 bigsun 于这个帖子:
UiGood (2011-10-24 11:21)
评价: 3.7%
UiGood
帖子: 45
注册时间: 2011-04-27 17:11
送出感谢: 2 次
接收感谢: 0

Re: Ubuntu10.10无法识别u盘

#12

帖子 UiGood » 2011-10-23 20:49

可否说的详细点,我这儿输入第一句的结果:
igood@igood-virtual-machine:~$ Device Drivers -->
bash: 未预期的符号 `newline' 附近有语法错误
头像
bigsun
帖子: 301
注册时间: 2009-01-11 16:05
送出感谢: 2 次
接收感谢: 11 次

Re: Ubuntu10.10无法识别u盘

#13

帖子 bigsun » 2011-10-23 23:18

这个有点麻烦
找几个老贴供参考:
viewtopic.php?t=134404
viewtopic.php?t=34172
viewtopic.php?t=110461

在内核原程序目录下:
make menuconfig
找对应选项.
这些用户感谢了作者 bigsun 于这个帖子:
UiGood (2011-10-24 10:14)
评价: 3.7%
UiGood
帖子: 45
注册时间: 2011-04-27 17:11
送出感谢: 2 次
接收感谢: 0

Re: Ubuntu10.10无法识别u盘

#14

帖子 UiGood » 2011-10-24 10:14

已经弄好了,多谢 :em02
UiGood
帖子: 45
注册时间: 2011-04-27 17:11
送出感谢: 2 次
接收感谢: 0

Re: Ubuntu10.10无法识别u盘

#15

帖子 UiGood » 2011-10-26 22:28

现在问题是没法热插拔,拔掉再识别就得再重启,这是怎么回事呢
回复

回到 “常用硬件支持”