求教!ubuntu10.10源码安装alsa-1.0.24失败

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
cmheia
帖子: 10
注册时间: 2010-12-04 0:15
送出感谢: 0
接收感谢: 0

求教!ubuntu10.10源码安装alsa-1.0.24失败

#1

帖子 cmheia » 2011-02-25 1:46

以前安装过1.0.23版的,今天忽然想升级看看,
alsa-driver-1.0.24、 alsa-lib-1.0.24.1、 alsa-utils-1.0.24.2 都成功完成了:./configure、make、sudo make install步骤,没有遇到error
但是重启后就是死活不认识声卡,
终端执行service alsasound status,显示:ALSA sound driver not loaded.
声音首选项里找不到声卡……
这个怎么解决啊?
运行alsaconf
显示
No supported PnP or PCI card found

Screenshot-声音首选项.png
头像
KOSKERS
帖子: 1436
注册时间: 2008-11-01 13:38
送出感谢: 25 次
接收感谢: 4 次

Re: 求教!ubuntu10.10源码安装alsa-1.0.24失败

#2

帖子 KOSKERS » 2011-03-17 10:49

我是ubunutu 10.04
自从升级到2.6.38内核。alsa 1.0。24一直不生效。安装都是success。但是cat /proc/asound/version 一直都是1.0.23.
很无语。在2.6.36的时候我用1.0.24感觉音质好像更好一些(心里感觉)
有用Telegram的吗?
欢迎加入公共群组:
https://t.me/joinchat/AAAAAApBLdk7AGFEeQo0fQ
lycho127
帖子: 6
注册时间: 2009-04-30 7:53
送出感谢: 0
接收感谢: 0

Re: 求教!ubuntu10.10源码安装alsa-1.0.24失败

#3

帖子 lycho127 » 2011-03-25 21:54

哥们,我也遇到了一模一样到情况。很是郁闷。我msn:lycho127@hotmail.com
bauhinia
帖子: 4
注册时间: 2011-03-23 15:38
送出感谢: 0
接收感谢: 0

Re: 求教!ubuntu10.10源码安装alsa-1.0.24失败

#4

帖子 bauhinia » 2011-03-26 8:50

我也是差不多的问题,我的电脑是dell15R-478,装ubuntu10.10. 开始的时候笔记本出声音,插上耳机就没有声音了。参考网上的资料,似乎1.0.23不支持IDT 92HD81X, 所以参考http://www.hydjp.com/shengkafashaoyou/2010/1225/454.html , 可是在alsa-utils-1.0.24 make的时候出现了错误,现在是首选项-声音-硬件里什么也没有了,那位可以帮帮忙阿。 实在不行,让alsa 回到1.0.23也好阿 ,总比一点声音都没有好。
bauhinia
帖子: 4
注册时间: 2011-03-23 15:38
送出感谢: 0
接收感谢: 0

Re: 求教!ubuntu10.10源码安装alsa-1.0.24失败

#5

帖子 bauhinia » 2011-03-27 9:15

我的是dell 15r-478(N5010), 装ubuntu 10.10后喇叭有声音,插上耳机没有声音。更新alsa 1.0.24的时候,make alsa-utils出错,在网上有没找到解决办法。现在alsa版本1.0.24,但是喇叭,耳机都没有声音。首选项-声音-硬件里什么都没有。 谁能指点下啊。 不行让我装回alsa 1.0.23啊,起码喇叭有声音。
回复

回到 “常用硬件支持”