当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 关于 ubuntu 10.10 安装 brother DCP 7030 打印机问题
帖子发表于 : 2011-03-09 19:40 

注册: 2011-03-09 19:25
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
安装完驱动后可以打印 但是更新管理器自动提示
----------“软件索引已经损坏无法安装或删除任何软件。请使用新立得软件包管理器或在终端运行 "sudo apt-get install -f" 来修正这个问题。”
使用 “sudo apt-get install -f”修复显示
---------~$ sudo apt-get install -f
---------正在读取软件包列表... 完成
---------正在分析软件包的依赖关系树
---------正在读取状态信息... 完成
---------E: 软件包 brdcp7030lpr 需要重新安装,但是我无法找到相应的安装文件。

也无法重新安装软件,在“软件中心或终端”下重新安装软件包显示
------------------------------------------------------------------------------------------------------
$ sudo apt-get install brdcp7030lpr-2.0.2-1.i386.deb - - reinstal
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
E: 软件包 brdcp7030lpr 需要重新安装,但是我无法找到相应的安装文件。
--------------------------------------------------------------------------------------------------------
$ sudo apt-get install /home/liumingwei/文档/7030/brdcp7030lpr-2.0.2-1.i386.deb - - reinstal
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
E: 软件包 brdcp7030lpr 需要重新安装,但是我无法找到相应的安装文件。
--------------------------------------------------------------------------------------------------------

打印机使用没有问题 但是每次启动到桌面环境都提示
-------------------------------------------------------------------
“软件索引已经损坏无法安装或删除任何软件。请使用新立得软件包管理器或在终端运行 "sudo apt-get install -f" 来修正这个问题。”
使用 “sudo apt-get install -f”修复显示
------------------------------------------------------------------

使用


brscan3-0.2.9-1.i386.deb
linux-brprinter-installer-1.0.0-1
brscan-skey-0.2.1-3.i386.deb
该安装包安装
下载地址“http://forum.ubuntu.org.cn/download/file.php?id=104229”


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 关于 ubuntu 10.10 安装 brother DCP 7030 打印机问题
帖子发表于 : 2011-03-09 20:00 

注册: 2011-03-09 19:25
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
对软件包拆卸显示
--------------------------

$sudo dpkg -P brdcp7030lpr
dpkg:处理 brdcp7030lpr (--purge)时出错:
该软件包现在的状态极为不妥 - 建议您在卸载它之前再重新安装一次。
在处理时有错误发生:
brdcp7030lp
--------------------------

重新安装软件包显示

------------------------------
$ sudo apt-get install brdcp7030lpr - - reinstall
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
E: 软件包 brdcp7030lpr 需要重新安装,但是我无法找到相应的安装文件。
------------------------------

直接对软件包再次安装
------------------------------
$ sudo dpkg -i /home/liumingwei/ 文档/7030/brdcp7030lpr-2.0.2-1.i386.deb
选中了曾被取消选择的软件包 brdcp7030lpr。
(正在读取数据库 ... 系统当前共安装有 146740 个文件和目录。)
正预备替换 brdcp7030lpr 2.0.2-1 (使用 .../brdcp7030lpr-2.0.2-1.i386.deb) ...
正在解压缩将用于更替的包文件 brdcp7030lpr ...
start: Unknown job: lprng
dpkg:警告:子进程 旧的 post-removal 脚本 返回了错误号 1
dpkg - 现在尝试使用新软件包所带的脚本...
start: Unknown job: lprng
dpkg:处理 /home/liumingwei/文档/7030/brdcp7030lpr-2.0.2-1.i386.deb (--install)时出错:
子进程 新的 post-removal 脚本 返回了错误号 1
start: Unknown job: lprng
dpkg:清理时出错:
子进程 新的 post-removal 脚本 返回了错误号 1
在处理时有错误发生:
/home/liumingwei/文档/7030/brdcp7030lpr-2.0.2-1.i386.deb
------------------------------------------


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译