安装nvidia显卡驱动出错?不能满足的依赖关系

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
头像
riaz
帖子: 24
注册时间: 2006-11-05 16:08
送出感谢: 0
接收感谢: 0
联系:

安装nvidia显卡驱动出错?不能满足的依赖关系

#1

帖子 riaz » 2006-11-22 20:54

执行代码:
sudo apt-get install nvidia-glx
出错:
下列的软件包有不能满足的依赖关系:
nvidia-glx: 依赖: nvidia-kernel-1.0.9625

硬件:PD805+技嘉945+盈通7300le

偶是新手。大家帮忙看看。
llin82
帖子: 26
注册时间: 2006-10-29 11:06
送出感谢: 0
接收感谢: 0

#2

帖子 llin82 » 2006-11-23 10:36

先sudo apt-get install nvidia-kernel-1.0.9625 看看吧,我碰到的问题是:
sudo apt-get install nvidia-kernel-1.0.9625
它提示说:这是一个虚拟软件包,但没给实际包名。所以也没装上。我用的源
是上交大的,请问哪个源里有这个kernel包?谢谢。
llin82
帖子: 26
注册时间: 2006-10-29 11:06
送出感谢: 0
接收感谢: 0

#3

帖子 llin82 » 2006-11-23 10:39

先sudo apt-get install nvidia-kernel-1.0.9625 看看吧,我碰到的问题是:
sudo apt-get install nvidia-kernel-1.0.9625
它提示说:这是一个虚拟软件包,但没给实际包名。所以也没装上。我用的源
是上交大的,请问哪个源里有这个kernel包?谢谢。
头像
riaz
帖子: 24
注册时间: 2006-11-05 16:08
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 riaz » 2006-11-23 20:44

一样:
软件包 nvidia-kernel-1.0.9625 是一个由下面的软件包提供的虚拟软件包:
请您明确地选择一个来进行安装。
E: 软件包 nvidia-kernel-1.0.9625 还没有可供安装的候选者
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#5

帖子 eexpress » 2006-11-23 20:49

$● as nvidia-kernel
v nvidia-kernel-1.0.7184 -
v nvidia-kernel-1.0.8774 -
v nvidia-kernel-1.0.8776 -
v nvidia-kernel-1.0.9625 -
v nvidia-kernel-1.0.9629 -
i nvidia-kernel-common - NVIDIA binary kernel module common files
p nvidia-kernel-source - NVIDIA binary kernel module source

cn99的源。
● 鸣学
头像
felixlu
帖子: 311
注册时间: 2006-11-25 15:27
来自: SZ
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 felixlu » 2006-11-26 21:08

我也卡在这一步了……在新立得软件包管理器里面对nvidia-kernel-source这个包的描述好像说Ubuntu系统并不需要这个包,但是实际上选择安装NV驱动的时候又确实会出现上面的提示……是不是要先装这个源码、然后自己用源码安装,再来装NV的显卡驱动呢?
头像
riaz
帖子: 24
注册时间: 2006-11-05 16:08
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 riaz » 2006-11-29 19:28

现在搞定了,可以看看这里
viewtopic.php?t=32373&highlight=
回复

回到 “常用硬件支持”