双显卡:GT540M / Intel集成显卡,已经禁掉Optimus,但是依旧无法使用显卡驱动,无法启动3D

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
头像
大笨虎
帖子: 18
注册时间: 2011-05-03 17:35
送出感谢: 0
接收感谢: 0

双显卡:GT540M / Intel集成显卡,已经禁掉Optimus,但是依旧无法使用显卡驱动,无法启动3D

#1

帖子 大笨虎 » 2011-05-04 13:08

显卡: NVidia GT540M,华硕笔记本A53SV,BIOS里面没有关闭集成/独立显卡的选项

在系统中手动关闭独立显卡,使用lspci查看独立显卡后面为 rev FF(这应该用来判断关闭成功的提示吧?)

但是安装自带驱动还是无法使用,无法启动3D,是双显卡无法启动3D特效,还是说我还有什么地方没有设置对?
头像
Dim
帖子: 640
注册时间: 2009-04-06 15:03
送出感谢: 1 次
接收感谢: 0

Re: 双显卡:GT540M / Intel集成显卡,已经禁掉Optimus,但是依旧无法使用显卡驱动,无法启动3D

#2

帖子 Dim » 2011-05-04 14:05

我好你一点,我也是双显,bios显只能关独显,在ubuntu1010下,双显是不行,用集显都支持不了,11.04还算好可以集显,也能开特效了。新本本的双显是杯具啊
,
头像
大笨虎
帖子: 18
注册时间: 2011-05-03 17:35
送出感谢: 0
接收感谢: 0

Re: 双显卡:GT540M / Intel集成显卡,已经禁掉Optimus,但是依旧无法使用显卡驱动,无法启动3D

#3

帖子 大笨虎 » 2011-05-04 14:10

太悲剧了,这两天一直在给新本反复安装Ubuntu 11.04

使用网上的搜到方法关闭了独立显卡以后,应该是使用集成显卡了,但是其是没有驱动的,我重启,安装驱动,再重启,结果还是驱动已激活但未使用

真愁人,不知道在关闭了独立显卡以后,还需要做些什么操作
头像
lovelyzlf
帖子: 946
注册时间: 2009-11-04 13:03
送出感谢: 8 次
接收感谢: 6 次
联系:

Re: 双显卡:GT540M / Intel集成显卡,已经禁掉Optimus,但是依旧无法使用显卡驱动,无法启动3D

#4

帖子 lovelyzlf » 2011-05-04 14:23

貌似太新的硬件都不行哦!
linux for human beings!
SAMSUNG Q460,CPU intel i3 2330,RAM 8G,HDD640G,Graphic card GT540 1G
Debian-testing(wheezy)+KDE
头像
大笨虎
帖子: 18
注册时间: 2011-05-03 17:35
送出感谢: 0
接收感谢: 0

Re: 双显卡:GT540M / Intel集成显卡,已经禁掉Optimus,但是依旧无法使用显卡驱动,无法启动3D

#5

帖子 大笨虎 » 2011-05-04 14:33

lovelyzlf 写了:貌似太新的硬件都不行哦!
是不是说,我这款显卡,即使停止了独立显卡,单使用集成显卡,还是无法安装显卡驱动?启动不了3D特效?

另:集成显卡需要安装驱动不?
头像
Dim
帖子: 640
注册时间: 2009-04-06 15:03
送出感谢: 1 次
接收感谢: 0

Re: 双显卡:GT540M / Intel集成显卡,已经禁掉Optimus,但是依旧无法使用显卡驱动,无法启动3D

#6

帖子 Dim » 2011-05-05 11:36

大笨虎 写了:
lovelyzlf 写了:貌似太新的硬件都不行哦!
是不是说,我这款显卡,即使停止了独立显卡,单使用集成显卡,还是无法安装显卡驱动?启动不了3D特效?

另:集成显卡需要安装驱动不?
楼主你也不用关独显,我说说我的你试试,我的可以用,
首先,你一定要用11.04的版本,10.10我用了是不行。在11.04安装后可以支持新的INTEL显卡,不用自己在安驱动,同时他会提醒你可以安NV显卡驱动,我没安装,接下来我安装COMP
IZ直接可以开启,
补,我的是NV530M和INTEL9100
,
e21
帖子: 641
注册时间: 2008-01-24 9:47
送出感谢: 0
接收感谢: 4 次

Re: 双显卡:GT540M / Intel集成显卡,已经禁掉Optimus,但是依旧无法使用显卡驱动,无法启动3D

#7

帖子 e21 » 2011-05-05 12:40

我的本子也是这样,现在用11.04可以驱动集成显卡,但太卡了软件多是动一下停一下的。莫非这个二代i3显卡性能比上一代的4500集成显卡还差很多,我上一个本集成显卡装11.04开各种特效都比较流畅,这个新本就差远了。
lishuai19871005
帖子: 54
注册时间: 2008-11-28 11:24
送出感谢: 0
接收感谢: 0

Re: 双显卡:GT540M / Intel集成显卡,已经禁掉Optimus,但是依旧无法使用显卡驱动,无法启动3D

#8

帖子 lishuai19871005 » 2011-05-05 15:42

楼主竟然和我的电脑一样的配置,双显卡,GT540和intel 集成显卡,你禁用独显之后 安装的显卡驱动都是nvidia的吧?那你独显都禁用了,安装那个没用了吧,我装上10.10后,很卡,安装系统附加驱动,开机卡死在checking battery state,升级到11.04之后好多了,我从官网上下载了gt540的linux 驱动,貌似也不行,不过你可以试试……
starfine
帖子: 12
注册时间: 2010-09-11 14:55
送出感谢: 0
接收感谢: 0

Re: 双显卡:GT540M / Intel集成显卡,已经禁掉Optimus,但是依旧无法使用显卡驱动,无法启动3D

#9

帖子 starfine » 2011-05-05 21:00

楼主你的主板设置里面是不是只有设置compatible和enhanced两个选项?
UBUNTU下面要选择compatible就可以使用独显了。比如安装XP的时候也是选 的这个模式,enhanced的这个模式是装VISTA和WIN7的时候用的。
这样做有个不方便的地方就是每次换系统登陆的话,都要进BIOS去设置IDE模式,有点麻烦。不过这是唯一的办法 。
这个办法我是在华硕的官网看的,也是有个友友不能安UBUNTU的显卡驱动,然后工程师说选兼容模式,你可以试试看。
头像
大笨虎
帖子: 18
注册时间: 2011-05-03 17:35
送出感谢: 0
接收感谢: 0

Re: 双显卡:GT540M / Intel集成显卡,已经禁掉Optimus,但是依旧无法使用显卡驱动,无法启动3D

#10

帖子 大笨虎 » 2011-05-09 11:39

lishuai19871005 写了:楼主竟然和我的电脑一样的配置,双显卡,GT540和intel 集成显卡,你禁用独显之后 安装的显卡驱动都是nvidia的吧?那你独显都禁用了,安装那个没用了吧,我装上10.10后,很卡,安装系统附加驱动,开机卡死在checking battery state,升级到11.04之后好多了,我从官网上下载了gt540的linux 驱动,貌似也不行,不过你可以试试……

关于禁用独显,我尝试了几种方法,均没能关闭独显(看别的帖子说,如果关闭成功,查看/sys/kernel/debug/vgaswitcheroo/switch这个文件,会有一个off,一个pwr,如果开机没有这个文件,说明关闭失败)

如果不关闭独立显卡的话,我查看上面的文件,两个都是pwr,而且我不知道那个是独立显卡,哪个是集成显卡
头像
大笨虎
帖子: 18
注册时间: 2011-05-03 17:35
送出感谢: 0
接收感谢: 0

Re: 双显卡:GT540M / Intel集成显卡,已经禁掉Optimus,但是依旧无法使用显卡驱动,无法启动3D

#11

帖子 大笨虎 » 2011-05-09 11:43

Dim 写了:
大笨虎 写了:
lovelyzlf 写了:貌似太新的硬件都不行哦!
是不是说,我这款显卡,即使停止了独立显卡,单使用集成显卡,还是无法安装显卡驱动?启动不了3D特效?

另:集成显卡需要安装驱动不?
楼主你也不用关独显,我说说我的你试试,我的可以用,
首先,你一定要用11.04的版本,10.10我用了是不行。在11.04安装后可以支持新的INTEL显卡,不用自己在安驱动,同时他会提醒你可以安NV显卡驱动,我没安装,接下来我安装COMP
IZ直接可以开启,
补,我的是NV530M和INTEL9100
安装好了Ubuntu不管任何显卡,直接安装compiz,我试过,不能启动,Ubuntu我一直是在11.04下测试的
lishuai19871005
帖子: 54
注册时间: 2008-11-28 11:24
送出感谢: 0
接收感谢: 0

Re: 双显卡:GT540M / Intel集成显卡,已经禁掉Optimus,但是依旧无法使用显卡驱动,无法启动3D

#12

帖子 lishuai19871005 » 2011-05-14 17:54

大笨虎 写了:
lishuai19871005 写了:楼主竟然和我的电脑一样的配置,双显卡,GT540和intel 集成显卡,你禁用独显之后 安装的显卡驱动都是nvidia的吧?那你独显都禁用了,安装那个没用了吧,我装上10.10后,很卡,安装系统附加驱动,开机卡死在checking battery state,升级到11.04之后好多了,我从官网上下载了gt540的linux 驱动,貌似也不行,不过你可以试试……

关于禁用独显,我尝试了几种方法,均没能关闭独显(看别的帖子说,如果关闭成功,查看/sys/kernel/debug/vgaswitcheroo/switch这个文件,会有一个off,一个pwr,如果开机没有这个文件,说明关闭失败)

如果不关闭独立显卡的话,我查看上面的文件,两个都是pwr,而且我不知道那个是独立显卡,哪个是集成显卡
集成显卡驱动都在内核里面集成了吧,我的cpu是i3-2310,安装11.04之后感觉集显还行,独立显卡现在真的不敢用了……
Soybean
帖子: 16
注册时间: 2011-04-16 20:33
送出感谢: 0
接收感谢: 0

Re: 双显卡:GT540M / Intel集成显卡,已经禁掉Optimus,但是依旧无法使用显卡驱动,无法启动3D

#13

帖子 Soybean » 2011-05-19 23:09

ubuntu貌似是不支持optimus。。。少折腾了吧
ychristian
帖子: 47
注册时间: 2007-07-17 14:36
送出感谢: 0
接收感谢: 0

Re: 双显卡:GT540M / Intel集成显卡,已经禁掉Optimus,但是依旧无法使用显卡驱动,无法启动3D

#14

帖子 ychristian » 2011-05-23 11:44

e21 写了:我的本子也是这样,现在用11.04可以驱动集成显卡,但太卡了软件多是动一下停一下的。莫非这个二代i3显卡性能比上一代的4500集成显卡还差很多,我上一个本集成显卡装11.04开各种特效都比较流畅,这个新本就差远了。
snd集成显卡不错,见我版内的帖子。
头像
jeffstric
帖子: 23
注册时间: 2011-06-10 22:33
送出感谢: 0
接收感谢: 0
联系:

Re: 双显卡:GT540M / Intel集成显卡,已经禁掉Optimus,但是依旧无法使用显卡驱动,无法启动3D

#15

帖子 jeffstric » 2011-06-13 12:41

:em20 相同问题啊 双显卡的悲剧,现在在思考要不要退回到9,04去……
回复

回到 “常用硬件支持”