当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 13 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [已解决]Ubuntu 11.04,nVidia 7300LE,不装任何闭源与开源驱动,开机时白屏闪过
帖子发表于 : 2011-05-09 22:58 

注册: 2008-02-05 20:26
帖子: 198
送出感谢: 0 次
接收感谢: 0 次
引用:
刚装完11.04时一切正常,按提示只能进入经典无特效界面。然后安装了nvidia(current)驱动,重启后,进入系统时出现几秒钟白屏,这时可以看到上面有字符变化,看得出是显示启动信息时的字符界面的时候。然后登录unity或者带特效的gnome界面后,鼠标可以移动,但屏幕上的任何地方均无法点击。强制重启,可以进入无特效的gnome界面,卸掉nvidia驱动,重启,白屏依然存在。又改装nvidia(173版本)驱动,开机白屏依然存在,但unity界面和带特效的gnome界面都能正常使用,系统其他使用也都不受影响。


引用:
以上是原先的帖子内容

现在我发现,全新装完系统,不装任何闭源与开源驱动,开机时都会白屏闪过,但开机后ctrl-alt-fN进入控制台正常。
若进入recovery模式,一开始会显示为黑色背景+很粗而看不清楚的白色字符,后来依旧变成白屏。但强制重启第二次进入recovery模式后,就会一切正常。但此时重启进入正常模式,分辨率自动变为640*480
安装开源驱动后的症状与上面完全相同。
而如果装源里173版本的闭源驱动,就会出现ctrl-alt-fN白屏,其他症状与上面相同。
而若装源里current版本的闭源驱动,进入桌面后鼠标可以移动,但点击任何东西都没有反应。


现在已经解决,修改grub2的配置文件,在内核参数后面加vga=795,这个数字和分辨率有关,请自行搜索相关资料。


最后由 brglng 编辑于 2011-06-04 11:05,总共编辑了 5 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: 11.04 + nVidia 7300LE 开机有几秒钟白屏
帖子发表于 : 2011-05-09 23:03 
头像

注册: 2010-01-28 10:45
帖子: 19507
送出感谢: 6
接收感谢: 41
额的开源3D的驱动也花屏,但不影响使用


_________________

*********宁静致远*********
如果我说的有什么不对,请看签名第一行


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 11.04 + nVidia 7300LE 开机有几秒钟白屏
帖子发表于 : 2011-05-14 0:47 

注册: 2008-02-05 20:26
帖子: 198
送出感谢: 0 次
接收感谢: 0 次
于是我现在发现只要按ctrl-alt-f1进入控制台界面就是白屏。。。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 11.04 + nVidia 7300LE 开机有几秒钟白屏
帖子发表于 : 2011-05-14 17:59 

注册: 2008-02-05 20:26
帖子: 198
送出感谢: 0 次
接收感谢: 0 次
换了开源驱动后开机白屏还是存在,但进系统后再进入控制台没有白屏了
但貌似开源驱动性能比闭源的差不少,启用compiz时能看到明显的卡。。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 11.04 + nVidia 7300LE 开机有几秒钟白屏
帖子发表于 : 2011-05-14 19:25 
头像

注册: 2009-10-08 11:15
帖子: 8428
地址: 大城市铁岭
送出感谢: 0 次
接收感谢: 9
ctrl-alt-fN不能进,很多就是显卡驱动没装好
装N卡闭源驱动,要在blocklist里加入些东东,不同系统不一样,不同内核也可能不一样


_________________
我们是命运的妓女,它把我们都嫖了

N卡驱动:http://www.nvidia.cn/Download/index.aspx?lang=cn
极品飞车:http://www.geforce.cn/optimize/optimal-game-settings/need-for-speed-shift-geforce-gts-450-ops
孤岛危机优化设置:http://www.geforce.cn/optimize/optimal-game-settings/crysis-geforce-gtx-450-ops
:cp /etc/skel/.bashrc ~/
PS1="\[\e]2;\u@\H \w\a\e[32;1m\]\T$\[\e[0m\] "
http://cdimage.ubuntu.com/
http://releases.ubuntu.com/


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 11.04 + nVidia 7300LE 开机有几秒钟白屏
帖子发表于 : 2011-05-14 19:40 

注册: 2008-02-05 20:26
帖子: 198
送出感谢: 0 次
接收感谢: 0 次
ctrl-alt-fN其实可以进,但进去之后整个屏幕是白的,里面的字符显示不完整,都是很分散的黑色的像素点,打字的话也能看到屏幕上有反应,说明是进去了,但显示有点问题。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 11.04 + nVidia 7300LE 开机有几秒钟白屏
帖子发表于 : 2011-05-14 19:48 
头像

注册: 2009-10-08 11:15
帖子: 8428
地址: 大城市铁岭
送出感谢: 0 次
接收感谢: 9
代码:
ls /etc/modprobe.d/

看看


_________________
我们是命运的妓女,它把我们都嫖了

N卡驱动:http://www.nvidia.cn/Download/index.aspx?lang=cn
极品飞车:http://www.geforce.cn/optimize/optimal-game-settings/need-for-speed-shift-geforce-gts-450-ops
孤岛危机优化设置:http://www.geforce.cn/optimize/optimal-game-settings/crysis-geforce-gtx-450-ops
:cp /etc/skel/.bashrc ~/
PS1="\[\e]2;\u@\H \w\a\e[32;1m\]\T$\[\e[0m\] "
http://cdimage.ubuntu.com/
http://releases.ubuntu.com/


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 11.04 + nVidia 7300LE 开机有几秒钟白屏
帖子发表于 : 2011-05-14 19:54 
头像

注册: 2009-10-08 11:15
帖子: 8428
地址: 大城市铁岭
送出感谢: 0 次
接收感谢: 9
你的驱动 是这个吗http://www.nvidia.cn/object/linux-display-ia32-270.41.06-driver-cn.html


_________________
我们是命运的妓女,它把我们都嫖了

N卡驱动:http://www.nvidia.cn/Download/index.aspx?lang=cn
极品飞车:http://www.geforce.cn/optimize/optimal-game-settings/need-for-speed-shift-geforce-gts-450-ops
孤岛危机优化设置:http://www.geforce.cn/optimize/optimal-game-settings/crysis-geforce-gtx-450-ops
:cp /etc/skel/.bashrc ~/
PS1="\[\e]2;\u@\H \w\a\e[32;1m\]\T$\[\e[0m\] "
http://cdimage.ubuntu.com/
http://releases.ubuntu.com/


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 11.04 + nVidia 7300LE 开机有几秒钟白屏
帖子发表于 : 2011-05-14 23:22 

注册: 2008-02-05 20:26
帖子: 198
送出感谢: 0 次
接收感谢: 0 次
我装的是源里的驱动,173版本


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 11.04 + nVidia 7300LE 开机有几秒钟白屏
帖子发表于 : 2011-05-15 10:07 
头像

注册: 2009-10-08 11:15
帖子: 8428
地址: 大城市铁岭
送出感谢: 0 次
接收感谢: 9
viewtopic.php?f=94&t=328774


_________________
我们是命运的妓女,它把我们都嫖了

N卡驱动:http://www.nvidia.cn/Download/index.aspx?lang=cn
极品飞车:http://www.geforce.cn/optimize/optimal-game-settings/need-for-speed-shift-geforce-gts-450-ops
孤岛危机优化设置:http://www.geforce.cn/optimize/optimal-game-settings/crysis-geforce-gtx-450-ops
:cp /etc/skel/.bashrc ~/
PS1="\[\e]2;\u@\H \w\a\e[32;1m\]\T$\[\e[0m\] "
http://cdimage.ubuntu.com/
http://releases.ubuntu.com/


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 11.04 + nVidia 7300LE 开机有几秒钟白屏
帖子发表于 : 2011-05-15 11:09 

注册: 2008-02-05 20:26
帖子: 198
送出感谢: 0 次
接收感谢: 0 次
晕。我能进unity,compiz 3d效果什么的全都没问题,就是ctrl-alt-fN进控制台会出现白屏。


页首
 用户资料  
 
12 楼 
 文章标题 : Re: Ubuntu 11.04,nVidia 7300LE,不装任何闭源与开源驱动,开机时白屏闪过……标题要长……
帖子发表于 : 2011-05-15 19:56 

注册: 2008-02-05 20:26
帖子: 198
送出感谢: 0 次
接收感谢: 0 次
现在我发现,全新装完系统,不装任何闭源与开源驱动,开机时都会白屏闪过,但开机后ctrl-alt-fN进入控制台正常。
若进入recovery模式,一开始会显示为黑色背景+很粗而看不清楚的白色字符,后来依旧变成白屏。但强制重启第二次进入recovery模式后,就会一切正常。但此时重启进入正常模式,分辨率自动变为640*480
安装开源驱动后的症状与上面完全相同。
而如果装源里173版本的闭源驱动,就会出现ctrl-alt-fN白屏,其他症状与上面相同。
而若装源里current版本的闭源驱动,进入桌面后鼠标可以移动,但点击任何东西都没有反应。


页首
 用户资料  
 
13 楼 
 文章标题 : Re: Ubuntu 11.04,nVidia 7300LE,不装任何闭源与开源驱动,开机时白屏闪过………………标题要长
帖子发表于 : 2011-06-04 11:01 

注册: 2008-02-05 20:26
帖子: 198
送出感谢: 0 次
接收感谢: 0 次
解决了。在启动时的内核参数后面加了vga=795


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 13 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译