装了官方的显卡驱动就悲剧了~~~~

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
头像
Alvin2008
帖子: 77
注册时间: 2010-09-01 19:41
送出感谢: 0
接收感谢: 0

装了官方的显卡驱动就悲剧了~~~~

#1

帖子 Alvin2008 » 2011-05-23 12:41

今天闲着就想装官方的显卡驱动,先下了最新版的,然后在硬件驱动里移除原来的受限驱动,再用 sudo apt-get --purge remove nvidia-*卸载了一下,重启后进入命令界面安装新驱动,安装后进入系统有开机声,但只有一个鼠标可以动,其它都是黑的,什么都没法做(后来发现系统可以运行屏保,而且屏保动画正常,还可以在桌面下用快捷键调出终端,当然显示器上还是一片黑,只是我发现鼠标形状变了……)。现在我只能用ctrl+alt+f1进入命令界面把新驱动删了,但是不知道怎么恢复成原来的了,请问系统自带的驱动有没有被我删了?还有没有办法恢复成原来的?或者怎么让新驱动正常运行?是不是这个驱动不支持?

我在教程中看到说要改/etc/default/linux-restricted-modules-common这文件,可是我的/etc/default/下根本没有这个文件,这个是什么文件?为什么我没有,怎么做才会有这个文件?

求大神啊~~~~

我的系统:Ubuntu 10.04 显卡:GF 7300
头像
冲浪板
论坛版主
帖子: 7467
注册时间: 2007-05-06 8:19
送出感谢: 0
接收感谢: 5 次

Re: 装了官方的显卡驱动就悲剧了~~~~

#2

帖子 冲浪板 » 2011-05-23 13:09

没有你就造一个
头像
黄美姬
论坛版主
帖子: 8428
注册时间: 2009-10-08 11:15
来自: 大城市铁岭
送出感谢: 0
接收感谢: 1 次

Re: 装了官方的显卡驱动就悲剧了~~~~

#3

帖子 黄美姬 » 2011-05-23 14:59

我们是命运的妓女,它把我们都嫖了

N卡驱动:http://www.nvidia.cn/Download/index.aspx?lang=cn
极品飞车:http://www.geforce.cn/optimize/optimal- ... ts-450-ops
孤岛危机优化设置:http://www.geforce.cn/optimize/optimal- ... tx-450-ops
:cp /etc/skel/.bashrc ~/
PS1="\[\e]2;\u@\H \w\a\e[32;1m\]\T$\[\e[0m\] "
http://cdimage.ubuntu.com/
http://releases.ubuntu.com/
头像
Alvin2008
帖子: 77
注册时间: 2010-09-01 19:41
送出感谢: 0
接收感谢: 0

Re: 装了官方的显卡驱动就悲剧了~~~~

#4

帖子 Alvin2008 » 2011-05-23 15:32

黄美姬 写了:viewtopic.php?f=42&t=331903
这个跟我的情况有些不太一样,我刚才恢复诚默认了,可以进入图新界面了,然后再装了一遍官方的驱动,貌似也装成功了,因为可以进入Nvidia-settings进行设置,但是现在开不了特效了,只要设置外观首选项,不管是正常还是扩展,屏幕都会假死,点神么都没反应,请问该怎么办?只能卸载了吗?
头像
黄美姬
论坛版主
帖子: 8428
注册时间: 2009-10-08 11:15
来自: 大城市铁岭
送出感谢: 0
接收感谢: 1 次

Re: 装了官方的显卡驱动就悲剧了~~~~

#5

帖子 黄美姬 » 2011-05-23 16:20

你按那样装了吗,
http://www.nvidia.cn/Download/index.aspx?lang=cn
下载你的版本
按那样装,我的也是10.04,这样没问题
我们是命运的妓女,它把我们都嫖了

N卡驱动:http://www.nvidia.cn/Download/index.aspx?lang=cn
极品飞车:http://www.geforce.cn/optimize/optimal- ... ts-450-ops
孤岛危机优化设置:http://www.geforce.cn/optimize/optimal- ... tx-450-ops
:cp /etc/skel/.bashrc ~/
PS1="\[\e]2;\u@\H \w\a\e[32;1m\]\T$\[\e[0m\] "
http://cdimage.ubuntu.com/
http://releases.ubuntu.com/
头像
Alvin2008
帖子: 77
注册时间: 2010-09-01 19:41
送出感谢: 0
接收感谢: 0

Re: 装了官方的显卡驱动就悲剧了~~~~

#6

帖子 Alvin2008 » 2011-05-24 0:35

黄美姬 写了:你按那样装了吗,
http://www.nvidia.cn/Download/index.aspx?lang=cn
下载你的版本
按那样装,我的也是10.04,这样没问题

还是不行呐~外观里不能开特效,但是dock的特效却运行正常,真奇怪呀
上次由 Alvin2008 在 2011-05-24 12:24,总共编辑 1 次。
头像
iamfbi
帖子: 1081
注册时间: 2009-02-06 9:18
来自: 小僧乃吐蕃国大雪山大轮寺护国法师座下四大护法之西域妖僧是也
送出感谢: 0
接收感谢: 11 次

Re: 装了官方的显卡驱动就悲剧了~~~~

#7

帖子 iamfbi » 2011-05-24 0:56

之前我也遇到过类似的问题,不过我的是A卡,我是重装显卡驱动,然后好像我还重装了ubuntu-desktop和GDM。
Laptop: i5-460m hm55 4g 320g hd5470 14'led 2.3kg (acer 4738g)
Windows XP 7 8 all in one partition.
Ubuntu 10.04 LTS
Mac OS X 10.6.7
折腾笔记
论坛随手记
回复

回到 “常用硬件支持”