当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 15 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 安装摄像头的问题
帖子发表于 : 2005-09-27 0:01 
头像

注册: 2005-09-21 9:59
帖子: 327
送出感谢: 0 次
接收感谢: 0 次
我用rh el4的时候很容易把摄像头安装上了,用的是spca5xx的驱动。
但是系统换成Ubuntu之后同样的方法安装却不成功,提示如下:
引用:
Building SPCA5XX driver for 2.5/2.6 kernel.
Remember: you must have read/write access to your kernel source tree.
make -C /lib/modules/`uname -r`/build SUBDIRS=/root/Desktop/spca CC=cc modules
make[1]: Entering directory `/lib/modules/2.6.10-5-686/build'
make[1]: *** 没有规则可以创建目标“modules”。 停止。
make[1]: Leaving directory `/lib/modules/2.6.10-5-686/build'
make: *** [default] 错误 2

应该是缺少什么东西,请高手指点!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2005-09-27 0:10 
头像

注册: 2005-08-14 21:55
帖子: 58436
地址: 长沙
送出感谢: 4
接收感谢: 272
you must have read/write access to your kernel source tree.
就是说需要读写某些目录的权限。sudo可以不。


_________________
● 鸣学


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-09-27 0:27 
头像

注册: 2005-09-21 9:59
帖子: 327
送出感谢: 0 次
接收感谢: 0 次
应该不是权限的问题,sudo也是一样。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2005-09-27 0:33 
头像

注册: 2005-09-21 9:59
帖子: 327
送出感谢: 0 次
接收感谢: 0 次
据说要把linux源码目录和内核做个联结,可是Ubuntu的源码目录/usr/src/下面好象都是空的。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2005-09-27 0:35 
头像

注册: 2005-08-14 21:55
帖子: 58436
地址: 长沙
送出感谢: 4
接收感谢: 272
先要看下你说的方法。
做链接就是ln一个过去。具体的不清楚。


_________________
● 鸣学


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2005-09-27 1:17 
头像

注册: 2005-09-21 9:59
帖子: 327
送出感谢: 0 次
接收感谢: 0 次
关键是我找不到源码位置


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2005-10-01 21:42 
头像

注册: 2005-04-10 16:54
帖子: 2625
地址: 温州大学
送出感谢: 0 次
接收感谢: 1
贴出你的源文件,有无设置deb-src的源地址,如果没有的话,加入就可以看到相应的源文件包了!


_________________
我心无畏,源自于我心无知。
图片


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2005-10-01 22:00 
论坛管理员

注册: 2005-03-27 0:06
帖子: 10110
系统: Ubuntu 12.04
送出感谢: 7
接收感谢: 127
ubuntu breezy 已经带了 spca5xx 驱动了 。可以直接使用。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2005-10-01 23:00 
头像

注册: 2005-09-21 9:59
帖子: 327
送出感谢: 0 次
接收感谢: 0 次
看了很多人升级都出了问题,不敢升级,只有等着5.10出来


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2005-10-05 11:14 

注册: 2005-05-24 16:44
帖子: 55
送出感谢: 0 次
接收感谢: 0 次
oneleaf 写道:
ubuntu breezy 已经带了 spca5xx 驱动了 。可以直接使用。


我怎么没有找到?

官方的源里没有 这的源里也没有!


页首
 用户资料  
 
11 楼 
 文章标题 : 我怎么没有找到啊?
帖子发表于 : 2005-11-08 20:35 
头像

注册: 2005-10-01 21:38
帖子: 964
地址: 湖南邵东流光岭
送出感谢: 0 次
接收感谢: 0 次
oneleaf 写道:
ubuntu breezy 已经带了 spca5xx 驱动了 。可以直接使用


现在我已经使用breezy了,你们谁使用breezy可以正常用视频摄像头了?


_________________
小江恩的博客
http://gann.blog.ifeng.com/


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2005-11-08 22:42 

注册: 2005-05-02 15:29
帖子: 105
送出感谢: 0 次
接收感谢: 0 次
oneleaf 写道:
ubuntu breezy 已经带了 spca5xx 驱动了 。可以直接使用。

我这不能用系统自带的
如果用(比如用gnomemeeting)100%死机
自已make的能正常使用~


页首
 用户资料  
 
13 楼 
 文章标题 : 我的也是死机
帖子发表于 : 2005-11-09 21:32 
头像

注册: 2005-10-01 21:38
帖子: 964
地址: 湖南邵东流光岭
送出感谢: 0 次
接收感谢: 0 次
一用gnomemeeting就死机。


_________________
小江恩的博客
http://gann.blog.ifeng.com/


页首
 用户资料  
 
14 楼 
 文章标题 : Re: 我怎么没有找到啊?
帖子发表于 : 2006-02-15 17:12 

注册: 2006-02-14 21:05
帖子: 190
送出感谢: 0 次
接收感谢: 0 次
yinliang108 写道:
oneleaf 写道:
ubuntu breezy 已经带了 spca5xx 驱动了 。可以直接使用


现在我已经使用breezy了,你们谁使用breezy可以正常用视频摄像头了?



你们怎么安装驱动的阿?
是不是apt-get install spca5xx


页首
 用户资料  
 
15 楼 
 文章标题 : 一用gnome meeting就死机
帖子发表于 : 2006-02-16 8:50 

注册: 2006-02-14 21:05
帖子: 190
送出感谢: 0 次
接收感谢: 0 次
我已经删除驱动了

楼主的问题是内核版本不对

我以前也这样。

用别的版本我可以装上驱动

现在也装不上了


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 15 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Yahoo [Bot] 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译