当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 11 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [求助]耳塞只有一边有声音
帖子发表于 : 2006-12-11 14:53 

注册: 2005-12-16 13:09
帖子: 45
送出感谢: 0 次
接收感谢: 0 次
系统:Ubuntu 5.10
主板:ASUS 5PVDC-X
声卡:板载ADI AD1986A 6声道 HDAudia
驱动:是安装是系统自动识别安装的ALSA
附:在音量控制的,“文件”--“更改设备”中,有如下信息:
0:HDA Intel (Alsa Mixer)
1:Analog Devices AD1986A(OSS Mixer)
目前系统默认的是“0”。

在“多媒体系统选择器”中,设置如下:
默认接收器
输出:ESD-Enlightenment Sound Daemon 流水线:esdsink
输出:OSS-Open Sound System 流水线:osssrc

*************************************************************************************************

现在情况是这样的:
所有有声音的时候都是右耳塞正常,左耳塞有很大的“嘶嘶。。”声,而且只有“嘶嘶”的声音。
没有声音的时候就不用说了,完全一个哑巴。
当以下情况是有声音:
1、刚开机的时候,有开机音乐。到桌面启动成功以后,就没有了。
2、使用sudo /etc/init.d/alsa-utils stop
sudo /etc/init.d/alsa-utils start
之后可以发出声音。
当以下情况是没有声音:
1、如上1所提到的,桌面启动成功以后。
2、使用如上2方法后,当其它程序如LumaQQ发声后,就又没有声音了。

**************************************************************************************************

在网上搜了N久,无果,特来求教。若能解答,万分感激!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-12-11 19:54 

注册: 2005-12-16 13:09
帖子: 45
送出感谢: 0 次
接收感谢: 0 次
help help help help

T-T-T-hanks very much


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-12-11 21:33 

注册: 2005-12-16 13:09
帖子: 45
送出感谢: 0 次
接收感谢: 0 次
高手的进来啊,急求答案


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-12-18 23:37 

注册: 2005-12-16 13:09
帖子: 45
送出感谢: 0 次
接收感谢: 0 次
继续顶,求助达人,感激


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-12-18 23:41 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
alsamixer调整下2边声道试试。别说是耳机问题啊。


_________________
● 鸣学


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-12-19 7:00 

注册: 2005-12-16 13:09
帖子: 45
送出感谢: 0 次
接收感谢: 0 次
耳塞是好的


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-12-20 12:55 

注册: 2006-11-18 15:40
帖子: 452
送出感谢: 0 次
接收感谢: 0 次
没插紧有可能,动一下音量调节的滑杆也许有用


页首
 用户资料  
 
8 楼 
 文章标题 : 同意楼上的说法。
帖子发表于 : 2006-12-20 13:02 

注册: 2006-11-29 0:15
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
:lol: 同意楼上的说法。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2006-12-20 13:16 

注册: 2005-12-16 13:09
帖子: 45
送出感谢: 0 次
接收感谢: 0 次
感谢7、8楼
但是可以百分百排除这种可能


页首
 用户资料  
 
10 楼 
 文章标题 : 完美回答!
帖子发表于 : 2007-02-12 19:32 

注册: 2007-02-01 10:16
帖子: 44
送出感谢: 0 次
接收感谢: 0 次
本人使用的是华硕的P5PL2主板,板载了soundmax AD1986A声卡,可是在ubuntu下面却有时候出声,有时候单声道,搞的很是郁闷,寻遍了国内google的关于此板卡的驱动安装都没得到确实的解决办法。
后来发现到国外的一个网站,总算找到了解决办法,安装后reboot声卡立刻就出声了,而且两个音箱都出声了,爽啊!
摘抄如下:

Update to the latest version of alsa
These instructions do not interfere with the Ubuntu package structure or other kernel modules - in other words, the changes seem drastic however they are simply adding greater functionality to an existing kernel module


Install the required tools 安装需要的一些文件


sudo apt-get install build-essential ncurses-dev
Install your kernel headers 安装内核头文件


sudo apt-get install linux-headers-`uname -r`
Download the latest version of alsa from Alsa project (driver, library, and utils) to a directory (eg. /home/naaman/installers/alsa)

alsa-driver

下载alsa-driver驱动


alsa-lib

下载alsa-lib库文件
alsa-utils

下载alsa-utils

Setup installation directories 解压缩下载的文件


sudo mkdir -p /usr/src/alsacd /usr/src/alsasudo cp /home/naaman/installers/alsa/* .sudo tar xjf alsa-driver-1.0.14rc1.tar.bz2sudo tar xjf alsa-lib-1.0.14rc1.tar.bz2sudo tar xjf alsa-utils-1.0.14rc1.tar.bz2
Compile and install alsa-driver 重新编译安装,没有make和gcc的自己解决 :P


cd alsa-driver-1.0.14rc1sudo ./configure --with-cards=hda-intelsudo makesudo make install
Compile and install alsa-lib

cd ../alsa-lib-1.0.14rc1sudo ./configuresudo makesudo make install
Compile and install alsa-utils

cd ../alsa-utils-1.0.14rc1sudo ./configuresudo makesudo make install
Reboot

Note: You may need to right click on the volume control applet in your gnome-panel and go to the preferences and change the device to "HDA Intel (Alsa Mixer)". The same applies to the gnome volume control program. Additionally, you may also need enable some volume sliders through Edit-Preferences in gnome volume control.

Manually tell the driver which flavor you are using
Edit the file /etc/modprobe.d/alsa-base

sudo nano /etc/modprobe.d/alsa-base
Add the line "options snd-hda-intel model=3stack" (change "3stack" to the model you need) 在该文件的末尾加上这个字符串,注意要去掉" "


页首
 用户资料  
 
11 楼 
 文章标题 : 解决!哈哈
帖子发表于 : 2007-12-12 11:17 

注册: 2007-12-10 13:46
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
功夫不负有心人那,哈哈

忙活了三天,终于让一句话搞定了!

修改/etc/modprobe.d/alsa-base,在其中加入“options snd-hda-intel position_fix=1 model=3stack”。保存然后重启,问题解决!

高手阿 ,向前辈们致敬!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 11 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译