[问题]为什么我安装了ATI驱动却无法开启opengl?

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
头像
heidern
帖子: 92
注册时间: 2006-06-25 6:19
送出感谢: 0
接收感谢: 0
联系:

[问题]为什么我安装了ATI驱动却无法开启opengl?

#1

帖子 heidern » 2006-12-26 10:55

sudo apt-get install linux-restricted-modules-$(uname -r)
sudo apt-get install xorg-driver-fglrx
sudo aticonfig --initial
sudo aticonfig --overlay-type=Xv

我用上述方法安装了ati驱动(我是ati x1400 256M显卡),可以正常使用BERYL,但用cedega测试却告知无法开启opengl,用wine玩魔兽也提示无法开始opengl,运行用qt库编写的opengl程序也提示没有opengl支持,请问我该怎么办呀??????????? :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry:
国服2区MC部落
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#2

帖子 zhuqin_83 » 2006-12-26 11:04

那么试试不在beryl下行吗?
好像以前有人提起过,beryl下似乎不行。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
头像
juanzhewudi
帖子: 1114
注册时间: 2006-01-19 11:55
来自: HUST
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 juanzhewudi » 2006-12-26 11:36

你是用的xgl吧
xgl就是这样的。
头像
heidern
帖子: 92
注册时间: 2006-06-25 6:19
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 heidern » 2006-12-26 12:23

那我应该怎么做阿?
国服2区MC部落
头像
juanzhewudi
帖子: 1114
注册时间: 2006-01-19 11:55
来自: HUST
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 juanzhewudi » 2006-12-26 13:51

登录普通的gnome就可以使用了。
你能有beryl的效果就说明你装驱动装成功了,呵呵。
还有如果你是xgl的话试试转到aiglx上,因为他们的原理稍微有些不同,在aiglx上据说可以同时使用opengl加速游戏
kelvinhan
帖子: 173
注册时间: 2006-11-30 1:29
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 kelvinhan » 2006-12-26 22:17

ls -l /usr/lib/libGL.so
你看一下,是不是文件丢失了。
我装了新的ATI驱动后,也是这样,经检查,是 /usr/lib/xorg/libGL.so.1.2 丢失了
头像
heidern
帖子: 92
注册时间: 2006-06-25 6:19
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 heidern » 2006-12-27 12:36

heidern@heidern-laptop:~$ ls -l /usr/lib/libGL.so
lrwxrwxrwx 1 root root 10 2006-11-09 17:25 /usr/lib/libGL.so -> libGL.so.1


我系统里的这文件还在
国服2区MC部落
头像
heidern
帖子: 92
注册时间: 2006-06-25 6:19
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 heidern » 2006-12-27 12:38

还有 ,aiglx和xgl到底是什么样的概念阿?
国服2区MC部落
头像
juanzhewudi
帖子: 1114
注册时间: 2006-01-19 11:55
来自: HUST
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 juanzhewudi » 2006-12-27 15:16

xgl是完全的一个新的用于取代现有x服务器的一个技术。
aiglx是架构在现有x服务器上的。
因此,xgl会导致一些opengl游戏的不兼容.
我知道的就这些了,具体的google一下。
回复

回到 “常用硬件支持”