当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 为什么装nvidia-glx的时候总是要把386的内核和restricted modules装上?
帖子发表于 : 2007-01-03 10:29 

注册: 2007-01-03 10:18
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
我想换成686的内核, 可这时进入x的时候错误,提示的是版本不符吧,给了两个数字,我忘了是什么.

搜索了一下论坛, 有人说要将nvidia-kernel-common 先 remove才行。我在启动686内核的时候删掉了 386 restricted modules, 386内核和nvidia-kernel-commo. 然后做了以下操作:
1) sudo depmod
2) 安装linux-restricted-modules-2.6.15-25-686,
这时候显示会连同nvidia-kernel-common一同装上
3)sudo apt-get install nvidia-glx
每次做这步的时候总是会将386的内核和restricted modules装上?

请问怎么解决这个问题, 可以在686的内核下使用nvidia驱动?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-01-03 11:17 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
你的nv驱动只有386版本,使用svn版本,就可以直接使用generic内核。如果你是686,你应该先说明自己系统的版本哦。不过情况类似。


_________________
● 鸣学


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-01-03 11:51 

注册: 2007-01-03 10:18
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
eexpress 写道:
你的nv驱动只有386版本,使用svn版本,就可以直接使用generic内核。如果你是686,你应该先说明自己系统的版本哦。不过情况类似。


不好意思,我不太明白你说的, 能说相信点吗? 什么是svn版本?


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-01-03 12:08 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
使用svn版本的nv驱动,就是私人打了补丁(hack0)的版本。 比如:
deb http://amaranth.selfip.com edgy lrm #nvidia-beta

不过这样的版本会带来升级nv的不兼容性。但是对于以前一段时间的内核版本有效。否则就是出现你说的情况,只能使用386内核。

另:你的系统发行版本,你还没说明的。别人都是用generic内核版本了。许多问题,都和这些版本的不同有关的。


_________________
● 鸣学


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-01-03 14:09 

注册: 2007-01-03 10:18
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
我安装的是6.06LTS, 装完后把内核升级到linux-image-2.6.15-26-686


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-01-03 14:13 

注册: 2007-01-03 10:18
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
另外,generic内核是什么? 我搜了一下怎没有?


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-01-03 14:21 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
generic是edgy版本的了。你的6.06里面没这个。你找找老帖子。breezy的版本,细节问题我都不记得了哦。
nv驱动的版本和linux-restricted-modules-common,xserver-xorg-core以及几个很重要的库有依赖关系的。


_________________
● 鸣学


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译