当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : ibm r51e 安装ait官方8.24.8驱动后usb鼠标失灵 (已解决)
帖子发表于 : 2007-01-04 14:05 

注册: 2007-01-01 23:28
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
机器:ibm r51e
设备:trackpoint(指点杆),显卡ati xpress 200M,usb鼠标,无触摸板。
系统:kubuntu 6.06.1
问题:安装kubuntu后,系统一切正常,usb鼠标,指点杆都能用。但一旦安装ati官方8.24.8驱动后,进入系统5分钟内
usb鼠标就失灵,但指点杆可以使用,系统其他也正常,但无法关机和重启,一点关机或重启就死的那了。

另:ubuntu 6.10安装系统后,鼠标也会不定期失灵。所以降到6.06,裸系统usb鼠标是好了,一装ait驱动,usb鼠标就失灵。

求有经验的大侠帮解决,谢谢!


最后由 tonyrdx 编辑于 2007-01-05 15:29,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-01-04 14:36 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
对比下xorg.conf和它的备份文件呢?其他的想不出哦。指点杆都能用哦。dmesg看是不是鼠标自动失去连接了。你都没说,鼠标重新插入,是否又正常。


_________________
● 鸣学


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-01-04 15:11 

注册: 2007-01-01 23:28
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
eexpress 写道:
对比下xorg.conf和它的备份文件呢?其他的想不出哦。指点杆都能用哦。dmesg看是不是鼠标自动失去连接了。你都没说,鼠标重新插入,是否又正常。

谢谢eexpress大侠帮助。
xorg.conf鼠标设置部分没什么区别,用sudo dpkg-reconfigure xserver-xorg,重新配置后,只要选fglrx,usb鼠标准挂。选ati就没问题。
插拔鼠标后dmesg在kubuntu6.06下的提示。
出错:
[17179703.040000] usb 1-2: USB disconnect, address 3
[17179707.040000] ohci_hcd 0000:00:13.0: IRQ INTR_SF lossage
[17179708.636000] usb 2-2: new low speed USB device using ohci_hcd and address 2
[17179709.636000] ohci_hcd 0000:00:13.1: Unlink after no-IRQ? Controller is probably using the wrong IRQ.
正常
[17179740.420000] usb 1-2: USB disconnect, address 3
[17179745.260000] usb 1-2: new low speed USB device using ohci_hcd and address 4
[17179745.476000] input: USB Optical Mouse as /class/input/input5
[17179745.476000] input: USB HID v1.10 Mouse [USB Optical Mouse] on usb-0000:00:13.0-2


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-01-04 15:21 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
引用:
ohci_hcd 0000:00:13.0: IRQ INTR_SF lossage
建议搜索这个。如果有相同的问题,英文网站多半会有这样的信息,你就可以找到方案了。我也伴你的福,增加了知识。 :lol:


_________________
● 鸣学


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-01-05 15:27 

注册: 2007-01-01 23:28
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
eexpress 写道:
引用:
ohci_hcd 0000:00:13.0: IRQ INTR_SF lossage
建议搜索这个。如果有相同的问题,英文网站多半会有这样的信息,你就可以找到方案了。我也伴你的福,增加了知识。 :lol:


终于搞定了! :D 要关闭apic。
具体方法如下:
编辑/boot/grub/menu.lst
kernel /vmlinuz-2.6.15-27-386 root=/dev/hda6 ro noapic irqpoll quiet splash
initrd /initrd.img-2.6.15-27-386

希望碰到usb鼠标失灵的朋友试试,应该可以解决问题。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-01-05 15:39 

注册: 2006-12-26 8:56
帖子: 21
送出感谢: 0 次
接收感谢: 0 次
看来我的本本还没装ati驱动,不过好像用起来没影响。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Exabot [Bot] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译