[问题]混音后音量调节不起作用

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
只身天涯
帖子: 19
注册时间: 2006-12-23 10:20
来自: NUC
送出感谢: 0
接收感谢: 0
联系:

[问题]混音后音量调节不起作用

#1

帖子 只身天涯 » 2007-01-07 17:50

RT用的6.10
先按WIKI里的方法装了不起作用。又用如下方法做了
# apt-get install libesd-alsa0
# gedit /etc/asound.conf


  改为:

CODE:
pcm.card0 {
type hw
card 0
}

pcm.!default {
type plug
slave.pcm "dmixer"
}

pcm.dmixer {
type dmix
ipc_key 1025
slave {
pcm "hw:0,0"
period_time 0
period_size 2048
buffer_size 32768
rate 48000
}
bindings {
0 0
1 1
}
}



  然后:

CODE:
# killall esd
# cp /etc/esound/esd.conf /etc/esound/esd.conf.DEFAULT
# gedit /etc/esound/esd.conf



  改为:

CODE:
[esd]
auto_spawn=1
spawn_options=-terminate -nobeeps -as 2 -d default
spawn_wait_ms=100
# default options are used in spawned and non-spawned mode
default_options=


  然后:

CODE:
# ln -fs /usr/lib/libesd.so.0 /usr/lib/libesd.so.1
结果混音倒是实现了
可是音量调节能调节但是音量没有任何变化,该怎么办啊?
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2007-01-07 17:56

不是音效里面有勾选混音的吗。这么复杂?
● 鸣学
只身天涯
帖子: 19
注册时间: 2006-12-23 10:20
来自: NUC
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 只身天涯 » 2007-01-08 9:57

那问题是当时我看的WIKI
没注意
现在要如何才能把音量控制搞好啊
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#4

帖子 eexpress » 2007-01-08 9:59

你先把以前的相关修改恢复罗。再到音效里面,勾选混音。
当然,如果你的声卡特殊。可能需要其他方式。到时候再说,先这样试试。
● 鸣学
只身天涯
帖子: 19
注册时间: 2006-12-23 10:20
来自: NUC
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 只身天涯 » 2007-01-08 12:00

eexpress 写了:你先把以前的相关修改恢复罗。再到音效里面,勾选混音。
当然,如果你的声卡特殊。可能需要其他方式。到时候再说,先这样试试。
郁闷的是我没有备份以前的配置啊
怎么办才好啊
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#6

帖子 eexpress » 2007-01-08 13:18

你不是安装wiki的修改的?难道是清空老文件后,修改的?有些文件有xxxxx.xxx~这样的自动备份。
● 鸣学
回复

回到 “常用硬件支持”