当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 15 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 有人在breezy下把9550的三D驱动起来了么?
帖子发表于 : 2005-10-07 21:35 
头像

注册: 2005-07-20 15:01
帖子: 266
送出感谢: 0 次
接收感谢: 0 次
麻烦贴一下详细过程啊!
官方的驱动版本比较低,装不上啊 :cry:


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2005-10-07 22:45 
论坛管理员

注册: 2005-03-27 0:06
帖子: 10111
系统: Ubuntu 12.04
送出感谢: 7
接收感谢: 128
和 horay 下的安装没有区别,去主站点搜索ati。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-10-10 19:31 

注册: 2005-10-10 19:19
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
俺今天装了一天ati9550得驱动也没装上,哪位高人指点一下
一共用了两种方法,第一种用ubuntu默认得ati驱动
udo apt-get install fglrx-driver
echo fglrx | sudo tee -a /etc/modules
sudo sed -i -e 's/"ati"/"fglrx"/' /etc/X11/xorg.conf
重启后发现不支持3d效果,opengl也打不开
2种,
去ati官方网站去下了驱动,编译成deb包
然后在安装linux-header包得时候发现breezy得内核是2.6.12得,但是搜索得时候没有发现2.6.12相对应得linux-header包,最新得Linux-header包是对内核2.6.11得,结果在make得时候出错
哪位达人在breezy有成功得麻烦贴一个详细得过程


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2005-10-13 14:24 
头像

注册: 2005-08-02 7:23
帖子: 773
地址: 上海
送出感谢: 0 次
接收感谢: 1
linux-restricted-modules包装了没有?fglrx.ko模块在里面,装上后才能启用3D加速.再装上xorg-driver-fglrx,改一下xorg.conf就可以了.


_________________
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2005-10-15 23:16 
头像

注册: 2005-10-05 11:15
帖子: 74
地址: http://bulaoge.com/?arete
送出感谢: 0 次
接收感谢: 0 次
我都是sudo apt-get install xorg-driver-fglrx
然后echo fglrx | sudo tee -a /etc/modules
接着sudo sed -i -e 's/"ati"/"fglrx"/' /etc/X11/xorg.conf
关机重启。
5.04和5.10都可以打开3D。

偶正好有个问题,借这里一并问了。

fglrxinfo的输出结果是
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9550 Generic
OpenGL version string: 1.3.5272 (X4.3.0-8.16.20)

fgl_glxgears的结果证明3D应该打开了
2520 frames in 5.0 seconds = 504.000 FPS
2492 frames in 5.0 seconds = 498.400 FPS
2355 frames in 5.0 seconds = 471.000 FPS
2443 frames in 5.0 seconds = 488.600 FPS
1929 frames in 5.0 seconds = 385.800 FPS
1959 frames in 5.0 seconds = 391.800 FPS
2181 frames in 5.0 seconds = 436.200 FPS
2335 frames in 5.0 seconds = 467.000 FPS

可是,glxgears命令出现三个齿轮(还转得很慢)之后,终端没有任何输出。
请教这是为什么?


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2005-10-16 9:05 
头像

注册: 2005-04-10 16:54
帖子: 2625
地址: 温州大学
送出感谢: 0 次
接收感谢: 1
glxinfo

display: :0 screen: 0
----------------------
direct rendering: Yes
----------------------

如果是Yes的话,应该是打开了!


_________________
我心无畏,源自于我心无知。
图片


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2005-10-17 12:45 
头像

注册: 2005-08-02 7:23
帖子: 773
地址: 上海
送出感谢: 0 次
接收感谢: 1
glxgears -iacknowledgethatthistoolisnotabenchmark
才可以输出结果.
另外,ATI又发布了最新驱动8.18.6,不知道什么时候能进breezy源.


_________________
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2005-10-17 21:51 
头像

注册: 2005-10-05 11:15
帖子: 74
地址: http://bulaoge.com/?arete
送出感谢: 0 次
接收感谢: 0 次
catinsnow 写道:
glxgears -iacknowledgethatthistoolisnotabenchmark
才可以输出结果.
另外,ATI又发布了最新驱动8.18.6,不知道什么时候能进breezy源.


这回可以了,谢谢!
不过可以请教为什么吗?以前都是直接glxgears的说?


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2005-10-17 22:03 
头像

注册: 2005-08-14 21:55
帖子: 58436
地址: 长沙
送出感谢: 4
接收感谢: 272
-iacknowledgethatthistoolisnotabenchmark
什么烂东西。作外星人搞。


_________________
● 鸣学


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2005-10-20 18:54 

注册: 2005-10-02 18:54
帖子: 43
送出感谢: 0 次
接收感谢: 0 次
我的9550就是按照官方的5.04的指南装的 ,用glxgears -iacknowledgethatthistoolisnotabenchmark 看了一下,可以跑3000多呢,不过我是全新安装的5.10


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2005-10-20 21:29 
头像

注册: 2005-08-02 7:23
帖子: 773
地址: 上海
送出感谢: 0 次
接收感谢: 1
-iacknowledgethatthistoolisnotabenchmark
大概意思是“我知道此工具不是性能测试”
避免用它的结果评判3D性能。


_________________
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2005-10-25 19:45 
头像

注册: 2005-07-01 13:09
帖子: 548
地址: 广西南宁
送出感谢: 0 次
接收感谢: 1
3840 frames in 5.1 seconds = 752.843 FPS
3000 frames in 5.1 seconds = 585.452 FPS
3480 frames in 5.1 seconds = 683.690 FPS
3120 frames in 5.2 seconds = 600.240 FPS
3840 frames in 5.1 seconds = 752.739 FPS
3600 frames in 5.1 seconds = 711.437 FPS
3720 frames in 5.1 seconds = 724.832 FPS
3600 frames in 5.0 seconds = 717.500 FPS
3894 frames in 5.0 seconds = 774.886 FPS
3960 frames in 5.1 seconds = 775.988 FPS
3960 frames in 5.1 seconds = 780.920 FPS
3960 frames in 5.1 seconds = 770.886 FPS
3960 frames in 5.1 seconds = 775.134 FPS
3960 frames in 5.1 seconds = 777.447 FPS
3960 frames in 5.1 seconds = 774.681 FPS
3960 frames in 5.1 seconds = 770.010 FPS
4067 frames in 5.1 seconds = 800.799 FPS
4080 frames in 5.0 seconds = 808.241 FPS
4080 frames in 5.1 seconds = 804.237 FPS
3960 frames in 5.2 seconds = 768.776 FPS
3600 frames in 5.1 seconds = 710.164 FPS
4080 frames in 5.0 seconds = 808.514 FPS
我没有装到ATI的9550的驱动。。偶装好系统就试的效果:(
留个备份装好驱动在比比看
装好驱动以后的我的是9550的。。。。
10102 frames in 5.0 seconds = 2020.203 FPS
10103 frames in 5.0 seconds = 2020.574 FPS
10102 frames in 5.0 seconds = 2020.316 FPS
10103 frames in 5.0 seconds = 2020.489 FPS
10103 frames in 5.0 seconds = 2020.409 FPS
10102 frames in 5.0 seconds = 2020.280 FPS
10103 frames in 5.0 seconds = 2020.412 FPS
10102 frames in 5.0 seconds = 2020.293 FPS
10103 frames in 5.0 seconds = 2020.494 FPS
10101 frames in 5.0 seconds = 2020.180 FPS
10103 frames in 5.0 seconds = 2020.565 FPS
10102 frames in 5.0 seconds = 2020.224 FPS
10072 frames in 5.0 seconds = 2009.893 FPS


_________________
最新座驾:华晨中华酷宝 1.8T手动


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2005-10-26 0:23 
头像

注册: 2005-08-02 7:23
帖子: 773
地址: 上海
送出感谢: 0 次
接收感谢: 1
我的ATI9100装上驱动之后:
10382 frames in 5.0 seconds = 2076.322 FPS
10383 frames in 5.0 seconds = 2076.461 FPS
10382 frames in 5.0 seconds = 2076.295 FPS
10350 frames in 5.0 seconds = 2069.984 FPS
看来和CPU关系比较大,运行时CPU都是满负荷的。而且我用radeon模块也得到了1900FPS的成绩,但玩PPRACER时差多了,WAR3也不可以玩。看来这个成绩真的不能用来标称3D性能。


_________________
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2005-10-26 10:28 
头像

注册: 2005-04-07 20:15
帖子: 105
送出感谢: 0 次
接收感谢: 0 次
为什么我的就不行!x.log说无法驱动agp


_________________
试着用它来代替windows吧,你会重新找回当年的感动!


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2005-10-31 14:04 
头像

注册: 2005-08-02 7:23
帖子: 773
地址: 上海
送出感谢: 0 次
接收感谢: 1
annerose 写道:
为什么我的就不行!x.log说无法驱动agp

最后附上设备名和log原文~ :)


_________________
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 15 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译