当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 乱搞搞,竟然可以无线上网了,怪事
帖子发表于 : 2007-01-21 2:44 

注册: 2007-01-16 15:41
帖子: 125
送出感谢: 0 次
接收感谢: 0 次
我本本是BenQ Joybook 7000,Intel 2200BG网卡,装完Ubuntu后无线网卡虽然认出来,但是一直不能上网。试了很多方法,ndiswrapper,madwifi,linux-wlan-ng,ipw2200,netmang-manager等等,因为是菜鸟,对Linux的软件安装不懂,这些东东总要make,make install ,总会出这样那样的错误,少些包,少些源码,反正不明白,搞了一个星期也没装成功一个。
今天有点搞明白怎么弄这些东东了,编译安装这些东东需要相应的内核源码和一些包,弄好这些东东后又开始新一轮试验工程。
第一:试验madwifi,简单几步,安装成功,没有认出网卡,东搞西半天不行,放弃,删除。
第二:试验ndiswrapper,简单几步,安装成功,东搞西半天没有认出网卡,于是把原来的ipw2200删除,认出网卡,网卡从eth1变成了wlan0,但是从dmesg信息中可以看出ndiswrapper在路由器认证的时候失败。我就把路由器从共享密钥改为开放系统,去掉密码认证,配置表态IP,ndiswrapper行了,无线网络有信号了,但是网络数据包好象只能进不能出,上不了外网,并且装完ndiswrapper玩玩一会就会死机不动了,我关机开机关机开机,总想会有解决办法,奇怪了,无线网双从wlan0变成原来的eth1,不明白,还死机,没办法,删除。
第三:试验linux-wlan-ng,这个安装不成功,少个包,放弃。
最后,我一下决心双装回ipw2200,重启,奇怪无线上网好了,可以上网了,太高兴了。

这样乱搞搞,竟然搞好了,不过也不知道是不是我把路由器从共享密钥改为开放系统的原因,因为Ubuntu装安的完后就是用IPW2200。


页首
 用户资料  
 
2 楼 
 文章标题 : 又发现一怪问题
帖子发表于 : 2007-01-21 6:25 

注册: 2007-01-16 15:41
帖子: 125
送出感谢: 0 次
接收感谢: 0 次
我在使用过程中又发现一怪问题,必须把有线网关掉,ifconfig eth0 down,然后无线网才能上网。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-01-25 9:33 
头像

注册: 2005-10-16 13:24
帖子: 958
地址: 四川成都
送出感谢: 2
接收感谢: 0 次
看看你的路由,是不是默认走eth0的路由了?
多个网卡建议你单独配置路由


_________________
Thank you Ubuntu Team!!!!
I still can't belive this is free...


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译