[问题]Ubuntu误检测到实际根本没有的光驱,如何解决?

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
KEYI22
帖子: 12
注册时间: 2006-01-09 17:16
送出感谢: 0
接收感谢: 0

[问题]Ubuntu误检测到实际根本没有的光驱,如何解决?

#1

帖子 KEYI22 » 2007-01-22 12:20

我有两块硬盘hda、hdb,一个光驱hdc。这两天把旧的光驱换了。
照理说应该和原来没变化,但结果/dev下多出了一个hdd!
接着每回启动Ubuntu都回去找hdd,然后就不断出错,连机器都无法启动。
能不能让Ubuntu把错认的hdd删掉?

哪位帮忙解决下,谢了!
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2007-01-22 12:29

live进去,rm呢?
● 鸣学
KEYI22
帖子: 12
注册时间: 2006-01-09 17:16
送出感谢: 0
接收感谢: 0

#3

帖子 KEYI22 » 2007-01-22 14:51

没用,重启时好像/dev/hdd又重新生成了。
以下是dmesg | grep "hdd"的输出:

代码: 全选

[4294671.758000]     ide1: BM-DMA at 0xf008-0xf00f, BIOS settings: hdc:DMA, hdd:pio
[4294673.561000] hdd: SCR-830, ATAPI CD/DVD-ROM drive
[4294675.841000] hdd: status error: status=0x00 { }
[4294675.841000] hdd: status error: status=0x00 { }
[4294675.841000] hdd: status error: status=0x00 { }
[4294675.841000] hdd: status error: status=0x00 { }
[4294675.891000] hdd: ATAPI reset complete
[4294675.891000] hdd: status error: status=0x00 { }
[4294675.891000] hdd: status error: status=0x00 { }
[4294675.891000] hdd: status error: status=0x00 { }
[4294675.891000] hdd: status error: status=0x00 { }
[4294675.941000] hdd: ATAPI reset complete
[4294675.941000] hdd: status error: status=0x00 { }
[4294675.941000] hdd: ATAPI CD-ROM drive, 0kB Cache
...
是不是光驱不兼容?
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#4

帖子 eexpress » 2007-01-22 15:01

c和d是认到一起了。BIOS settings: hdc:DMA, hdd:pio
换跳线呢,换ide线呢。我乱猜的。你改好了,对大家都是经验。 :lol:
或者bios里面看设置交换ide1的磁盘没。
● 鸣学
KEYI22
帖子: 12
注册时间: 2006-01-09 17:16
送出感谢: 0
接收感谢: 0

#5

帖子 KEYI22 » 2007-01-22 18:12

应该是硬件问题,我又换了一个光驱就没问题了。
回复

回到 “常用硬件支持”