(Tenda)腾达TWL541U无线USB网卡安装(edgy)

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
edelweiss
帖子: 97
注册时间: 2006-12-17 13:52
送出感谢: 0
接收感谢: 0

(Tenda)腾达TWL541U无线USB网卡安装(edgy)

#1

帖子 edelweiss » 2007-01-27 23:42

今天兴起想去弄只无线网卡试下,本想买TP-Link的,但价格不尽人意,无意中看到了腾达,之前未曾用,不知如何,还是弄个试试。回家一看光碟内容,全是MSWindows的驱程,简直傻了眼,插上去之后,灯长亮,用lsusb只能看到XXXX:XXXX的字样,但后面连个英文都无啊,:em18 在论坛找了N多个网页狂扫了几个小时, :em20 终于看到了ndiswrapper这个东东,viewtopic.php?t=74&highlight=ndiswrapper
但看到话源上的有问题,用apt-get install试装了,可以顺利通过,但就是到了sudo modprobe ndiswrapper 这里出现错误,看来真的不行,只好到http://ndiswrapper.sourceforge.net/这里下了一个,

代码: 全选

tar zxf ndiswrapper-1.34.tar.gz
cd ndiswrapper-1.34
make
sudo make install
然后再去到光碟中的TWL541U目录下,找到相应netMw225.inf文件的位置

代码: 全选

ndiswrapper -i netMw225.inf
ndiswrapper -m
sudo modprobe ndiswrapper 
此时网卡上的灯开始狂闪一阵,重启之后,再插入网卡,终于可以用啦。
用ifconfig -a看一下
eth0 链路封装:以太网 硬件地址 00:19:21:29:E5:9A
inet 地址:192.168.0.101 广播:192.168.0.255 掩码:255.255.255.0
inet6 地址: fe80::219:21ff:fe29:e59a/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 跃点数:1
接收数据包:919 错误:0 丢弃:0 过载:0 帧数:0
发送数据包:1029 错误:0 丢弃:0 过载:0 载波:0
碰撞:0 发送队列长度:1000
接收字节:734046 (716.8 KiB) 发送字节:279345 (272.7 KiB)
中断:58

lo 链路封装:本地环回
inet 地址:127.0.0.1 掩码:255.0.0.0
inet6 地址: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 跃点数:1
接收数据包:68 错误:0 丢弃:0 过载:0 帧数:0
发送数据包:68 错误:0 丢弃:0 过载:0 载波:0
碰撞:0 发送队列长度:0
接收字节:5348 (5.2 KiB) 发送字节:5348 (5.2 KiB)

sit0 链路封装:IPv6-in-IPv4
NOARP MTU:1480 跃点数:1
接收数据包:0 错误:0 丢弃:0 过载:0 帧数:0
发送数据包:0 错误:0 丢弃:0 过载:0 载波:0
碰撞:0 发送队列长度:0
接收字节:0 (0.0 b) 发送字节:0 (0.0 b)

vmnet1 链路封装:以太网 硬件地址 00:50:56:C0:00:01
inet 地址:172.16.211.1 广播:172.16.211.255 掩码:255.255.255.0
inet6 地址: fe80::250:56ff:fec0:1/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 跃点数:1
接收数据包:0 错误:0 丢弃:0 过载:0 帧数:0
发送数据包:57 错误:0 丢弃:0 过载:0 载波:0
碰撞:0 发送队列长度:1000
接收字节:0 (0.0 b) 发送字节:0 (0.0 b)

vmnet8 链路封装:以太网 硬件地址 00:50:56:C0:00:08
inet 地址:172.16.105.1 广播:172.16.105.255 掩码:255.255.255.0
inet6 地址: fe80::250:56ff:fec0:8/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 跃点数:1
接收数据包:0 错误:0 丢弃:0 过载:0 帧数:0
发送数据包:57 错误:0 丢弃:0 过载:0 载波:0
碰撞:0 发送队列长度:1000
接收字节:0 (0.0 b) 发送字节:0 (0.0 b)

wlan0 链路封装:以太网 硬件地址 06:50:43:A0:84:E4
UP BROADCAST MULTICAST MTU:1500 跃点数:1
接收数据包:0 错误:0 丢弃:0 过载:0 帧数:0
发送数据包:0 错误:0 丢弃:0 过载:0 载波:0
碰撞:0 发送队列长度:1000
接收字节:0 (0.0 b) 发送字节:0 (0.0 b)
今天任务完成,明天再设下路由同网卡看看感觉如何。 :em76 要去睡觉啦。 :em93
hover
帖子: 48
注册时间: 2007-01-21 0:20
送出感谢: 0
接收感谢: 0

#2

帖子 hover » 2007-01-28 12:44

楼主,我按照你的方法安装后重启,ifconfig -a看不到无线网卡,是什么原因?
edelweiss
帖子: 97
注册时间: 2006-12-17 13:52
送出感谢: 0
接收感谢: 0

#3

帖子 edelweiss » 2007-02-03 15:02

还要加上以下步骤,
USB的无线网卡也不能即插即用,拔掉再插上的时候,需要:
$ sudo ifdown -a
$ sudo ifup -a
因为之前我曾安装过HP方面的程序,而且支持USB方的即插即用,所以不用运行以上的语句。
另外,偶也发觉重启之后,如果仍插着USB的网卡,我台机就会不能进入,还没有找出个所有。
如果不是高手,建议个装个network-manager-gnome会用得顺手一点

关于network-manager-gnome在重启之后可能还会有些问题可以参考一下这里viewtopic.php?t=22877&highlight=nm-applet
回复

回到 “常用硬件支持”