[分享]分辨率和刷新率无效的解决办法。

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
gamexg
帖子: 72
注册时间: 2007-01-27 14:06
送出感谢: 0
接收感谢: 0

[分享]分辨率和刷新率无效的解决办法。

#1

帖子 gamexg » 2007-01-30 16:49

配置文件为
/etc/X11/xorg.conf
修改
Section "Monitor"
段里的
HorizSync 28.0 - 51.0
VertRefresh 43.0 - 60.0
为你的显示器的参数
HorizSync为行频
VertRefresh为场频
注意:行频和场频在显示器后面应该标出,否则查显示器手册。这一步非常建议你进行,否则系统可能认为你的显示器不支持你指定的设置,将跳过你指定的设置。

确保
Section "Screen"
段里有你需要的分辨率,X将优先使用前面的设置。

重启X后运行
xrandr
可显示当前分辨率和刷新率,可用的分辨率和刷新率列表。

按照上面的设置刷新率将自动设置。

如果刷新率不符合你的要求可以试用下面的两个方法。

方法一:
修改
Modes "1024x768" "800x600" "640x480"

Modes "1024x768_85" "800x600" "640x480"
这将强制使用1024x768 的分辨率 85的刷新率(如果行频和场频未设置有可能无效)。

方法二:
运行 gtf 1024 768 85
gamexg@ubuntu:~$ gtf 1024 768 85

# 1024x768 @ 85.00 Hz (GTF) hsync: 68.60 kHz; pclk: 94.39 MHz
Modeline "1024x768_85.00" 94.39 1024 1088 1200 1376 768 769 772 807 -HSync +Vsync

将输出的内容考到 Section "Monitor" 段里。

1024 768 为分辨率
85 为刷新率


注意:如果行频和场频不正确系统可能认为你的显示器不支持你要求的模式,系统将跳过你指定的模式。
头像
ggjjzhzz
帖子: 137
注册时间: 2006-12-21 9:46
送出感谢: 0
接收感谢: 0

#2

帖子 ggjjzhzz » 2007-01-30 19:28

我有一个更好的办法:
$ sudo nvidia-settings
在里面可以改的。
gamexg
帖子: 72
注册时间: 2007-01-27 14:06
送出感谢: 0
接收感谢: 0

#3

帖子 gamexg » 2007-01-31 8:56

ggjjzhzz 写了:我有一个更好的办法:
$ sudo nvidia-settings
在里面可以改的。
在哪里?
feng3243
帖子: 210
注册时间: 2006-08-29 23:08
来自: 广东茂名
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 feng3243 » 2007-02-01 15:10

ggjjzhzz 写了:我有一个更好的办法:
$ sudo nvidia-settings
在里面可以改的。
在哪里改的呢?
做一个精通linux的高手--不易;
做一个熟练的linux使用者--不难。
头像
cime63
帖子: 286
注册时间: 2007-01-28 11:53
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 cime63 » 2007-02-01 16:48

在终端中输入$ sudo nvidia-settings ,然后会打开一个管理工具,可以进行设置.
gamexg
帖子: 72
注册时间: 2007-01-27 14:06
送出感谢: 0
接收感谢: 0

#6

帖子 gamexg » 2007-02-01 16:59

cime63 写了:在终端中输入$ sudo nvidia-settings ,然后会打开一个管理工具,可以进行设置.
我这里没有发现有可以设置分辨率和刷新率的地方阿
lisir
帖子: 1187
注册时间: 2006-04-29 14:54
来自: 山东
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 lisir » 2007-02-01 20:17

选择第二项“x server display configuration"
学会看置顶帖、精华帖。
学会使用搜索。
常见问题解答和发帖需知
gamexg
帖子: 72
注册时间: 2007-01-27 14:06
送出感谢: 0
接收感谢: 0

#8

帖子 gamexg » 2007-02-01 20:24

lisir 写了:选择第二项“x server display configuration"
我这里没有这项,可能是驱动版本的问题
我的版本是1.0-8776
mesocool
帖子: 113
注册时间: 2005-03-27 17:11
系统: Linux Mint 14 Nadia
来自: Seattle, USA
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 mesocool » 2007-07-10 3:48

lisir 写了:选择第二项“x server display configuration"
这里也改不了,频率只能到60。。
vision
帖子: 88
注册时间: 2006-04-14 1:12
来自: 上海
送出感谢: 0
接收感谢: 0

#10

帖子 vision » 2007-07-10 20:13

sudo dpkg-reconfigure xserver-xorg

在最后一步里面有自动侦测显示器。选好你显示器的最高支持分辨率以及刷新率

至于其他的或者默认或者按需设置
图片
the flying flower
that
changes the colour of my day
头像
fearmind
帖子: 212
注册时间: 2007-08-24 13:32
送出感谢: 0
接收感谢: 0

#11

帖子 fearmind » 2007-09-10 11:40

vision 写了:sudo dpkg-reconfigure xserver-xorg

在最后一步里面有自动侦测显示器。选好你显示器的最高支持分辨率以及刷新率

至于其他的或者默认或者按需设置
楼上正解,问题已解决,谢谢~~~~~~~
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#12

帖子 eexpress » 2007-09-10 12:24

如果使用ddcprobe的,宽屏有问题的。别想都自动。
● 鸣学
头像
1973liul_xxxx
帖子: 250
注册时间: 2006-07-29 20:50
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 1973liul_xxxx » 2007-09-11 22:42

ggjjzhzz 写了:我有一个更好的办法:
$ sudo nvidia-settings
在里面可以改的。
谢谢!终于搞定!可以上到91了哈哈哈....
向那些默默支持Ubuntu和Linux的兄弟致敬!
我的百度空间:
http://hi.baidu.com/%B0%A2%CC%B8
fauyin
帖子: 7
注册时间: 2007-11-11 19:59
送出感谢: 0
接收感谢: 0

变成100HZ出问题了。

#14

帖子 fauyin » 2007-11-13 19:42

电脑先是60HZ的刷新率,按照论坛贴子的方法,变成了100HZ,一进入X登录界面电脑就闪个不停,根本看不清。重启依然如是。
fearmind 写了:
vision 写了:sudo dpkg-reconfigure xserver-xorg

在最后一步里面有自动侦测显示器。选好你显示器的最高支持分辨率以及刷新率

至于其他的或者默认或者按需设置
楼上正解,问题已解决,谢谢~~~~~~~
请问怎么回调刷新率呀,我想先试试75,再试试能不能上85HZ。我在WIN2000中就是60.1KHZ 75HZ.
luofeng
帖子: 38
注册时间: 2007-08-25 13:11
来自: ecjtu
送出感谢: 0
接收感谢: 0

#15

帖子 luofeng » 2007-12-27 21:38

vision 写了:sudo dpkg-reconfigure xserver-xorg

在最后一步里面有自动侦测显示器。选好你显示器的最高支持分辨率以及刷新率

至于其他的或者默认或者按需设置
我也用了这种方法, 不过还是没有用!
专注,才能追逐目标,才能追求完美。
回复

回到 “常用硬件支持”