我遇到了一个很奇怪的问题,我的系统在开机一段时间后就没有声音了。

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
vanjohn
帖子: 27
注册时间: 2012-12-25 15:46
送出感谢: 3 次
接收感谢: 0

我遇到了一个很奇怪的问题,我的系统在开机一段时间后就没有声音了。

#1

帖子 vanjohn » 2013-01-29 16:09

登陆以后是有声音的,但是用一段时间以后声音就悄然消失了,包括系统声音,播放器的声音。
我用的是 ubuntu 12.10 root用户登陆,登陆以后手动运行下面的代码打开声音管理器

代码: 全选

pulseaudio --system --daemonize --high-priority --log-target=syslog --disallow-exit --disallow-module-loading=0
头像
pl_014
帖子: 201
注册时间: 2009-08-12 16:38
系统: linux mint
来自: 没准
送出感谢: 0
接收感谢: 2 次
联系:

Re: 我遇到了一个很奇怪的问题,我的系统在开机一段时间后就没有声音了。

#2

帖子 pl_014 » 2013-01-29 17:44

试试使用录音机程序,看看是硬件上是衰减还是某些bug等等。
不要拿arch的稳定性代表linux的稳定性,不要拿gentoo的易用性代表linux的易用性,不要拿fvwm的ui代表linux的ui,不要拿红旗linux在桌面上的表现代表linux在桌面上的表现。
在你准备以一幅理性的腔调反驳别人的观点之前要先审视一下自己这样是否理性。
除掉那些收费软件、盗版软件、流氓软件、间谍软件和木马之外,windoze这一生态系统下的日用软件还是以开源软件和跨平台软件为主,所以我没有理由不用linux,只是windoze比linux多出了大量的游戏,和一些专业软件而已。
头像
tang.zhe
帖子: 1424
注册时间: 2010-07-15 13:31
送出感谢: 71 次
接收感谢: 22 次

Re: 我遇到了一个很奇怪的问题,我的系统在开机一段时间后就没有声音了。

#3

帖子 tang.zhe » 2013-01-29 17:56

12.10下的wine好像有次bug
vanjohn
帖子: 27
注册时间: 2012-12-25 15:46
送出感谢: 3 次
接收感谢: 0

Re: 我遇到了一个很奇怪的问题,我的系统在开机一段时间后就没有声音了。

#4

帖子 vanjohn » 2013-03-01 17:46

tang.zhe 写了:12.10下的wine好像有次bug
难道是wine的错?
vanjohn
帖子: 27
注册时间: 2012-12-25 15:46
送出感谢: 3 次
接收感谢: 0

Re: 我遇到了一个很奇怪的问题,我的系统在开机一段时间后就没有声音了。

#5

帖子 vanjohn » 2013-03-01 17:47

pl_014 写了:试试使用录音机程序,看看是硬件上是衰减还是某些bug等等。
录音及在哪?
头像
pl_014
帖子: 201
注册时间: 2009-08-12 16:38
系统: linux mint
来自: 没准
送出感谢: 0
接收感谢: 2 次
联系:

Re: 我遇到了一个很奇怪的问题,我的系统在开机一段时间后就没有声音了。

#6

帖子 pl_014 » 2013-03-02 17:25

vanjohn 写了:
pl_014 写了:试试使用录音机程序,看看是硬件上是衰减还是某些bug等等。
录音及在哪?
linux下的所有程序都是有自己的名字的,录音机也不例外,可以从网上搜搜,不过我搜到的冒似官方源里没有,你也试试吧。一般地,gnome和kde等比较老的桌面系统下都会自带录音机程序,你也可以试试找找。
还有一个方法是执行命令cat /dev/audio > test0.au(可能需要root权限),但是在我的系统里没这个文件。
不要拿arch的稳定性代表linux的稳定性,不要拿gentoo的易用性代表linux的易用性,不要拿fvwm的ui代表linux的ui,不要拿红旗linux在桌面上的表现代表linux在桌面上的表现。
在你准备以一幅理性的腔调反驳别人的观点之前要先审视一下自己这样是否理性。
除掉那些收费软件、盗版软件、流氓软件、间谍软件和木马之外,windoze这一生态系统下的日用软件还是以开源软件和跨平台软件为主,所以我没有理由不用linux,只是windoze比linux多出了大量的游戏,和一些专业软件而已。
回复

回到 “常用硬件支持”