当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 每次都要重新安装 显卡驱动才能进系统
帖子发表于 : 2007-02-06 17:09 

注册: 2006-10-30 12:18
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
我按照论坛的提示安如下步骤安装 nvidia驱动:
从nVIDIA官方网站下载驱动包,手动安装驱动程序。

从官方网站上(http://www.nvidia.com/object/linux_display_ia32_1.0-9746.html)下选择适合自己配置的驱动包,分为32位和64位的。

解决安装驱动的包依赖问题

sudo apt-get install linux-headers-$(uname -r) libc6-dev

* 安装驱动,必需在真正的命令终端操作(按Ctrl+Alt+F1切换),登录,输入以下命令:

sudo /etc/init.d/gdm stop
sudo sh NVIDIA-Linux-x86-1.0-9625-pkg1.run

安装结束后,系统将提示是否启用新的配置文件,选择“是yes”

在终端里执行以下命令重启GDM。

sudo /etc/init.d/gdm start

注意:通过这种方法安装驱动,每一次系统内核升级后,都必须重新安装一次显卡驱动。下面这个命令可以查看你的显卡是否已经支持direct rendering

glxinfo | grep direct

如果你的驱动安装正确了,这个命令应该会出现下面这样的提示:

direct rendering: Yes

* 这个提示说明你的显卡驱动已经OK了。如果得到的是其他提示,试试用nVIDIA的配置工作重新配置,再重启GDM;

sudo nvidia-xconfig



这样 装好后 ,可以进入系统 ,可是 如果我重启机器 ,还需要同样执行上述的步骤,每次都是这样。
有没有谁知道这是什么问题啊?
谢谢了


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-02-06 18:17 
头像

注册: 2006-07-14 18:56
帖子: 345
地址: Apple Valley, Planet Tux, Linux System
送出感谢: 0 次
接收感谢: 0 次
你是不是没把nvidia-glx、 nvidia-settings和nvidia-kernel-common卸载啊?如果是,把它们卸载了再装官方驱动;如果不是把X的输出贴出来。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译