ATI卡,成功安装的个人经验分享

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
changkongyan
帖子: 33
注册时间: 2006-11-12 8:36
送出感谢: 0
接收感谢: 0

ATI卡,成功安装的个人经验分享

#1

帖子 changkongyan » 2007-02-09 12:45

Ubuntu 的安装可谓是力尽艰辛啊,我的电脑ati显卡x700,相信论坛上的很多人都碰到了我类似的问题,并且没有一个彻底的解决方法吧(因为也查了n多这种帖子)下面讲讲我的个人安装的整个过程和总结的思路,希望对各位有所帮助

1安装过程
先是我下载了一个desktop的盘子,也就是livecd。试过n此,因无法进入而告终,泪奔.....查找帖子是ait的显卡对linux的驱动支持不太好的缘故,无法使用x-windows而至。许多达人建议用alternate安装,也就是文本安装,安装成功,但是没法开机....哭死!不得已,只好安装兼容性一流的hiweed,成功了,甚至连驱动都不需要各种特效都能使用。不知是界面的缘故还是得不到永远是最好的,总给我流下些许遗憾。 再试!

刻录一张dvd版本的,情况还是一样,不能x-windows.......于是恨透了ati 毅然决定挥泪告别Ubuntu
今天,在巧合的情况下把dvd关盘放入,点了使用安全图形模式,尽然进了livecd?在惊讶之于安装之!问题又随之而来,硬盘分的时候说系统进行的测试发现了未更正的错误 ,不管了next再说,安装成功后重启,果然...还是进不去......未更正的错误,我想应该是磁盘错误,于是在windows下的每个盘用磁盘扫描,最后一次安装,居然成功了,哈哈

以上是我的整个过程,下面讲讲我的一些想法:
(1)之前安装的hiweed在品旁留下了些什么正是Ubuntu 所需要的,所以成功了
(2)由于livecd的容量问题,所以没有显卡调试工具而dvd版本有,所以dvd 以l安全图形模式成功进入
(3)第三种可能就是....上帝不忍心看我如此折腾自己的电脑,于是让我安装成功了

为方便各位ati不能安装的烦恼,我将论坛的各种应对方法合辑一下,遗漏的希望大家加一下:

1:用alternate CD装就好了 ~ 安装结束别着急进入X-window 从recovery模式进入 输入下列命令

代码:

sudo apt-get update

sudo apt-get install xorg-driver-fglrx

sudo depmod -a


然后初始化显卡驱动
代码:

sudo aticonfig --initial


2:在下载安装驱动之前必须连接好网络,我是网通宽带用户,所以现执行:
pppoeconf
根据提示一步一步做,连接好网络之后可以下载安装我们的显卡驱动了:
sudo apt-get update

sudo apt-get install linux-restricted-modules-$(uname -r)

sudo apt-get install xorg-driver-fglrx

echo fglrx | sudo tee -a /etc/modules

sudo sed -i -e 's/"ati"/"fglrx"/' /etc/X11/xorg.conf
之后执行:
sudo killall gdm

gdm

这样就可以重新启动X界面,进入图形界面将Ubuntu成功安装
安装好以后的新操作系统刚才我们安装的驱动还是没有的,所以不要进入图形界面的系统中,进入文本界面的系统,重新执行上面的命令,就可以了。

3:直接用hiweed 兼容性好

4:以在命令行界面里
自己修改 /etc/X11/xorg.conf 文件,把它改成适合你显示器的配置。(楼主你的显示器是不是很老??)
我上次就是改高了,也出现你这个错误。。。。。

5:默认的ati不行,要么改成vesa,进入到xwindow再装官方驱动,或者在字符状态下,在命令行直接安装官方的驱动是个不错的选择。
上次由 changkongyan 在 2007-02-09 13:37,总共编辑 2 次。
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#2

帖子 zhuqin_83 » 2007-02-09 12:53

先加精,让遇到同样问题的朋友好找一些。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
alenking
帖子: 6
注册时间: 2007-02-06 9:27
送出感谢: 0
接收感谢: 0

#3

帖子 alenking » 2007-02-23 8:13

很好,本人确认过了,是显卡问题,你把它搞一下就了可以了,用X700的都会这样,我的到现在还不能识别为ATI X700,只能用vesa,感到好悲哀哦
头像
wyg1258
帖子: 654
注册时间: 2006-09-12 19:44
来自: whu
送出感谢: 0
接收感谢: 0

#4

帖子 wyg1258 » 2007-02-23 11:43

我的 X550 同样遇到了该问题~~~
三年将拜君赐
帖子: 20
注册时间: 2007-02-18 14:10
送出感谢: 0
接收感谢: 0

#5

帖子 三年将拜君赐 » 2007-02-23 16:20

不知道ATI M9700会不会这样
头像
cdhs999
帖子: 61
注册时间: 2006-04-23 18:39
送出感谢: 0
接收感谢: 0

#6

帖子 cdhs999 » 2007-03-12 11:50

谢谢你提供的资料,以后有类似的问题可以参考。
不知道X300会不会出现这样的问题
samuelshi
帖子: 101
注册时间: 2006-04-13 9:57
送出感谢: 0
接收感谢: 0

#7

帖子 samuelshi » 2007-03-30 17:18

cdhs999 写了:谢谢你提供的资料,以后有类似的问题可以参考。
不知道X300会不会出现这样的问题


我用的ati x300se的显卡,Ubuntu刚装好没法进x-windows,后来在xorg.conf里将"ati"改成"radeon"就好了
头像
jarryson
帖子: 4002
注册时间: 2005-08-14 19:53
送出感谢: 1 次
接收感谢: 2 次
联系:

#8

帖子 jarryson » 2007-03-30 22:25

楼上的redeon应该是开源的驱动

开源的驱动比较方便呢。。虽然官方的支持的好。但是某些特性官方的不支持。
心林
帖子: 3
注册时间: 2007-04-11 13:04
送出感谢: 0
接收感谢: 0

#9

帖子 心林 » 2007-04-12 17:27

我也是进不了x windows呀,我最近几天装了几个版本的LINUX 都不成功呀!差点想跳楼 :( ,现在试下楼主的方法,看看行不行?
头像
wangliuru
帖子: 69
注册时间: 2007-04-09 13:35
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 wangliuru » 2007-04-12 18:09

For ATI black screen problem try

If u want to install the driver in the GUI

firstly key in

live vga=771

in the live CD startup screen

then after u hear the login sound

use ctrl+alt+F2


try key in

Option "CRT2Position" "clone"
Option "MonitorLayout" "LVDS,Auto"

in the Device Section of the /etc/X11/xorg.conf

then u

/etc/init.d/gdm restart

u will be able to see the GUI. then u do ur bussiness.
心林
帖子: 3
注册时间: 2007-04-11 13:04
送出感谢: 0
接收感谢: 0

#11

帖子 心林 » 2007-04-13 12:47

I frist install hiweed live cd.it can run x-window.Then I copy xorg.conf to my D disk.
when I install ubuntu linux 6.10,I copy xorg.conf of hiweed live cd to ubuntu's X11 folder.
X-window can run!I think configur of xorg.conf.
头像
ipv6now
帖子: 759
注册时间: 2006-09-30 1:08
来自: QingDao
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 ipv6now » 2007-04-13 13:11

现在觉得用amd的卡就是一种煎熬
dksadhorse
帖子: 8
注册时间: 2007-04-18 14:21
送出感谢: 0
接收感谢: 0

#13

帖子 dksadhorse » 2007-04-27 20:41

ati,ati,ati。郁闷啊
头像
goodlucky
帖子: 113
注册时间: 2007-03-27 14:08
来自: 郑州市
送出感谢: 0
接收感谢: 0
联系:

#14

帖子 goodlucky » 2007-04-28 22:38

ati,ati 我可是从始都看好你呢,现在呢,唉!!
华硕Z99H54SC
英特尔酷睿双核 T5450.G8400独显.
* 250G海量硬盘.2G内存.
* 14寸宽屏,DVD刻录, 内置无线网卡,
DVD Super-Multi DL
========
Ubuntu 8.04
raulos
帖子: 7
注册时间: 2007-04-30 14:23
送出感谢: 0
接收感谢: 0

#15

帖子 raulos » 2007-05-08 16:24

在Ubuntu7.04里,我用ATI的R9550,一切正常,用“受限驱动”也一切正常!
无论是NV还是ATI,习惯就好!
回复

回到 “常用硬件支持”