有没有人在ubuntu edgy下装过intel 915GM的驱动哈?

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
FreePeter
帖子: 2
注册时间: 2007-02-24 10:52
送出感谢: 0
接收感谢: 0

有没有人在ubuntu edgy下装过intel 915GM的驱动哈?

#1

帖子 FreePeter » 2007-02-24 10:55

偶从intel官网下的驱动,然后sudo ./install.sh,结果安装了在
Compiling new agpgart module...
Compiling DRM module...
时出错,信息如下:
make -C /lib/modules/2.6.17-11-generic/build SUBDIRS=/home/freepeter/download/dripkg/agpgart-2.0 modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.17-11-generic'
CC [M] /home/freepeter/download/dripkg/agpgart-2.0/backend.o
/home/freepeter/download/dripkg/agpgart-2.0/backend.c:69: error: conflicting types for ‘agp_backend_acquire’
include/linux/agp_backend.h:105: error: previous declaration of ‘agp_backend_acquire’ was here
/home/freepeter/download/dripkg/agpgart-2.0/backend.c:77: error: conflicting types for ‘agp_backend_acquire’
include/linux/agp_backend.h:105: error: previous declaration of ‘agp_backend_acquire’ was here
/home/freepeter/download/dripkg/agpgart-2.0/backend.c:89: error: conflicting types for ‘agp_backend_release’
include/linux/agp_backend.h:106: error: previous declaration of ‘agp_backend_release’ was here
/home/freepeter/download/dripkg/agpgart-2.0/backend.c:93: error: conflicting types for ‘agp_backend_release’
include/linux/agp_backend.h:106: error: previous declaration of ‘agp_backend_release’ was here
/home/freepeter/download/dripkg/agpgart-2.0/backend.c:220: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘drm_agp’
/home/freepeter/download/dripkg/agpgart-2.0/backend.c: In function ‘agp_add_bridge’:
/home/freepeter/download/dripkg/agpgart-2.0/backend.c:281: warning: ‘inter_module_register’ is deprecated (declared at include/linux/module.h:562)
/home/freepeter/download/dripkg/agpgart-2.0/backend.c:281: error: ‘drm_agp’ undeclared (first use in this function)
/home/freepeter/download/dripkg/agpgart-2.0/backend.c:281: error: (Each undeclared identifier is reported only once
/home/freepeter/download/dripkg/agpgart-2.0/backend.c:281: error: for each function it appears in.)
/home/freepeter/download/dripkg/agpgart-2.0/backend.c: In function ‘agp_remove_bridge’:
/home/freepeter/download/dripkg/agpgart-2.0/backend.c:301: warning: ‘inter_module_unregister’ is deprecated (declared at include/linux/module.h:563)
make[2]: *** [/home/freepeter/download/dripkg/agpgart-2.0/backend.o] 错误 1
make[1]: *** [_module_/home/freepeter/download/dripkg/agpgart-2.0] 错误 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.17-11-generic'
make: *** [default] 错误 2
make -f Makefile.linux DRM_MODULES=gdg.ko modules
make[1]: Entering directory `/home/freepeter/download/dripkg/drm'
make -C /lib/modules/2.6.17-11-generic/build SUBDIRS=`pwd` DRMSRCDIR=`pwd` modules
make[2]: Entering directory `/usr/src/linux-headers-2.6.17-11-generic'
rm: 无法删除‘/home/freepeter/download/dripkg/drm/.tmp_versions/CVS’: Is a directory
make[2]: *** [crmodverdir] 错误 1
make[2]: Leaving directory `/usr/src/linux-headers-2.6.17-11-generic'
make[1]: *** [modules] 错误 2
make[1]: Leaving directory `/home/freepeter/download/dripkg/drm'

...这个。。。是编译参数的问题还是什么问题哈?
头像
RegentW
帖子: 1486
注册时间: 2007-02-27 21:47
来自: NN
送出感谢: 2 次
接收感谢: 0

#2

帖子 RegentW » 2007-02-27 21:54

我安装了。呵呵
先安装915resolution包,好像在universe。Intel的驱动有bug,奇怪吧
头像
Beetle
帖子: 1637
注册时间: 2005-10-14 16:55
系统: OS X
来自: 江苏
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 Beetle » 2007-02-27 22:45

LZ是指哪个?貌似intel放出过两个,有一个说是可以完全开启3D的……
livi
帖子: 16
注册时间: 2006-10-26 13:46
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 livi » 2007-03-09 19:54

2楼的都装好了吗,能否讲讲具体的安装过程啊,官方下载的驱动我也没有安装上,我是用源装的,但是装完后系统就进不了X界面了。
头像
RegentW
帖子: 1486
注册时间: 2007-02-27 21:47
来自: NN
送出感谢: 2 次
接收感谢: 0

#5

帖子 RegentW » 2007-03-14 20:01

livi 写了:2楼的都装好了吗,能否讲讲具体的安装过程啊,官方下载的驱动我也没有安装上,我是用源装的,但是装完后系统就进不了X界面了。
1. 在新立得那里搜915resolution
2. 安装这个模块
3. 重启
4. 修改分辨率
Core i5, 512G + SSD 20G, DDRIII 8G
回复

回到 “常用硬件支持”