Ubuntu 13.04 安装ati 13.4 驱动失败,无法进入X和启动compiz

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
luoweipeter
帖子: 8
注册时间: 2013-04-04 9:50
系统: Ubuntu12.10
送出感谢: 0
接收感谢: 0

Ubuntu 13.04 安装ati 13.4 驱动失败,无法进入X和启动compiz

#1

帖子 luoweipeter » 2013-04-26 21:48

我的机器是联想Y460A i3-330
显卡是:ati radeon hd 5650 和intel集成显卡的所谓双显卡系统。
以前在ubuntu是使用如下方案来实现禁用独显和开启集成显卡

代码: 全选

sudo gedit /etc/rc.local
在exit 0上面加入
echo IGD > /sys/kernel/debug/vgaswitcheroo/switch
echo OFF > /sys/kernel/debug/vgaswitcheroo/switch
可是这个方案在使用一段时间后出现在grub后进入ubuntu系统黑屏的问题 :em20
需要多次重复的重启机器才能勉强进入系统。
这次兴冲冲的换上了ubuntu 13.04 64位 希望能够解决掉这个问题 :em05
然而我如法炮制在12.10下的方案后,发现重启后直接黑屏,并且风扇狂转,笔记本瞬时热得烫手。。。。 :em06
重启了无数次也无法进入系统。 :em20
无奈重装了一遍,去安装ATI的闭源驱动amd-catalyst-13.4-linux-x86.x86_64.run 来解决问题。
然而更加蛋疼的事情来了,按照官方指引 来安装后发现X无法进入以及启动compiz。。。。。
并且在tty2下输入fglrxinfo发现没有办法找到…………
难道驱动根本就没哟装上去???
请问各位大神,如何才能装上这个蛋疼的ATI 13.4的驱动???
wikeryong
帖子: 14
注册时间: 2012-11-13 10:35
系统: Ubuntu 12.04
送出感谢: 0
接收感谢: 0

Re: Ubuntu 13.04 安装ati 13.4 驱动失败,无法进入X和启动compiz

#2

帖子 wikeryong » 2013-04-28 14:27

我参照这个是装成功了,12.10升级到13.04重装了一下也装成功了
viewtopic.php?f=126&t=390372
luoweipeter
帖子: 8
注册时间: 2013-04-04 9:50
系统: Ubuntu12.10
送出感谢: 0
接收感谢: 0

Re: Ubuntu 13.04 安装ati 13.4 驱动失败,无法进入X和启动compiz

#3

帖子 luoweipeter » 2013-04-28 23:47

wikeryong 写了:我参照这个是装成功了,12.10升级到13.04重装了一下也装成功了
viewtopic.php?f=126&t=390372
请问你的机器也是y460么?在安装显卡的过程中需不需要关闭集成显卡???
xuanwu_yan
帖子: 11
注册时间: 2009-10-10 12:00
送出感谢: 0
接收感谢: 0

Re: Ubuntu 13.04 安装ati 13.4 驱动失败,无法进入X和启动compiz

#4

帖子 xuanwu_yan » 2013-04-29 17:00

wikeryong 写了:我参照这个是装成功了,12.10升级到13.04重装了一下也装成功了
viewtopic.php?f=126&t=390372
同问,你也是ati显卡?
头像
smallapple
论坛版主
帖子: 7867
注册时间: 2009-03-28 15:12
送出感谢: 0
接收感谢: 19 次

Re: Ubuntu 13.04 安装ati 13.4 驱动失败,无法进入X和启动compiz

#5

帖子 smallapple » 2013-04-29 17:06

13.04装开源驱动就行了
fglrx-updates

代码: 全选

fglrxinfo
display: :0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: AMD Radeon HD 7500/7600 Series
OpenGL version string: 4.2.12002 Compatibility Profile Context 9.012
wikeryong
帖子: 14
注册时间: 2012-11-13 10:35
系统: Ubuntu 12.04
送出感谢: 0
接收感谢: 0

Re: Ubuntu 13.04 安装ati 13.4 驱动失败,无法进入X和启动compiz

#6

帖子 wikeryong » 2013-04-29 17:44

luoweipeter 写了:
wikeryong 写了:我参照这个是装成功了,12.10升级到13.04重装了一下也装成功了
viewtopic.php?f=126&t=390372
请问你的机器也是y460么?在安装显卡的过程中需不需要关闭集成显卡???
是ati显卡,型号是e40
牛精kk
帖子: 25
注册时间: 2012-07-07 14:16
系统: bodhi2.3/win7
送出感谢: 0
接收感谢: 0

Re: Ubuntu 13.04 安装ati 13.4 驱动失败,无法进入X和启动compiz

#7

帖子 牛精kk » 2013-04-30 16:45

我也是期望13.04正式版能够很好的解决ati6570显卡,但现实很残酷---没一次成功的(包括以往的beta 每日构建)
luoweipeter
帖子: 8
注册时间: 2013-04-04 9:50
系统: Ubuntu12.10
送出感谢: 0
接收感谢: 0

Re: Ubuntu 13.04 安装ati 13.4 驱动失败,无法进入X和启动compiz

#8

帖子 luoweipeter » 2013-05-01 14:13

牛精kk 写了:我也是期望13.04正式版能够很好的解决ati6570显卡,但现实很残酷---没一次成功的(包括以往的beta 每日构建)
同悲……
回复

回到 “常用硬件支持”