机箱前面的音频接口没有声音?

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
头像
woainba15
帖子: 833
注册时间: 2006-11-11 17:14
来自: 浙江宁波
送出感谢: 0
接收感谢: 0
联系:

机箱前面的音频接口没有声音?

#1

帖子 woainba15 » 2007-03-03 13:48

在xp下前面的音频接口可以正常使用,这就说明连接是没有问题的,但是在ubuntu下就是出不了声音!这个是什么原因,对硬件不兼容吗?我的是asus的p5rd1-vm主板!
时间过得快啊!
xdsnet
帖子: 80
注册时间: 2006-02-28 15:44
送出感谢: 0
接收感谢: 0

#2

帖子 xdsnet » 2007-03-06 8:23

后面的接口有声音没有?
我估计还是整个声卡驱动没有对。
头像
woainba15
帖子: 833
注册时间: 2006-11-11 17:14
来自: 浙江宁波
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 woainba15 » 2007-03-06 11:56

后面的有的,我没装驱动,装好系统后面的就能出声音的!
时间过得快啊!
xdsnet
帖子: 80
注册时间: 2006-02-28 15:44
送出感谢: 0
接收感谢: 0

#4

帖子 xdsnet » 2007-03-07 17:49

那问题奇怪了,一般那个接口其实就是一个物理的跳接实现,而和主板驱动等都没有关系的,也就是说前面的端口实际上可能是和后面端口并联,但插上后会物理断开后面端口而已(主要放在短路等问题)
会不会你插错口了?
插入了前置的mic口了?
头像
woainba15
帖子: 833
注册时间: 2006-11-11 17:14
来自: 浙江宁波
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 woainba15 » 2007-03-08 11:40

这我可以肯定没有插错的,因为在win一切都可以正常使用的!我也觉得很是奇怪!
时间过得快啊!
头像
woainba15
帖子: 833
注册时间: 2006-11-11 17:14
来自: 浙江宁波
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 woainba15 » 2007-05-06 16:49

到了feisty还没有解决这个问题,差不多在linux下只有这么一个问题困扰我了!
时间过得快啊!
lumi
帖子: 78
注册时间: 2007-04-30 17:03
来自: 苏州
送出感谢: 0
接收感谢: 0

#7

帖子 lumi » 2007-05-07 22:39

估计是驱动本身的问题了。驱动没有把front panel jack连通。或者font panel jack被mute了。
先打开音量控制程序,把编辑->首选项里的所有选项全打勾,在试着看看回放(playback)里是否有相关声音被mute了。
如果还不行,可以看看/proc/asound/card0/codec#0,把它贴出来,应该会有帮助。
另外,看看这款主板的声卡芯片是哪家的,然后email给他们的技术支持,也许会很快得到解决。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#8

帖子 eexpress » 2007-05-07 23:23

记得是加一行参数。声卡驱动的配置里面。以前的老帖子有人是这样搞的。
● 鸣学
头像
woainba15
帖子: 833
注册时间: 2006-11-11 17:14
来自: 浙江宁波
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 woainba15 » 2007-05-08 13:06

lumi 写了:估计是驱动本身的问题了。驱动没有把front panel jack连通。或者font panel jack被mute了。
先打开音量控制程序,把编辑->首选项里的所有选项全打勾,在试着看看回放(playback)里是否有相关声音被mute了。
如果还不行,可以看看/proc/asound/card0/codec#0,把它贴出来,应该会有帮助。
另外,看看这款主板的声卡芯片是哪家的,然后email给他们的技术支持,也许会很快得到解决。
全打钩了,也不行!
这个是/proc/asound/card0/codec#0的内容
Codec: Analog Devices AD1986A
Address: 0
Vendor Id: 0x11d41986
Subsystem Id: 0x1043818f
Revision Id: 0x100500
Default PCM:
rates [0x7f]: 8000 11025 16000 22050 32000 44100 48000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Default Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Default Amp-Out caps: ofs=0x1f, nsteps=0x1f, stepsize=0x05, mute=1
Node 0x02 [Audio Output] wcaps 0x30311: Stereo Digital
PCM:
rates [0x60]: 44100 48000
bits [0x2]: 16
formats [0x5]: PCM AC3
Connection: 2
0x01* 0x06
Node 0x03 [Audio Output] wcaps 0x44d: Stereo Amp-Out
Amp-Out caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
Amp-Out vals: [0x0f 0x0f]
Power: 0x0
Node 0x04 [Audio Output] wcaps 0x40d: Stereo Amp-Out
附件
screenshot1.png
时间过得快啊!
lumi
帖子: 78
注册时间: 2007-04-30 17:03
来自: 苏州
送出感谢: 0
接收感谢: 0

#10

帖子 lumi » 2007-05-11 9:53

音量控制的"开关"里面是否有一个headphone复选框?有没有被选中?

还可以再试试去ALSA网站上下载最新的1.0.14rc3版driver看看。

另外,codec#0的内容贴的不是很全啊。
头像
woainba15
帖子: 833
注册时间: 2006-11-11 17:14
来自: 浙江宁波
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 woainba15 » 2007-05-11 11:15

lumi 写了:音量控制的"开关"里面是否有一个headphone复选框?有没有被选中?

还可以再试试去ALSA网站上下载最新的1.0.14rc3版driver看看。

另外,codec#0的内容贴的不是很全啊。
感谢lumi的回复,
好像没有headphone这个复选框,codec#0是这样的:
Codec: Analog Devices AD1986A
Address: 0
Vendor Id: 0x11d41986
Subsystem Id: 0x1043818f
Revision Id: 0x100500
Default PCM:
rates [0x7f]: 8000 11025 16000 22050 32000 44100 48000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Default Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Default Amp-Out caps: ofs=0x1f, nsteps=0x1f, stepsize=0x05, mute=1
Node 0x02 [Audio Output] wcaps 0x30311: Stereo Digital
PCM:
rates [0x60]: 44100 48000
bits [0x2]: 16
formats [0x5]: PCM AC3
Connection: 2
0x01* 0x06
Node 0x03 [Audio Output] wcaps 0x44d: Stereo Amp-Out
Amp-Out caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
Amp-Out vals: [0x18 0x18]
Power: 0x0
Node 0x04 [Audio Output] wcaps 0x40d: Stereo Amp-Out
Power: 0x0
Node 0x04 [Audio Output] wcaps 0x40d: Stereo Amp-Out
Amp-Out caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
Amp-Out vals: [0x80 0x80]
Power: 0x0
Node 0x05 [Audio Output] wcaps 0x40d: Stereo Amp-Out
Amp-Out caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
Amp-Out vals: [0x80 0x80]
Power: 0x0
Node 0x06 [Audio Input] wcaps 0x100511: Stereo
PCM:
rates [0x7f]: 8000 11025 16000 22050 32000 44100 48000
bits [0x6]: 16 20
formats [0x1]: PCM
Power: 0x0
Connection: 1
0x12
Node 0x07 [Audio Mixer] wcaps 0x200101: Stereo
Connection: 8
0x03 0x09 0x13 0x14 0x15 0x16 0x17 0x18
Node 0x08 [Audio Mixer] wcaps 0x200100: Mono
Connection: 1
0x07
Connection: 1
0x07
Node 0x09 [Audio Mixer] wcaps 0x20010e: Mono Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-In vals: [0x80] [0x80]
Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-Out vals: [0x80]
Connection: 2
0x04 0x05
Node 0x0a [Audio Selector] wcaps 0x300101: Stereo
Connection: 3
0x07* 0x04 0x05
Node 0x0b [Audio Selector] wcaps 0x300101: Stereo
Connection: 2
0x07* 0x04
Node 0x0c [Audio Selector] wcaps 0x300101: Stereo
Connection: 2
0x04* 0x07
Node 0x0d [Audio Selector] wcaps 0x300101: Stereo
Connection: 2
0x05* 0x08
Node 0x0e [Audio Selector] wcaps 0x300100: Mono
Connection: 2
Node 0x0e [Audio Selector] wcaps 0x300100: Mono
Connection: 2
0x08* 0x11
Node 0x0f [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
Amp-Out caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
Amp-Out vals: [0x03 0x03]
Connection: 8
0x1f* 0x20 0x1d 0x1d 0x27 0x28 0x29 0x2a
Node 0x10 [Audio Selector] wcaps 0x300101: Stereo
Connection: 3
0x20* 0x1c 0x1f
Node 0x11 [Audio Selector] wcaps 0x300941: Stereo
Connection: 2
0x0f* 0x2b
Node 0x12 [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
Amp-Out caps: ofs=0x00, nsteps=0x0f, stepsize=0x05, mute=1
Amp-Out vals: [0x0f 0x0f]
Connection: 8
0x11* 0x22 0x00 0x21 0x10 0x07 0x08 0x23
Node 0x13 [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
Amp-Out caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
Amp-Out vals: [0x1f 0x1f]
Connection: 1
Amp-Out vals: [0x1f 0x1f]
Connection: 1
0x11
Node 0x14 [Audio Selector] wcaps 0x30010c: Mono Amp-Out
Amp-Out caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
Amp-Out vals: [0x80]
Connection: 1
0x23
Node 0x15 [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
Amp-Out caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
Amp-Out vals: [0x1f 0x1f]
Connection: 1
0x22
Node 0x16 [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
Amp-Out caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
Amp-Out vals: [0x1f 0x1f]
Connection: 1
0x21
Node 0x17 [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
Amp-Out caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
Amp-Out vals: [0x1f 0x1f]
Connection: 1
0x10
Connection: 1
0x10
Node 0x18 [Audio Selector] wcaps 0x30010c: Mono Amp-Out
Amp-Out caps: ofs=0x0f, nsteps=0x0f, stepsize=0x0b, mute=1
Amp-Out vals: [0x8f]
Connection: 2
0x19* 0x24
Node 0x19 [Beep Generator Widget] wcaps 0x700000: Mono
Node 0x1a [Pin Complex] wcaps 0x400185: Stereo Amp-Out
Amp-Out caps: ofs=0x1f, nsteps=0x1f, stepsize=0x05, mute=1
Amp-Out vals: [0x80 0x80]
Pincap 0x081f: OUT HP Detect
Pin Default 0x02214021: [Jack] HP Out at Ext Front
Conn = 1/8, Color = Green
Pin-ctls: 0xc0: OUT HP
Connection: 1
0x0a
Node 0x1b [Pin Complex] wcaps 0x400185: Stereo Amp-Out
Amp-Out caps: ofs=0x1f, nsteps=0x1f, stepsize=0x05, mute=1
Amp-Out vals: [0x1f 0x1f]
Pincap 0x081001f: OUT HP EAPD Detect
Pin Default 0x01014011: [Jack] Line Out at Ext Rear
Conn = 1/8, Color = Green
Pin Default 0x01014011: [Jack] Line Out at Ext Rear
Conn = 1/8, Color = Green
Pin-ctls: 0x40: OUT
Connection: 1
0x0b
Node 0x1c [Pin Complex] wcaps 0x400185: Stereo Amp-Out
Amp-Out caps: ofs=0x1f, nsteps=0x1f, stepsize=0x05, mute=1
Amp-Out vals: [0x80 0x80]
Pincap 0x0837: IN OUT Detect
Pin Default 0x01013012: [Jack] Line Out at Ext Rear
Conn = 1/8, Color = Blue
Pin-ctls: 0x40: OUT
Connection: 1
0x0c
Node 0x1d [Pin Complex] wcaps 0x400985: Stereo Amp-Out
Amp-Out caps: ofs=0x1f, nsteps=0x1f, stepsize=0x05, mute=1
Amp-Out vals: [0x80 0x80]
Pincap 0x081737: IN OUT Detect
Pin Default 0x01019015: [Jack] Line Out at Ext Rear
Conn = 1/8, Color = Pink
Pin-ctls: 0x40: OUT
Connection: 1
0x0d
Connection: 1
0x0d
Node 0x1e [Pin Complex] wcaps 0x400104: Mono Amp-Out
Amp-Out caps: ofs=0x1f, nsteps=0x1f, stepsize=0x05, mute=1
Amp-Out vals: [0x80]
Pincap 0x0810: OUT
Pin Default 0x501700f0: [N/A] Speaker at Int N/A
Conn = Analog, Color = Unknown
Pin-ctls: 0x40: OUT
Connection: 1
0x0e
Node 0x1f [Pin Complex] wcaps 0x400081: Stereo
Pincap 0x081727: IN Detect
Pin Default 0x02a190f0: [Jack] Mic at Ext Front
Conn = 1/8, Color = Pink
Pin-ctls: 0x24: IN
Node 0x20 [Pin Complex] wcaps 0x400081: Stereo
Pincap 0x081727: IN Detect
Pin Default 0x018130f0: [Jack] Line In at Ext Rear
Conn = 1/8, Color = Blue
Pin-ctls: 0x20: IN
Node 0x21 [Pin Complex] wcaps 0x400081: Stereo
Pincap 0x0827: IN Detect
Node 0x21 [Pin Complex] wcaps 0x400081: Stereo
Pincap 0x0827: IN Detect
Pin Default 0x999710f0: [Fixed] Aux at Int ATAPI
Conn = Analog, Color = Black
Pin-ctls: 0x20: IN
Node 0x22 [Pin Complex] wcaps 0x400001: Stereo
Pincap 0x0820: IN
Pin Default 0x993310f0: [Fixed] CD at Int ATAPI
Conn = ATAPI, Color = Black
Pin-ctls: 0x20: IN
Node 0x23 [Pin Complex] wcaps 0x400000: Mono
Pincap 0x0820: IN
Pin Default 0x50b700f0: [N/A] Telephony at Int N/A
Conn = Analog, Color = Unknown
Pin-ctls: 0x20: IN
Node 0x24 [Pin Complex] wcaps 0x400000: Mono
Pincap 0x0820: IN
Pin Default 0x50f700f0: [N/A] Other at Int N/A
Conn = Analog, Color = Unknown
Pin-ctls: 0x20: IN
Node 0x25 [Pin Complex] wcaps 0x400301: Stereo Digital
Pincap 0x0810: OUT
Pin Default 0x014510f0: [Jack] SPDIF Out at Ext Rear
Pincap 0x0810: OUT
Pin Default 0x014510f0: [Jack] SPDIF Out at Ext Rear
Conn = Optical, Color = Black
Pin-ctls: 0x40: OUT
Connection: 1
0x02
Node 0x26 [Power Widget] wcaps 0x500500: Mono
Power: 0x0
Connection: 8
0x07* 0x08 0x13 0x14 0x15 0x16 0x17 0x18
Node 0x27 [Audio Mixer] wcaps 0x200101: Stereo
Connection: 2
0x1f 0x1d
Node 0x28 [Audio Mixer] wcaps 0x200101: Stereo
Connection: 2
0x1f 0x20
Node 0x29 [Audio Mixer] wcaps 0x200101: Stereo
Connection: 2
0x1d 0x20
Node 0x2a [Audio Mixer] wcaps 0x200101: Stereo
Connection: 3
0x1f 0x1d 0x20
Node 0x2b [Audio Mixer] wcaps 0x200100: Mono
0x1f 0x1d 0x20
Node 0x2b [Audio Mixer] wcaps 0x200100: Mono
Connection: 1
0x0f
附件
screenshot1.png
时间过得快啊!
lumi
帖子: 78
注册时间: 2007-04-30 17:03
来自: 苏州
送出感谢: 0
接收感谢: 0

#12

帖子 lumi » 2007-05-15 9:52

从alsa driver 代码看,ADI确实没有对headphone进行处理。
看来ADI本身没有支持Linux下的驱动,对ADI的支持是ALSA组织来做的,所以会有些问题。在这个方面,realtek的声卡做的比较好,alsa里对realtek声卡的patch是realtek自己开发的。

如果你有兴趣,并且对Linux下驱动开发有点了解,可以自己debug一下。

alsa驱动源代码目录下的alsa-kernel/pci/hda/patch_analog.c是ADI的HDA声卡的patch(注,其他的声卡如果是AC97的架构就不是这个文件了)。其中patch_ad1986a函数是你的声卡初始化的入口函数。因为我不清楚你的主板配置情况,你可以在
board_config = snd_hda_check_board_config(codec, ad1986a_cfg_tbl);这一行下面加一句printk来查看一下你的board_config,然后再进一步分析。
头像
woainba15
帖子: 833
注册时间: 2006-11-11 17:14
来自: 浙江宁波
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 woainba15 » 2007-05-17 20:09

感谢lumi的回复,这个对我来说确实有点困难,但是我还是会继续研究下去的!
时间过得快啊!
berg525
帖子: 3
注册时间: 2008-11-06 21:34
送出感谢: 0
接收感谢: 0

Re: 机箱前面的音频接口没有声音?

#14

帖子 berg525 » 2008-11-07 1:55

等阿,研究出来了不,我也遇到了同样的情况。。。
ryoohki
帖子: 3249
注册时间: 2008-10-28 20:18
送出感谢: 0
接收感谢: 0

Re: 机箱前面的音频接口没有声音?

#15

帖子 ryoohki » 2008-11-08 22:17

在音量控制的 首选项 里找个< Front 回放 > 的选项,然后打个勾 ,然后去把音量开到最高
回复

回到 “常用硬件支持”