[问题]Ubuntu5.10下编译源码的问题,没有gcc-3.4?

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
头像
avauntage
帖子: 570
注册时间: 2005-09-22 10:15
来自: 北京
送出感谢: 0
接收感谢: 0

[问题]Ubuntu5.10下编译源码的问题,没有gcc-3.4?

#1

帖子 avauntage » 2005-10-17 15:47

今天重新装了5.10,发现在5.4下面编译通过的ndiswrapper1.4,居然编译不了,说是需要gcc-3.4,可是盘上没有啊?用了5.4光盘上面的gcc-3.3,编译的过程中出错,说是有几个.h找不到,估计是Linux-headers的问题。
有哪位老大在5.10下面编译过源码的?指点一下。否则就只好再装回5.4了,郁闷~
空手把锄头,步行骑水牛;人在桥上过,人流水不流。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2005-10-17 15:57

哈哈。刚才我安装nvidia,编译内核,安装的4.0,字符界面搞了一堆。还提示一定要3.4。气晕。新立得有吧。
● 鸣学
头像
avauntage
帖子: 570
注册时间: 2005-09-22 10:15
来自: 北京
送出感谢: 0
接收感谢: 0

#3

帖子 avauntage » 2005-10-17 16:09

没有ndiswrapper就上不了网~我们这只有无线
空手把锄头,步行骑水牛;人在桥上过,人流水不流。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#4

帖子 eexpress » 2005-10-17 16:11

5.04光盘吧。难道你自己升级了?
不能上网真惨了。
● 鸣学
头像
avauntage
帖子: 570
注册时间: 2005-09-22 10:15
来自: 北京
送出感谢: 0
接收感谢: 0

#5

帖子 avauntage » 2005-10-17 17:14

搞了一个gcc-3.4,还是不行,编译的时候找不到一些.h,难道ndiswrapper1.4不能在2.6.12的内核下编译?我在2.6.10上还是编译通过的啊?
空手把锄头,步行骑水牛;人在桥上过,人流水不流。
头像
avauntage
帖子: 570
注册时间: 2005-09-22 10:15
来自: 北京
送出感谢: 0
接收感谢: 0

#6

帖子 avauntage » 2005-10-18 9:57

编译没有搞定,但是ndiswrapper搞定了,哈哈,又能上网了。在网上找到了一个已经编译好了的1.4版,谁有需要给我发邮件吧,我发给你。
最搞笑的是这个编译的版本里面的那个ndiswrapper.ko是有点点问题的,在modprobe之后会出一个错误,需要手工的拷贝先前编译源码时没有成功的时候编译出来的那个ndiswrapper.ko到\usr\lib\modules\2.6.12-9-386\kernel\drivers\net\ndiswrapper下面,覆盖掉有问题的那个。然后再次modprobe ndiswrapper,一切正常!好想说一句粗口^_^
空手把锄头,步行骑水牛;人在桥上过,人流水不流。
回复

回到 “常用硬件支持”