ati驱动还是装不上, 怎么办(已经解决)

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
zincx
帖子: 44
注册时间: 2007-03-23 22:11
送出感谢: 0
接收感谢: 0

ati驱动还是装不上, 怎么办(已经解决)

#1

帖子 zincx » 2007-03-28 0:14

按照zhuqin_83的方法, 不管是 方法 一 还是 方法 二 , 都装不上 驱动, 配置 是这样的,
升技 NF7 的板, NFORCE2芯片, 显卡是 9550 , 已经刷成9600的 BIOS,用 hiweed的 livecd可以起动xgl,
但是用 ubuntu6.10就装不上 ati的驱动, 弄了 5 个多小时, 装了N遍, 还是 没什么结果, 请问能不能帮帮我,
我是看了不少贴了, 也看到问同样问题的人, 请多多帮忙 , 谢谢
上次由 zincx 在 2007-04-26 14:19,总共编辑 1 次。
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#2

帖子 zhuqin_83 » 2007-03-28 0:21

不要装了,开源驱动对9系列的卡支持挺好。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
binsir543
帖子: 180
注册时间: 2007-03-22 2:04
送出感谢: 0
接收感谢: 0

#3

帖子 binsir543 » 2007-03-28 0:28

6.06的不好配
6.10的用非官方驱动比6.06好
头像
shaojz2005
帖子: 278
注册时间: 2006-07-13 13:01
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 shaojz2005 » 2007-03-28 0:38

zhuqin_83 写了:不要装了,开源驱动对9系列的卡支持挺好。
你的意思是系统自带的驱动吗?是的,显示挺好的,就是(1)不能玩beryl;(2)在我的显示器上有小小的移位
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#5

帖子 zhuqin_83 » 2007-03-28 0:57

肯定可以装beryl,肯定可以设置显示器。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
binsir543
帖子: 180
注册时间: 2007-03-22 2:04
送出感谢: 0
接收感谢: 0

#6

帖子 binsir543 » 2007-03-28 1:01

我的魔兽都能玩了,但是xgl不支持opengl,我是在一个系统下玩魔兽,一个玩beryl
zincx
帖子: 44
注册时间: 2007-03-23 22:11
送出感谢: 0
接收感谢: 0

关于ati驱动装不上的问题,目前貌似解决(1)

#7

帖子 zincx » 2007-03-28 17:09

看来这里的人都好热心,zhuqin_83, 谢谢你!!!
昨天在乱弄,弄了 几乎有 12 个小时, 装驱动装得都崩溃了(不是程序, 而是我 :cry: ), 睡觉时回想,我好像第一次就把 驱动装好了,
当时我不知怎么弄的, 重启后输入 fglrxinfo , 后, 有这些东西,
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9600
按理说已经成功(那么简单 8) ),但是我现在忘了是用哪个方法装的了, 感觉是第2种吧,
但是, 显示器刷新频率只有 60H , 于是, 我觉得装得有问题, 因为, 我在执行
sudo dpkg-reconfigure xserver-xorg 时,很多都是 Esc 跳过去的, 懒得看那么多英文, 但是, 应该是成功的安装了 ati 驱动, 当时应该是第一次安装。 然后想解决 刷新频率的问题, 决定删除驱动重装,这次执行
sudo dpkg-reconfigure xserver-xorg 后, 慢慢的看, 基本理解, 但是, 就不成了, 显示
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
version string: 1.2 (1.5 Mesa 6.4.1)
后来看了N多贴子, 不管英文,中文, 看了N多, 不过基本和zhuqin_83 的方法一样,排除了自己认为的所有可能
最终的结果是
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
version string: 1.2 (1.5 Mesa 6.4.1)
弄到 12 点多,只能发贴了, 然后睡觉!!!!
早上再弄, 想到了昨天貌似成功安装的第一次, 用了以下的方法, 感觉可以成功吧,居然成功了, 还是用貌似成功吧,都有点不敢肯定:
我庆幸昨天把那个第一次安装的 xorg.conf(以下简称 1xorg.conf)保留了, 我用第二种方法安装,到了
sudo dpkg-reconfigure xserver-xorg 这步,我不做了, 我把 1xorg.conf的内容, 覆盖当前xorg.conf内容,
重启后, 刷新率还是有问题, 但是还是高兴的, 执行 fglrxinfo
有以下一写信息了
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9600
目前又回到第一次安装的情况, 然后我执行sudo dpkg-reconfigure xserver-xorg ,
想只是改变一下 显示器的设置, 应该不会影响显卡驱动才对的吧, 却出问题了, 重启后, 刷新率没问题了, 85H
但是, 又出现了
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
version string: 1.2 (1.5 Mesa 6.4.1)
郁闷!!!
上次由 zincx 在 2007-03-28 17:20,总共编辑 1 次。
zincx
帖子: 44
注册时间: 2007-03-23 22:11
送出感谢: 0
接收感谢: 0

关于ati驱动装不上的问题,目前貌似解决(2)

#8

帖子 zincx » 2007-03-28 17:15

当然, 这时又把 1xorg.conf的内容, 覆盖当前xorg.conf内容,
只改显示器那一栏, 然后重启, 终于, 刷新率解决, RADEON 9600 也出来了,
目前应该就弄好显卡驱动了吧, 然后就装 XGL+BERYL, 貌似也是成功的, 但是, 感觉主题好难看,
又不能换主题,不过这个问题, 过一段时间应该可以解决吧!!
有高手指点就更好了, 请多多指教!!
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#9

帖子 zhuqin_83 » 2007-03-28 21:10

主题的问题,在会话里添加gnome-settings-daomon。
你应该比较一下正常和不正常的两个xorg.conf文件,不然你永远不知道为什么。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
zincx
帖子: 44
注册时间: 2007-03-23 22:11
送出感谢: 0
接收感谢: 0

#10

帖子 zincx » 2007-03-28 23:19

主题问题解决,不过好象要重新登录才可以,以前用hiweed时就可以随时用, 不过这不是问题,
应该是
菜单-系统-首选项-会话-启动程序-添加-填入以下内容:
gnome-settings-daemon
这是由于6.10在运行Beryl时没有自动运行gnome-settings-daemon而导致的。dapper用户不存在这个问题。
以上是引用,
嗯, zhuqin_83,谢谢 指教, 还有许多问题, 到时再问你。
关于那两过 xorg.conf, 我确实比较过, 但没看出什么来, 还得好好想想,
不过不知怎么第一次 就成功了, 也是比较幸运的

目前还有两个小问题,在gnome 下可以用fcitx , 但在xgl模式下不能用输入法 , 不知怎么整, 看到论坛有人问, 好象没人解答, 还有自从 ubuntu 从安装到现在, 还是没认出 cpu 等设备
系统>系统管理>设备管理器 :
供应商:Unknown
设备:Unknown
状态:状态
总线类型:pci
设备类型:processor
功能:processor

望高手 指点, 谢谢 [/img]
zincx
帖子: 44
注册时间: 2007-03-23 22:11
送出感谢: 0
接收感谢: 0

#11

帖子 zincx » 2007-03-29 16:07

xgl 下, fcitx 问题原来很简单, 在启动 xgl 后, 不知为什么, fcitx 没有启动, 但没什么关系, 在 shell 下,
执行 fcitx 就可以 启动了 , 现在可以一直用 xgl 了 。
关于 那个 认不出 CPU 的问题, 还是没解决, 貌似没有人 有这个问题。

问一个问题, 可以在 ubuntu 下装多一个, 或几过shell 吗, 以前用 suse , 有许多shell 可以选择 ,
ubuntu的 shell 在我的 机器上, 有时后会 崩溃, 装多过 shell, 比较好些吧, 作为备用 !!
szllm
帖子: 98
注册时间: 2007-01-28 7:25
送出感谢: 0
接收感谢: 0

#12

帖子 szllm » 2007-03-29 17:28

其实zhuqin_83都 讲到了点子上:
1、开源驱动对9系列的卡支持挺好。
2、肯定可以装beryl,肯定可以设置显示器。

我当初的想法也 和你一样,非要装个ATI的驱动,崩溃加疯狂几次后,
最后一次老老实实重新安装了系统,装个BERYL就能用了 ,连GLX都 不要。
现在挺好的。
zincx
帖子: 44
注册时间: 2007-03-23 22:11
送出感谢: 0
接收感谢: 0

#13

帖子 zincx » 2007-03-30 0:39

当时想着, 还是专业点好吧, 就用了 第2种方法了, 然后又换回第1种, 接着就不行了, 一般,我不会选择重装系统,
不过真的很感谢这里的 人!!

最近有过问题,大家帮忙看看, 我有个朋友 ,他的 UBUNTU CD 一直都启动不了,从而 装不了系统, 这是怎么回事, 那张盘在别的 机器上可以正常运用, 我的问题是 cpu 还是 认不出来, 请问各位, 你们的 认出来了吗??
xx3fb
帖子: 13
注册时间: 2007-03-19 19:51
送出感谢: 0
接收感谢: 0

#14

帖子 xx3fb » 2007-03-30 12:21

看过这个么?




viewtopic.php?t=26188


添加两段
代码:
Section "Extensions"
Option "Composite" "0"
EndSection

Section "ServerFlags"
Option "AIGLX" "off"
EndSection
上面这段很重要!
zincx
帖子: 44
注册时间: 2007-03-23 22:11
送出感谢: 0
接收感谢: 0

大家有没遇到这种情况:

#15

帖子 zincx » 2007-04-13 19:25

大家有没遇到这种情况:
就是开机时, 桌面上,多了一个窗口, 但是, 非常小, 在窗口选择中, 多了个, gnome-panel的窗口选择,
奇怪, 有时会出现, 但有时又不会出现, 有人遇到这个情况吗?????
想关闭, 但是不能关闭, 如果选择关闭, 就出现错误, 然后, gnome-panel 变成 未命名窗口。
附件
Screenshot.png
回复

回到 “常用硬件支持”