声卡/显卡驱动问题

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
gam2046
帖子: 2
注册时间: 2015-11-16 13:09
系统: Ubuntu 14
送出感谢: 0
接收感谢: 0

声卡/显卡驱动问题

#1

帖子 gam2046 » 2015-11-16 13:20

硬件为USB外置5.1声道声卡与Intel(R) Core(TM) i5-4460核心显卡。

而系统识别出来的硬件信息,我看不懂是什么含义,表现出来为,系统只输出双声道,我尝试播放含有5.1声道的视频文件(该文件在Windows测试过),并且在播放器中设置为5.1声道输出,实际上依旧只有双声道,且视频无法启动硬件加速,都是CPU软解视频。网上一阵搜索,都是说N卡和A卡装闭源驱动的。似乎都没有提到核心显卡的驱动怎么办,有些人说intel的核心显卡驱动,系统内核中已经集成了,那么为何我这里依旧不能启动硬件加速?(哪怕是浏览器中用flash播放一个视频,都是一顿一顿的,明显的声画不同步。

lspci相关信息:

代码: 全选

00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06) (prog-if 00 [VGA controller])
	Subsystem: Elitegroup Computer Systems Device 7e44
	Flags: bus master, fast devsel, latency 0, IRQ 48
	Memory at f7800000 (64-bit, non-prefetchable) [size=4M]
	Memory at e0000000 (64-bit, prefetchable) [size=256M]
	I/O ports at f000 [size=64]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
	Capabilities: [d0] Power Management version 2
	Capabilities: [a4] PCI Advanced Features
	Kernel driver in use: i915

00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06)
	Subsystem: Elitegroup Computer Systems Device 7e44
	Flags: bus master, fast devsel, latency 0, IRQ 49
	Memory at f7d10000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: [50] Power Management version 2
	Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit-
	Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
	Kernel driver in use: snd_hda_intel
头像
vickycq
论坛版主
帖子: 4507
注册时间: 2011-03-20 13:12
系统: Debian
来自: 山东省寿光县
送出感谢: 100 次
接收感谢: 995 次
联系:

Re: 声卡/显卡驱动问题

#2

帖子 vickycq » 2015-11-16 16:18

有些人说intel的核心显卡驱动,系统内核中已经集成了,那么为何我这里依旧不能启动硬件加速?
硬解需要额外配置
Intel 核显启用硬件加速 参考
http://askubuntu.com/a/296173

1.

代码: 全选

sudo apt-get install i965-va-driver libva1 vainfo
2.
用 vainfo 查看硬件加速支持情况,应有如下类似输出
libva: VA-API version 0.32.0
libva: va_getDriverName() returns 0
libva: Trying to open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
libva: va_openDriver() returns 0
vainfo: VA-API version: 0.32 (libva 1.0.15)
vainfo: Driver version: Intel i965 driver - 1.0.17
vainfo: Supported profile and entrypoints
VAProfileMPEG2Simple : VAEntrypointVLD
VAProfileMPEG2Main : VAEntrypointVLD
... ...
... ...
VAProfileVC1Main : VAEntrypointVLD
VAProfileVC1Advanced : VAEntrypointVLD
3.
配置播放器使用硬件加速
vlc mpv 可使用 vaapi,默认的 mplayer 不可以

4.
哪怕是浏览器中用 flash 播放一个视频,都是一顿一顿的,明显的声画不同步
浏览器硬件加速比较复杂,情况一直在变化
Flash
http://askubuntu.com/questions/342600/h ... l-graphics
Firefox
https://wiki.archlinux.org/index.php/Fi ... .28OMTC.29
http://www.silicongadget.com/internet/b ... inux/2791/
http://askubuntu.com/questions/491750/f ... in-firefox
Chromium
http://askubuntu.com/questions/336302/g ... 310#336310
https://bugs.launchpad.net/ubuntu/+sour ... ug/1463598
http://www.kelvinblog.tk/enable-chromiu ... ion-linux/

5.
表现出来为,系统只输出双声道
先参考
https://help.ubuntu.com/community/SurroundSound
http://askubuntu.com/questions/491626/s ... itech-g430
进行基本测试
上次由 vickycq 在 2015-11-24 21:21,总共编辑 1 次。
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户
gam2046
帖子: 2
注册时间: 2015-11-16 13:09
系统: Ubuntu 14
送出感谢: 0
接收感谢: 0

Re: 声卡/显卡驱动问题

#3

帖子 gam2046 » 2015-11-16 18:23

vickycq 写了: 5.
表现出来为,系统只输出双声道
先参考
https://help.ubuntu.com/community/SurroundSound
http://askubuntu.com/questions/491626/s ... itech-g430
进行基本测试
感谢你的答复。由于图形加速的资料比较多,我晚些时候再看。我暂时先尝试您给出相关声音的资料。

我尝试修改文件`/etc/pulse/daemon.conf`:(5.1声道)
default-sample-channels = 6

然后重启,情况依旧。

我尝试运行`alsamixer`,提示:

代码: 全选

cannot open mixer: 没有那个文件或目录
尝试运行`speaker-test -Dplug:surround51 -c6 -l1 -twav`:

代码: 全选

speaker-test 1.0.27.2

重播设备是plug:surround51
流参数是 48000Hz,S16_LE,6 频道
WAV文件
ALSA lib confmisc.c:768:(parse_card) cannot find card '0'
ALSA lib conf.c:4248:(_snd_config_evaluate) function snd_func_card_driver returned error: 没有那个文件或目录
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:4248:(_snd_config_evaluate) function snd_func_concat returned error: 没有那个文件或目录
ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib conf.c:4248:(_snd_config_evaluate) function snd_func_refer returned error: 没有那个文件或目录
ALSA lib conf.c:4727:(snd_config_expand) Evaluate error: 没有那个文件或目录
ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM surround51
重播打开错误: -2,没有那个文件或目录
尝试运行`speaker-test -c 6`,依旧为双声道。

这台电脑,以前我装过Ubuntu 15,打开系统设置 -> 声音,如图有一个模拟2.1/5.1/7.1等选项,由于ubuntu 15我感觉个别情况下,有些问题,我换回了14版本。就变成了图中的样子,不在有选项。
屏幕截图.png
系统设置 -> 声音
头像
vickycq
论坛版主
帖子: 4507
注册时间: 2011-03-20 13:12
系统: Debian
来自: 山东省寿光县
送出感谢: 100 次
接收感谢: 995 次
联系:

Re: 声卡/显卡驱动问题

#4

帖子 vickycq » 2015-11-16 20:40

  1. 提供更多信息
    • 1-1. 在插入 USB 声卡的情况下 打开终端执行

      代码: 全选

      cd
      wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh
      
      选择 ok -> UPLOAD / SHARE
      会回应一个网址:
      Your ALSA information is located at http://www.alsa-project.org/db/?f=aaaaaaaaaaaaaaaa
      Please inform the person helping you.
      把该网址贴上来。
    • 1-2. 在插入 USB 声卡的情况下 打开终端执行

      代码: 全选

      sudo apt-get install pastebinit
      aplay -L | pastebinit -b http://paste.ubuntu.com/ 
      
      会回应一个网址,把该网址贴上来。
  2. 尝试运行`speaker-test -Dplug:surround51 -c6 -l1 -twav`:
    ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM surround51
    重播打开错误: -2,没有那个文件或目录
    以下仅考虑 speaker-test 测试
    5.1 声卡是 USB 设备,设备名称应该不是 plug:surround51
    可用 PCM 名称用 aplay -L 列出。例如在我这里,5.1声道USB设备为 surround51:CARD=H2n,DEV=0
    重新测试:speaker-test -Dsurround51:CARD=H2n -c2 -l1 -twav

    代码: 全选

    alexy@debian-PC ~ $ aplay -L | grep surround
    surround21:CARD=SB,DEV=0
    surround40:CARD=SB,DEV=0
    surround41:CARD=SB,DEV=0
    surround50:CARD=SB,DEV=0
    surround51:CARD=SB,DEV=0
    surround71:CARD=SB,DEV=0
    surround21:CARD=H2n,DEV=0
    surround40:CARD=H2n,DEV=0
    surround41:CARD=H2n,DEV=0
    surround50:CARD=H2n,DEV=0
    surround51:CARD=H2n,DEV=0
    surround71:CARD=H2n,DEV=0
    
  3. 我尝试运行`alsamixer`,提示:
    cannot open mixer: 没有那个文件或目录
    是否只有一个 USB 声卡,没有板载声卡?
    再看有没有文件 /etc/modprobe.d/alsa-base.conf
    若有,看其中有没有内容 options snd-usb-audio index=-2
    若有,在 options snd-usb-audio index=-2 一行前加上注释符 #
    考虑到目前不知您的 USB 声卡是否使用驱动 snd-usb-audio,也可把所有含 index=-2 的行全部注释掉。
    重新启动计算机
    参考
    https://bugs.debian.org/cgi-bin/bugrepo ... bug=620904
    http://askubuntu.com/a/609604
    https://wiki.archlinux.org/index.php/Ad ... sound_card
    https://justus.berlin/2015/05/no-sound- ... ry-solved/
上次由 vickycq 在 2015-11-16 21:08,总共编辑 10 次。
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户
头像
langyxxl
帖子: 443
注册时间: 2012-01-17 22:17
送出感谢: 3 次
接收感谢: 20 次

Re: 声卡/显卡驱动问题

#5

帖子 langyxxl » 2015-11-16 20:56

那么多声道,得有那么多设备才行吧。。
附件
2015-11-16 20-54-26屏幕截图.png
头像
freeying
帖子: 4
注册时间: 2010-06-08 9:43
送出感谢: 0
接收感谢: 0

Re: 声卡/显卡驱动问题

#6

帖子 freeying » 2018-05-08 22:02

langyxxl 写了:那么多声道,得有那么多设备才行吧。。
您这个声卡用的什么驱动?我的怎么出不来5.1声道呀。
回复

回到 “常用硬件支持”