当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [已解决] N专有驱动如何开启vsync?
帖子发表于 : 2017-08-14 12:35 
头像

注册: 2012-01-17 22:17
帖子: 441
送出感谢: 3
接收感谢: 20
笔记本双显卡,系统ubuntu17.04 安装了N卡的官方驱动,在驱动中禁用了intel集显,只用N卡。

但是跑glxgears,简直就像疯了一样,能有5000fps,最关键的是glxgears程序一开始就提示
“Running synchronized to the vertical refresh. The framerate should be
approximately the same as the monitor refresh rate.”
无语了。。。

哪位大神知道如何让glxgears运行在60fps啊


附件:
2017-08-14 12-30-38屏幕截图.png
2017-08-14 12-30-38屏幕截图.png [ 152.38 KiB | 被浏览 1034 次 ]



最后由 langyxxl 编辑于 2017-08-14 14:16,总共编辑了 1 次
页首
 用户资料  
 
2 楼 
 文章标题 : Re: N专有驱动如何开启vsync?
帖子发表于 : 2017-08-14 14:00 
头像

注册: 2012-01-17 22:17
帖子: 441
送出感谢: 3
接收感谢: 20
额,查了nvidia官方资料https://devtalk.nvidia.com/default/topic/957814/prime-and-prime-synchronization/
终于解决了

ubuntu默认竟然是关闭prime的vsync的,这样会导致很多问题,比如看网页滚动的时候撕裂,看视频撕裂等等
ubuntu在/etc/modprobe.d/nvidia-graphics-drivers.conf文件的最后一行竟然是
options nvidia_381_drm modeset=0

改为options nvidia_381_drm modeset=1,再运行“update-initramfs -u”更新内核,重启,就比原来好多了,终于告别撕裂了
glxgears的fps也恢复正常了,不过为什么前面几秒的fps不是精确的60.。。。。

有大神知道吗?


附件:
2017-08-14 13-55-39屏幕截图.png
2017-08-14 13-55-39屏幕截图.png [ 86.44 KiB | 被浏览 1002 次 ]

页首
 用户资料  
 
3 楼 
 文章标题 : Re: [已解决] N专有驱动如何开启vsync?
帖子发表于 : 2017-10-07 13:50 
头像

注册: 2012-11-13 11:30
帖子: 366
系统: ubuntu17.10,Arch
送出感谢: 6
接收感谢: 4
你解决了一个困扰我五年的问题,我快被感动到哭了


_________________
博客


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译