[问题]实在抱歉,烦请高手帮我解决声卡没有声音的问题

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
tingtao
帖子: 28
注册时间: 2006-06-02 13:36
送出感谢: 0
接收感谢: 0

[问题]实在抱歉,烦请高手帮我解决声卡没有声音的问题

#1

帖子 tingtao » 2007-04-20 23:14

华硕A8H笔记本,之前安装过hiweed1.0,声音完全正常。昨晚安装ubuntu7.04,是格式化分区后全新安装,从头到尾就没出来过声音。在坛子里找了一天,方法试了N个,就是不行。我快崩溃了:(

经过筛选,我觉得有两个帖子比较接近我的情况。但是仍然没法帮我解决问题。
《声卡驱动安装上了。但是没有声音的朋友进来看~!希望对你有帮助。》viewtopic.php?t=45667

这个帖子中提到的“{方法很简单,打开音量控制,找到External Amplifier开关,让其显示出来。如果这个后面的对号是选中的,把对号去掉。 }我照他的方法去做了。果然。我的本本从以前的没有一点声音。变成了当我插上耳机的时候耳机有声音。本本自带的小喇叭还是没声音。不管怎么说。总比以前好很多了。后来。我又在网上查找了一些文章。有一位高手说。{打开音量控制',在弹出的面板上找到'Headphone Jack Sense' 将下面的静音打上对号,还有'Line Jack Sense'下面的静音也打上对号.这时你就能听到'铛'的一声了,声音就出来了.}我又照他说的方法去做了。 果然。全部都有声音了。插上耳机,耳机有声音。扒掉耳机。本本的小喇叭有声音了。 ”,External Amplifier开关我去掉对号了,还是没有声音。至于后边提到的两个开关,我这里压根没有。


《可加载模块,但声卡工作不正常的解决方法》about41246.html&highlight=analog

这个帖子,是最接近我的情况了,我也是snd_hda_intel
tingtao@tingtao-laptop:~$ lsmod|grep snd
snd_hda_intel 21912 1
snd_hda_codec 205440 1 snd_hda_intel
snd_pcm_oss 44544 0
snd_mixer_oss 17408 1 snd_pcm_oss
snd_pcm 79876 3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_seq_dummy 4740 0
snd_seq_oss 32896 0
snd_seq_midi 9600 0
snd_rawmidi 25472 1 snd_seq_midi
snd_seq_midi_event 8448 2 snd_seq_oss,snd_seq_midi
snd_seq 52592 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer 23684 2 snd_pcm,snd_seq
snd_seq_device 9100 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd 54020 12 snd_hda_intel,snd_hda_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore 8672 1 snd
snd_page_alloc 10888 2 snd_hda_intel,snd_pcm

运行alsamixer,查看Chip,我的正好就是:│ Chip: Analog Devices AD1986A
然后,我尝试了所有四种模式 sudo gedit /etc/modprobe.d/options ,在最后一行分别尝试添加了
options snd-hda-intel single_cmd=1 model=laptop-eapd
options snd-hda-intel single_cmd=1 model=laptop
options snd-hda-intel single_cmd=1 model=3stack
options snd-hda-intel single_cmd=1 model=6stack

每一次却都是让我以失望而告终。

恳切请求高手帮我一下,实在太郁闷了。我暂时不想装回hiweed1了,因为感觉Ubuntu7.04整体上还是让我非常满意的。
andrew_t
帖子: 614
注册时间: 2006-12-14 3:00
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 andrew_t » 2007-04-21 0:47

写的太乱了,没看懂
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#3

帖子 eexpress » 2007-04-21 1:12

bug。无解。等修复。
到package.ubuntu.com去找20-13的内核吧。这后面的内核都有问题。
● 鸣学
tingtao
帖子: 28
注册时间: 2006-06-02 13:36
送出感谢: 0
接收感谢: 0

#4

帖子 tingtao » 2007-04-21 7:18

andrew_t 写了:写的太乱了,没看懂
汗一个,俺的描述是太乱了点。
tingtao
帖子: 28
注册时间: 2006-06-02 13:36
送出感谢: 0
接收感谢: 0

#5

帖子 tingtao » 2007-04-21 7:19

eexpress 写了:bug。无解。等修复。
到package.ubuntu.com去找20-13的内核吧。这后面的内核都有问题。
噢,谢谢。那我就先等待一段时间吧。。。
回复

回到 “常用硬件支持”