当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 有在7.04下用Geforce2 pro 显卡的吗? 我实在解决不了这个问题,(已经解决)
帖子发表于 : 2007-04-23 13:27 

注册: 2007-03-01 10:38
帖子: 44
送出感谢: 0 次
接收感谢: 0 次
我以前用ubuntu 6.06时候,用源里的驱动就无法安装使用,我是用nvidia 7184的驱动手动编译的,能正常驱动.使用也正常


最近装的7.04,nvidia的7184驱动也编译不了了,不过nvidia的7185驱动可以编译安装,不过和用源里的驱动nvidia-glx-leagcy一样,不能正常使用,现象是:

本来分辨率是1024x768,刷新是85,驱动完成之后,分辨率变成了640x480,刷新率60,而且无法调整.
所有3D相关的屏幕保护都不能运行,用nvidia-setting看一下,发现openGL有问题.

我是按照wiki的方法做的,xorg.conf也编辑过了,nv改成了nvidia,去掉"dri",现在实在是搞不定了,请各位帮帮忙,谢谢

——————————————————————————————————————————————————

解决方法是这样的,装完系统后按照wiki的方法装驱动,不过要装nvidia-glx-leagcy的驱动,装完之后退出Xwindow

sudo /etc/init.d/gdm stop
sudo nvidia-glx-config enable //这个命令会修改/etc/X11/xorg.conf
编辑/etc/X11/xorg.conf
第一步 找到Load "dri"这行,在前面加#号,注释掉
第二步 找到BusID "PCI:0:5:0" 这行,改成BusID "PCI:1:0:0"
第三步 在文件中加入以下字段

Section "Extensions"
Option "Composite" "Disable"
EndSection

第四步 找到Driver "nv"这行,改成Driver "nvidia"

保存,重新启动X
sudo /etc/init.d/gdm start

这样分辨率就正常了,显卡的3D功能也打开了。

另外,刷新率问题的解决方法是在/etc/X11/xorg.conf中找到HorizSync和VertRefresh,分别在后面填上你的显示器的水平和垂直刷新率,因为不同的显示器不一样,写错了会出问题,这个我就不写了


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-04-24 13:00 

注册: 2007-04-24 10:55
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
顶个 :lol: :lol: :lol:


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译