有在7.04下用Geforce2 pro 显卡的吗? 我实在解决不了这个问题,(已经解决)

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
pcbit
帖子: 44
注册时间: 2007-03-01 10:38
送出感谢: 0
接收感谢: 0

有在7.04下用Geforce2 pro 显卡的吗? 我实在解决不了这个问题,(已经解决)

#1

帖子 pcbit » 2007-04-23 13:27

我以前用ubuntu 6.06时候,用源里的驱动就无法安装使用,我是用nvidia 7184的驱动手动编译的,能正常驱动.使用也正常


最近装的7.04,nvidia的7184驱动也编译不了了,不过nvidia的7185驱动可以编译安装,不过和用源里的驱动nvidia-glx-leagcy一样,不能正常使用,现象是:

本来分辨率是1024x768,刷新是85,驱动完成之后,分辨率变成了640x480,刷新率60,而且无法调整.
所有3D相关的屏幕保护都不能运行,用nvidia-setting看一下,发现openGL有问题.

我是按照wiki的方法做的,xorg.conf也编辑过了,nv改成了nvidia,去掉"dri",现在实在是搞不定了,请各位帮帮忙,谢谢

——————————————————————————————————————————————————

解决方法是这样的,装完系统后按照wiki的方法装驱动,不过要装nvidia-glx-leagcy的驱动,装完之后退出Xwindow

sudo /etc/init.d/gdm stop
sudo nvidia-glx-config enable //这个命令会修改/etc/X11/xorg.conf
编辑/etc/X11/xorg.conf
第一步 找到Load "dri"这行,在前面加#号,注释掉
第二步 找到BusID "PCI:0:5:0" 这行,改成BusID "PCI:1:0:0"
第三步 在文件中加入以下字段

Section "Extensions"
Option "Composite" "Disable"
EndSection

第四步 找到Driver "nv"这行,改成Driver "nvidia"

保存,重新启动X
sudo /etc/init.d/gdm start

这样分辨率就正常了,显卡的3D功能也打开了。

另外,刷新率问题的解决方法是在/etc/X11/xorg.conf中找到HorizSync和VertRefresh,分别在后面填上你的显示器的水平和垂直刷新率,因为不同的显示器不一样,写错了会出问题,这个我就不写了
stray_skyline
帖子: 2
注册时间: 2007-04-24 10:55
送出感谢: 0
接收感谢: 0

#2

帖子 stray_skyline » 2007-04-24 13:00

顶个 :lol: :lol: :lol:
回复

回到 “常用硬件支持”