[问题]庆祝一下:声卡终于发出声音了。顺便问一个问题 totem-xine播放rmvb有问题[已解决]

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
tingtao
帖子: 28
注册时间: 2006-06-02 13:36
送出感谢: 0
接收感谢: 0

[问题]庆祝一下:声卡终于发出声音了。顺便问一个问题 totem-xine播放rmvb有问题[已解决]

#1

帖子 tingtao » 2007-04-25 10:51

我的是华硕A8H笔记本,集成声卡,analog 1986A芯片,由于内核bug问题一直不能出声音。论坛已经有的解决方法也无效。昨晚通过这个英文的howto指导,终于可以正常发出声音了,把链接提供出来,希望能够帮助更多的朋友解决问题。不过在这个howto的指导下,我在编译alsa-utils出错,没能安装上最新的utils,但是系统自带的utils似乎还能正常使用。
https://help.ubuntu.com/community/HdaIntelSoundHowto

另外,我卸载了系统自带的totem-gstream,安装了totem-xine系列,w32codecs是通过下载deb包单独安装上的。现在的问题是,用totem播放rmvb时,有影像没声音。但是用mplayer放呢,就完全没问题。可是mplayer不支持进度条拖拽,只能用键盘或者鼠标滚轮快进快退,有点不爽。还有就是因为系统默认把影音文件关联给totem了。如果用mplayer播放的话,操作起来不是很方便啊。

------------------补充说明 ---------
发完这个帖子,无意中看到大侠发的一个feisty快速设置wiki,http://wiki.ubuntu.org.cn/fideas 里面给出了totem-xine播放rmvb无声的解决方法:
#

另外,如果使用 xine 后端的播放器,如 kaffeine, xine, totem-xine 等等播放器在播放有些 rmvb 的文件的时候会出现没有声音的现象,解决办法如下
#

首先关闭播放器,然后使用你喜欢的编辑器,比如 kate, gedit, vim 等打开文件 ~/.xine/catalog.cache,(比如 kate ~/.xine/catalog.cache 打开该文件。找到其中的
[/usr/lib/xine/plugins/1.1.4/xineplug_decode_real_audio.so] 代码段,将其下的 decoder_priority 的数值修改成 10

# . 修改完毕后这一段应该看起来是这样子的
# .

[/usr/lib/xine/plugins/1.1.4/xineplug_decode_real_audio.so]
....
....
decoder_priority=10
上次由 tingtao 在 2007-04-25 11:07,总共编辑 1 次。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2007-04-25 11:01

hda-intel。都是这毛病。烂内核。20-13的就正常。

看下/usr/lib/win32和/usr/lib/codec目录。是不是一致的。
● 鸣学
tingtao
帖子: 28
注册时间: 2006-06-02 13:36
送出感谢: 0
接收感谢: 0

#3

帖子 tingtao » 2007-04-25 11:09

eexpress 写了:hda-intel。都是这毛病。烂内核。20-13的就正常。

看下/usr/lib/win32和/usr/lib/codec目录。是不是一致的。
呵呵,可惜的是,这个bug没有被列为严重bug,所以fix的发布可能会比较慢。我本来想等fix的,实在。。。没耐性等待了。
回复

回到 “常用硬件支持”