当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 14 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 有没有遇到安装成功N卡驱动后,每次启动X后,系统刷新率自动改回43Hz。
帖子发表于 : 2007-05-10 9:55 
头像

注册: 2006-09-04 21:38
帖子: 1073
地址: 中国沙大
送出感谢: 0 次
接收感谢: 0 次
如题,在一台AMD64台式机上安装的kubuntu7.04。显卡为Nvidia GF5200。显示器是LG T710S。
不管如何,重启X或重启系统后,刷新率就会改回43Hz,并且屏幕发生偏移,且有点像隔行扫描显示。要手动修改后才能正常。


附件:
4.png
4.png [ 43.21 KiB | 被浏览 1007 次 ]

3.png
3.png [ 89.35 KiB | 被浏览 1013 次 ]

2.png
2.png [ 119.75 KiB | 被浏览 1001 次 ]



_________________
ArchLinux,你让我不得不放弃,等着我,我还会回来!
不要总是让我玩系统!我要用它来工作!
页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-05-10 10:06 
头像

注册: 2006-05-03 0:39
帖子: 8273
地址: المريخ
送出感谢: 0 次
接收感谢: 1
你要用管理员的权限运行它呀,否则你保存的时候它会告诉你无法保存滴,不信你仔细看看那文字

代码:
kdesu nvidia-settings


_________________
PHP是最好的语言!不服来战!


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-05-10 10:12 
头像

注册: 2006-12-23 13:46
帖子: 9203
地址: Azores Islands
送出感谢: 0 次
接收感谢: 1
高手们都被气跑了。现在只有菜鸟


怎么装的驱动?

一般这样装比较少有问题

代码:
sudo apt-get install nvidia-glx-new
sudo nvidia-xconfig
重启x或电脑


不行的话,也可以安装可能更稳定的 nvidia-glx


_________________
no security measure is worth anything if an attacker has physical access to the machine


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-05-10 10:39 
头像

注册: 2006-05-03 0:39
帖子: 8273
地址: المريخ
送出感谢: 0 次
接收感谢: 1
skyx 写道:
高手们都被气跑了。现在只有菜鸟


怎么装的驱动?

一般这样装比较少有问题

代码:
sudo apt-get install nvidia-glx-new
sudo nvidia-xconfig
重启x或电脑


不行的话,也可以安装可能更稳定的 nvidia-glx

他已经装好了,正在调整呢

skyx你真是淘气,把高手都气跑了


_________________
PHP是最好的语言!不服来战!


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-05-10 11:29 
头像

注册: 2006-09-04 21:38
帖子: 1073
地址: 中国沙大
送出感谢: 0 次
接收感谢: 0 次
stlxv 写道:
你要用管理员的权限运行它呀,否则你保存的时候它会告诉你无法保存滴,不信你仔细看看那文字

代码:
kdesu nvidia-settings


要我怎么样用管理员?
我试了 sudo nvidia-settings
还试了把那里面的xorg.conf内容复制下来,然后用sudo vim /etc/X11/xorg.conf编辑后写入
结果都一样,其实xorg.conf文件已经保存了。

引用:
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildmeister@builder26) Mon Feb 26 23:38:28 PST 2007

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"


莫名甚妙。还有就是那个xorg.conf文件,看不懂。


_________________
ArchLinux,你让我不得不放弃,等着我,我还会回来!
不要总是让我玩系统!我要用它来工作!


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-05-10 11:32 
头像

注册: 2006-05-03 0:39
帖子: 8273
地址: المريخ
送出感谢: 0 次
接收感谢: 1
保存了就好,按ctrl+alt+backspace重启X,不知道backspace是哪个键就直接重新启动计算机


_________________
PHP是最好的语言!不服来战!


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-05-10 11:33 
头像

注册: 2006-05-03 0:39
帖子: 8273
地址: المريخ
送出感谢: 0 次
接收感谢: 1
P.S. xorg.conf不需要你看懂


_________________
PHP是最好的语言!不服来战!


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-05-10 11:43 
头像

注册: 2006-09-04 21:38
帖子: 1073
地址: 中国沙大
送出感谢: 0 次
接收感谢: 0 次
stlxv 写道:
P.S. xorg.conf不需要你看懂


那我就不知道怎么办了,很不好意思,没按你的想法,它就是不听话,老样子。
在发贴之前我忘了说了,在发贴之前已经确保xorg.conf修改成功。
而且我试了两个驱动,都一样
NVIDIA-Linux-x86_64-1.0-9631-pkg2.run
NVIDIA-Linux-x86_64-1.0-9755-pkg2.run

觉得很可怕
我说看不懂,意思就是会不会是xorg.conf出了问题,可是更改后一切正常,重启X和重启计算机后都会回复到原来的地方去,就像安装了还原卡。发誓我已经把还原卡关了。


_________________
ArchLinux,你让我不得不放弃,等着我,我还会回来!
不要总是让我玩系统!我要用它来工作!


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-05-10 11:59 
头像

注册: 2005-08-15 0:04
帖子: 1880
地址: 南7技校
送出感谢: 0 次
接收感谢: 0 次
hoho, 和我以前的症状一样!
有个诡异的解决办法,我至今没有想通是为什么,当时只是瞎试一下,没想到成功了。

在 K Menu --> System Settings --> Monitor & Display 中把系统的 Refresh 改成 50. 一定是 50, 不要是别的数值,应该就正常了。 这时不要动 Nvidia-settings 中的任何值。

我个人考虑似乎这里的 50, 和其他的几个值都是指代一个特定的分辨率,而不是这里给出的值。也没有弄清楚原因,还请高手赐教.


_________________
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-05-10 12:07 
头像

注册: 2006-09-04 21:38
帖子: 1073
地址: 中国沙大
送出感谢: 0 次
接收感谢: 0 次
zhan 写道:
hoho, 和我以前的症状一样!
有个诡异的解决办法,我至今没有想通是为什么,当时只是瞎试一下,没想到成功了。

在 K Menu --> System Settings --> Monitor & Display 中把系统的 Refresh 改成 50. 一定是 50, 不要是别的数值,应该就正常了。 这时不要动 Nvidia-settings 中的任何值。

我个人考虑似乎这里的 50, 和其他的几个值都是指代一个特定的分辨率,而不是这里给出的值。也没有弄清楚原因,还请高手赐教.


试试这个有点变态的方法去。


_________________
ArchLinux,你让我不得不放弃,等着我,我还会回来!
不要总是让我玩系统!我要用它来工作!


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-05-10 12:17 
头像

注册: 2006-09-04 21:38
帖子: 1073
地址: 中国沙大
送出感谢: 0 次
接收感谢: 0 次
oydl82 写道:
zhan 写道:
hoho, 和我以前的症状一样!
有个诡异的解决办法,我至今没有想通是为什么,当时只是瞎试一下,没想到成功了。

在 K Menu --> System Settings --> Monitor & Display 中把系统的 Refresh 改成 50. 一定是 50, 不要是别的数值,应该就正常了。 这时不要动 Nvidia-settings 中的任何值。

我个人考虑似乎这里的 50, 和其他的几个值都是指代一个特定的分辨率,而不是这里给出的值。也没有弄清楚原因,还请高手赐教.


试试这个有点变态的方法去。


搞定了,重新声明,不是有点变态,是超级变态。

一进K菜单-->系统设置-->显示器与监视器中,发现已经是50了,就改成55,发现闪得厉害,又在Nvidia-settings中更改了,重启X后,又是闪得厉害,这时我在Nvidia-settings中改正常后,回到系统设置中,把它改回50,重启X后就OK了。


_________________
ArchLinux,你让我不得不放弃,等着我,我还会回来!
不要总是让我玩系统!我要用它来工作!


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-05-10 12:22 
头像

注册: 2006-05-03 0:39
帖子: 8273
地址: المريخ
送出感谢: 0 次
接收感谢: 1
:shock: 够BT...


_________________
PHP是最好的语言!不服来战!


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-05-10 12:23 
头像

注册: 2005-08-15 0:04
帖子: 1880
地址: 南7技校
送出感谢: 0 次
接收感谢: 0 次
贺。


_________________
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2007-05-10 18:46 
头像

注册: 2007-02-21 17:06
帖子: 221
地址: 广州
送出感谢: 0 次
接收感谢: 0 次
我的GF4卡子装上了驱动刷新频率就会变为倒序的了,选上正确的就行。Nvidia-settings要与显示设置一致才会生效的


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 14 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译