[问题]IBM X31笔记本装了ubuntu5.10之后进xp蓝屏

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
beinfant
帖子: 14
注册时间: 2005-11-03 15:54
送出感谢: 0
接收感谢: 0

[问题]IBM X31笔记本装了ubuntu5.10之后进xp蓝屏

#1

帖子 beinfant » 2005-11-04 9:32

本来装好了之后,我可以在启动菜单里看到xp的选项,就没有在意,后来准备重新进入xp的时候,发现一走到启动画面出来不到2秒就要蓝屏,然后自动重启,无论是安全模式还是其他模式一律蓝屏,请问这种情况如何处理?
hscui
帖子: 169
注册时间: 2005-09-21 16:26
送出感谢: 0
接收感谢: 0

#2

帖子 hscui » 2005-11-04 9:34

昏死,莫非某些OEM版的XP不能与Ubuntu共存?
beinfant
帖子: 14
注册时间: 2005-11-03 15:54
送出感谢: 0
接收感谢: 0

#3

帖子 beinfant » 2005-11-04 9:35

我有很多资料都在xp里面,我不想重装。当然我也可以把资料导出来,但是太麻烦了。我希望两个系统可以共存。
头像
oneleaf
论坛管理员
帖子: 10208
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 99 次

#4

帖子 oneleaf » 2005-11-04 9:53

找个XP覆盖安装试试?
beinfant
帖子: 14
注册时间: 2005-11-03 15:54
送出感谢: 0
接收感谢: 0

#5

帖子 beinfant » 2005-11-04 9:55

但是我原来的xp是个机器自带的,我怕有问题。另外,ibm笔记本都有一个隐藏分区,是不是因为这个出了问题。
beinfant
帖子: 14
注册时间: 2005-11-03 15:54
送出感谢: 0
接收感谢: 0

#6

帖子 beinfant » 2005-11-04 10:02

我用xp故障控制恢复台看到的分区信息是,只有一个未知的一个分区。我原来的情况是这样的,硬盘40G,隐藏分区大约5G,然后我的xp占了一个20G的ntfs分区,然后我把ubuntu5.10装在剩下的15G空间里,是自动分区的。然后就出现了上面所说的情况,是不是因为ubuntu修改了MBR或者启动分区的一些地方,导致xp无法识别自己的分区了。请高手指教,急!
头像
oneleaf
论坛管理员
帖子: 10208
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 99 次

#7

帖子 oneleaf » 2005-11-04 11:04

由于XP的分区顺序好像和Linux下的分区顺序不一样。所以安装Linux后,XP的安装的那个硬盘的分区顺序不对了。所以XP启动不了了,基本上是这样的,你安装前系统上有5G的隐藏分区,但XP没有理会,还是以为自己是第一个分区,而加入Linux,多了一个分区出来,于是XP发现自己是第二个分区,其实,本来就是第二个分区,于是就死掉了。

这种情况我有遇到,一般将那个隐藏分区删除,重新安装XP到硬盘的主分区就没有问题了。

重新安装是没有问题的,如果是行货,应该有送XP,如果是水货,更没有关系了,直接找个XP带SP2的重灌进去,一般就会好了。
beinfant
帖子: 14
注册时间: 2005-11-03 15:54
送出感谢: 0
接收感谢: 0

#8

帖子 beinfant » 2005-11-04 11:05

请问那个隐藏的分区如何删除?我用Acronis Disk Director看不到。
回复

回到 “常用硬件支持”