当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 10 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 现在笔记本有声音了,但却响个不停!!!
帖子发表于 : 2005-11-06 16:58 

注册: 2005-09-30 23:55
帖子: 105
送出感谢: 0 次
接收感谢: 0 次
请先参考贴子
http://forum.ubuntu.org.cn/viewtopic.php?t=3781

后来我把acpi=off改为了noapic
结果现在开机进入ubuntu后,就一直发出“布拉布拉”的声音,一直不停!!
因为我从来没听过ubuntu的开机音乐,所以我怀疑这个是不是ubuntu的开机音乐啊??
而且现在可以彻底关机了,但是进入系统以后特别慢!估计就是因为那个声音不停的原因
看来应该我的笔记本没有声音不是驱动的问题了
现在不知道该怎么办了


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2005-11-06 21:05 
论坛管理员

注册: 2005-03-27 0:06
帖子: 10110
系统: Ubuntu 12.04
送出感谢: 7
接收感谢: 127
其实笔记本的问题主要还是bios有错误的问题,修改bios的配置吧,或者找到升级版本。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-11-06 22:20 

注册: 2005-09-30 23:55
帖子: 105
送出感谢: 0 次
接收感谢: 0 次
我已经升到最新的bios了
还是这个样子


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2005-11-07 0:10 
头像

注册: 2005-08-14 21:55
帖子: 58436
地址: 长沙
送出感谢: 4
接收感谢: 272
把“多媒体选择器”那里都试试。没有音频服务,难道也响。


_________________
● 鸣学


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2005-11-07 0:22 
头像

注册: 2005-08-02 7:23
帖子: 773
地址: 上海
送出感谢: 0 次
接收感谢: 1
看log,好像系统对你BIOS的PNP支持有问题,没有办法给声音设备分配到中断.提示用以下这个参数:pci=biosirq ,你可以在内核启动里加上试试,另外看看你的bios吧,会不会有什么选项没有选好.
另外BIOS里禁用掉自带的modem试试.


_________________
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2005-11-07 12:25 

注册: 2005-09-30 23:55
帖子: 105
送出感谢: 0 次
接收感谢: 0 次
eexpress 写道:
把“多媒体选择器”那里都试试。没有音频服务,难道也响。

使用noapic参数时,就是没有音频服务也响,但用音量按钮可以调节“布拉布拉”声音的大小,也可以把“布拉布拉”声音关掉,但系统还是很慢


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2005-11-07 13:30 
头像

注册: 2005-08-14 21:55
帖子: 58436
地址: 长沙
送出感谢: 4
接收感谢: 272
确实是系统支持主板的问题。
不过还有一种可能,就是有些机器碰到音量不能控制的事(要不最大,要不静音),你的这个好像是那种背景噪音一样的,因为你的也可以关闭嘛。


_________________
● 鸣学


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2005-11-07 22:00 
头像

注册: 2005-08-02 7:23
帖子: 773
地址: 上海
送出感谢: 0 次
接收感谢: 1
代码:
[ 293.935037] PCI: No IRQ known for interrupt pin A of device 0000:00:1b.0. Please try using pci=biosirq.
[ 293.935054] hda-intel: unable to grab IRQ 0
[ 293.935083] HDA Intel: probe of 0000:00:1b.0 failed with error -16
[ 534.297854] PCI: No IRQ known for interrupt pin A of device 0000:00:1b.0. Please try using pci=biosirq.
[ 534.297875] hda-intel: unable to grab IRQ 0
[ 534.297889] HDA Intel: probe of 0000:00:1b.0 failed with error -16

log里的这部分,说明声音硬件没有正常启动.


_________________
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2005-11-08 14:03 

注册: 2005-09-30 23:55
帖子: 105
送出感谢: 0 次
接收感谢: 0 次
参数pci=biosirq也试过了
单独的pci=biosirq启动不了ubuntu
如果是acpi=off 加 pci=biosirq,可以启动,但没有声音


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2005-11-09 1:54 
头像

注册: 2005-08-02 7:23
帖子: 773
地址: 上海
送出感谢: 0 次
接收感谢: 1
要不试试调整一下bios里的irq设置,手工分配.


_________________
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 10 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译