当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 22 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 发贴庆祝,昂达A69T终于有声音了!!!!!!!!!兴奋ing
帖子发表于 : 2007-06-02 11:39 

注册: 2007-05-29 21:55
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
我的主板是A69T,声卡ALC861 系统是ubuntu7.04的,
其实我是按
https://help.ubuntu.com/community/HdaIntelSoundHowto
去做的。搞了一天了,试过论坛发的人的差不多所有方法都不行,只能自己去看英文了,幸亏我的英文还不错,呵呵,说笑的。。。。。。。。
按照他说的:
1,在BIOS下把audio的auto改成disable。我试过不取消BIOS的audio选项,也是按照他说的方法做,不行,看来这一步是必须的,起码可能是到现在还出不了声音的A69T必做的一步。

2,下载所需要的工具,

    sudo apt-get install build-essential ncurses-dev

3,装kernel headers

    sudo apt-get install linux-headers-`uname -r`

4,下载最新的alsa project,

   http://www.alsa-project.org/alsa/ftp/driver/下载alsa-driver-1.0.14rc4.tar.tar2
   http://www.alsa-project.org/alsa/ftp/lib/下载alsa-lib-1.0.14rc4.tar.tar2
   http://www.alsa-project.org/alsa/ftp/utils/下载alsa-utils-1.0.14rc4.tar.tar2

下载到~/downloads目录下

5,装。

   sudo mkdir -p /usr/src/alsa
   cd /usr/src/alsa
   sudo cp ~/downloads/alsa* .
   sudo tar xjf alsa-driver-1.0.14rc4.tar.bz2
   sudo tar xjf alsa-lib-1.0.14rc4.tar.bz2
   sudo tar xjf alsa-utils-1.0.14rc4.tar.bz2

6,编译alsa-driver

   cd alsa-driver-1.0.14rc4
   sudo ./configure --with-cards=hda-intel
   sudo make
   sudo make install

7,编译alsa-lib

   cd ../alsa-lib-1.0.14rc4
   sudo ./configure
   sudo make
   sudo make install

8,编译alsa-utils

   cd ../alsa-utils-1.0.14rc4
   sudo ./configure
   sudo make
   sudo make install

9,找ALSA-Configuration.txt文件看你的snd-hda-intel model
在你建了的/usr/src/alsa/alsa-driver-1.0.14rc4/alsa-kernel/Documentation下,
找到

ALC861VD/660VD
3stack 3-jack
3stack-dig 3-jack with SPDIF OUT
6stack-dig 6-jack with SPDIF OUT
3stack-660 3-jack (for ALC660VD)
auto auto-config reading BIOS (default)

看来识别不了。。。。。。。。
model为3stack

10,编辑/etc/modprobe.d/alsa-base

   gksudo gedit /etc/modprobe.d/alsa-base

11,在最后加上

   options snd-hda-intel model=3stack

OK了,全部工作做完,可以重启了,进入界面播出吓人的声音,原来我的音响开得太大了,哈哈。。。。。。。。

顺便说一下,我显卡驱动装的方法完全是按照

http://forum.ubuntu.org.cn/viewtopic.php?t=26188

的方法二装的,OK,分辨率有85,可惜我装完后,桌面效果不能用,提示“合成扩展不可用”,哪位可以用的给个方法。。。。。。。。。。。。。。。。

本人刚刚接触ubuntu,是个新手,错误之处欢迎提出。。。。。。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-06-02 12:37 
头像

注册: 2007-06-01 22:55
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
说实话,我吃了饭马上去补习英语。。。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-06-02 14:01 
头像

注册: 2007-06-01 22:55
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
我的板子也是A69T , 按照楼主说的改了BIOS中的那个选项,进入KUBUNTU,连音频设备都找不到了,不知道是什么原因。
还有,楼主写的第八项中的 gksudo 似乎没有这样一个命令。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-06-02 17:42 

注册: 2007-05-29 21:55
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
keleo030 写道:
我的板子也是A69T , 按照楼主说的改了BIOS中的那个选项,进入KUBUNTU,连音频设备都找不到了,不知道是什么原因。
还有,楼主写的第八项中的 gksudo 似乎没有这样一个命令。


编译完三个文件后,重启是回到BIOS把audio改回来,

我的系统可以运行gksudo阿,gksudo 的gk 和sudo没有空格哦


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-06-02 19:41 
头像

注册: 2007-06-01 22:55
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
谢谢,我再试试.


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-06-03 17:58 

注册: 2006-10-07 11:07
帖子: 108
地址: 成都
送出感谢: 0 次
接收感谢: 0 次
我也是这个板子,禁用集成声卡之后独立声卡才能100%发声,不然只有10%的几率有声音(我的音箱是接的独立声卡)

显卡问题也差不多,不能用3d桌面效果


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-06-04 18:17 

注册: 2007-05-06 2:11
帖子: 184
送出感谢: 0 次
接收感谢: 0 次
我的板子也是A69T ,但是在BIOS里找不到AUDIO选项,请楼主明示.期待中................


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-06-05 13:46 

注册: 2007-05-29 21:55
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
xufund 写道:
我的板子也是A69T ,但是在BIOS里找不到AUDIO选项,请楼主明示.期待中................


我的BIOS是1.02版的,是在第四项Integrated Peripherals里,

Integrated Peripherals/South Onchip PCI Device/ATI Azalia Audio

其他版本的BIOS也应该差不多,你找找。。。。。。。。。。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-06-05 20:15 

注册: 2007-05-06 2:11
帖子: 184
送出感谢: 0 次
接收感谢: 0 次
谢谢.我试试看


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-06-05 21:37 
头像

注册: 2007-04-23 17:40
帖子: 659
送出感谢: 0 次
接收感谢: 0 次
搂主,显卡问题解决了么?
我的显卡怎么识别为X1200呢?
执行AMD CCC Linux Edition时会闪烁几下,你的是这样的情况么?
我的也是“合成扩展错误”郁闷。


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-06-06 10:33 

注册: 2007-05-29 21:55
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
forrid 写道:
搂主,显卡问题解决了么?
我的显卡怎么识别为X1200呢?
执行AMD CCC Linux Edition时会闪烁几下,你的是这样的情况么?
我的也是“合成扩展错误”郁闷。


我也是这种情况,好郁闷,可能我们的显卡就是x1200也说不定,也可能它还识别不出来,现在网上都在争论A69T的显卡是

不是x1250


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-06-06 17:15 
头像

注册: 2007-04-23 17:40
帖子: 659
送出感谢: 0 次
接收感谢: 0 次
我们的显卡应该是1250的,在windows下可以看到详细信息。我也怀疑过是假的,真晕死了。


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-06-09 23:57 

注册: 2007-05-06 2:11
帖子: 184
送出感谢: 0 次
接收感谢: 0 次
很遗憾。我按楼主的方法试了重启后还是没声音。
系统提示:
没有找到音量控制插件和/或设备


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2007-06-11 0:14 

注册: 2007-06-10 23:00
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
gxgx XD


页首
 用户资料  
 
15 楼 
 文章标题 : 终于有声音了
帖子发表于 : 2007-07-22 9:02 
头像

注册: 2007-07-22 8:56
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
:D 很高兴,很上述方法终于有声音了,thanks a lot!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 22 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译