Ubuntu下无法识别u盘?

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
shawnrong
帖子: 2
注册时间: 2007-06-06 9:28
送出感谢: 0
接收感谢: 0

Ubuntu下无法识别u盘?

#1

帖子 shawnrong » 2007-06-06 9:35

在ibm t40上装的ubuntu 7.04,已经在新立得中升级到最新。
插入u盘后,系统没任何反应,用
#lsusb
也看不到任何设备信息:
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000
如果插入usb鼠标倒是可以识别,正常使用:
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 002: ID 046d:c00e Logitech, Inc. M-BJ69 Optical Wheel Mouse
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000
之前曾经在一个台式机和一台compaq笔记本上安装过ubuntu,都能正常识别该u盘,也试过
别的u盘,可以确认不是u盘的问题。

dmesg查看usb相关的信息:
[ 1885.556000] usb 4-4: new high speed USB device using ehci_hcd and address 114
[ 1887.824000] usb 4-4: new high speed USB device using ehci_hcd and address 122
[ 1888.328000] usb 4-4: new high speed USB device using ehci_hcd and address 123
[ 1893.116000] usb 4-4: new high speed USB device using ehci_hcd and address 15
[ 1897.652000] usb 4-4: new high speed USB device using ehci_hcd and address 32
[ 1899.668000] usb 4-4: new high speed USB device using ehci_hcd and address 39
[ 1900.172000] usb 4-4: new high speed USB device using ehci_hcd and address 40
[ 1904.204000] usb 4-4: new high speed USB device using ehci_hcd and address 55
[ 1907.984000] usb 4-4: new high speed USB device using ehci_hcd and address 69
[ 1909.244000] usb 4-4: new high speed USB device using ehci_hcd and address 73
[ 1915.040000] usb 4-4: new high speed USB device using ehci_hcd and address 95
[ 1917.812000] usb 4-4: new high speed USB device using ehci_hcd and address 105
[ 1918.072000] ehci_hcd 0000:00:1d.7: port 4 reset error -110
[ 1918.072000] hub 4-0:1.0: hub_port_status failed (err = -32)
[ 1927.136000] usb 4-4: new high speed USB device using ehci_hcd and address 13
[ 1927.640000] usb 4-4: new high speed USB device using ehci_hcd and address 14
[ 1935.200000] usb 4-4: new high speed USB device using ehci_hcd and address 43
[ 1935.460000] ehci_hcd 0000:00:1d.7: port 4 reset error -110
[ 1935.460000] hub 4-0:1.0: hub_port_status failed (err = -32)
[ 1937.216000] usb 4-4: new high speed USB device using ehci_hcd and address 48


在google上搜索,好像都没有人遇到这种问题。别人顶多是不能自动mount,可我这里好像
是根本连硬件都没认出来?!
shawnrong
帖子: 2
注册时间: 2007-06-06 9:28
送出感谢: 0
接收感谢: 0

#2

帖子 shawnrong » 2007-06-06 10:16

问题解决,执行
rmmod ehci_hcd
后就可以识别了,好畸形阿!
lumi
帖子: 78
注册时间: 2007-04-30 17:03
来自: 苏州
送出感谢: 0
接收感谢: 0

#3

帖子 lumi » 2007-06-20 16:43

估计是ehci(usb 2.0的host)驱动的兼容性问题。

rmmod ehci_hcd是卸载掉ehci的驱动,这样,你的u盘虽然能够访问,实际是按照usb 1.1的方式访问的。速度会慢很多。
letcase
帖子: 17
注册时间: 2007-07-29 8:57
来自: 武汉
送出感谢: 0
接收感谢: 0

#4

帖子 letcase » 2007-08-07 11:21

我也碰到这个问题了,按2楼方法解决了。可是我以前是可以用的,最后一次好像提示有错误,当时没有仔细看,后来就不行了。
头像
dsdsdds
帖子: 523
注册时间: 2007-04-05 21:22
送出感谢: 0
接收感谢: 0

#5

帖子 dsdsdds » 2008-05-14 12:06

:D强烈赞!
cnking.org
帖子: 2
注册时间: 2010-03-19 20:35
送出感谢: 0
接收感谢: 0

Re: Ubuntu下无法识别u盘?

#6

帖子 cnking.org » 2010-03-19 20:40

Ubuntu无法识别USB记忆棒的解决办法:http://www.cnking.org/post/355.html
头像
iorikyox
帖子: 92
注册时间: 2010-04-02 16:16
送出感谢: 1 次
接收感谢: 0

Re: Ubuntu下无法识别u盘?

#7

帖子 iorikyox » 2010-04-08 10:49

谢谢ls的回复,我的读卡器在ubuntu9.10下不能读sd卡,试试看
回复

回到 “常用硬件支持”