显示:合成扩展(composite extension)不能用

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
smartcar
帖子: 131
注册时间: 2006-04-07 14:14
来自: 北京
送出感谢: 0
接收感谢: 0
联系:

显示:合成扩展(composite extension)不能用

#1

帖子 smartcar » 2007-06-07 14:46

大家好,我用的是nc6000这款笔记本,显卡是ATI 9600的,在ubuntu 7.04 下我尝试使用显示效果,出了这个错误,不知道大家能不能告诉我需要怎么设置一下才能打开相关特性的支持?
谢谢了!
smartcar
帖子: 131
注册时间: 2006-04-07 14:14
来自: 北京
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 smartcar » 2007-06-07 16:42

自己顶一下!
头像
forrid
帖子: 659
注册时间: 2007-04-23 17:40
送出感谢: 0
接收感谢: 0

#3

帖子 forrid » 2007-06-07 20:22

ATI的显卡阿?别费那劲了
smartcar
帖子: 131
注册时间: 2006-04-07 14:14
来自: 北京
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 smartcar » 2007-06-08 14:41

不能搞定是么?:)
forrid 写了:ATI的显卡阿?别费那劲了
smartcar
帖子: 131
注册时间: 2006-04-07 14:14
来自: 北京
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 smartcar » 2007-06-11 12:55

我再顶顶顶!
NICMICHAEL
帖子: 309
注册时间: 2006-01-04 19:26
送出感谢: 0
接收感谢: 0

#6

帖子 NICMICHAEL » 2007-06-11 13:18

代码: 全选

sudo apt-get install xserver-xgl[code]

sudo gedit /usr/bin/startxgl

在新文件中添加以下这段脚本并保存退出
代码:
#!/bin/sh
Xgl :1 -fullscreen -ac -accel xv:pbuffer -accel glx:pbuffer &
DISPLAY=:1
cookie="$(xauth -i nextract - :0 | cut -d ' ' -f 9)"
xauth -i add :1 . "$cookie"
exec dbus-launch --exit-with-session gnome-session


代码:
gksudo nautilus /usr/bin

找到startxgl 右键属性->权限->勾选“允许以程序执行文件”



sudo gedit /usr/share/xsessions/xgl.desktop

添加以下一段
代码:

    [Desktop Entry]
    Encoding=UTF-8
    Name=Xgl
    Comment=Start an Xgl Session
    Exec=/usr/bin/startxgl
    Icon=
    Type=Application

重启,在登录界面选择会话成XGL
Athlon 64 X2 Dual Core Processor 4200+ Socket 939 OC 2.8 GHZ
G.Skill DDR400 2 3 2 5 1GB *2 Dual Channel OC DDR500
Szgalaxy 8600 GTE 650MHZ/2000MHZ
Seagate 80GB *2 RAID 0+Maxtor 80G
DFI LanParty UT NF4-D
kernel 2.6.22-ck1 再见,Con Kolivas!
smartcar
帖子: 131
注册时间: 2006-04-07 14:14
来自: 北京
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 smartcar » 2007-06-11 15:59

按照NICMICHAEL给出的方法的确是可用的,不过速度巨慢,或许是我的显卡确实太烂了?或者是驱动没搞对?
NICMICHAEL 写了:

代码: 全选

sudo apt-get install xserver-xgl[code]

sudo gedit /usr/bin/startxgl

在新文件中添加以下这段脚本并保存退出
代码:
#!/bin/sh
Xgl :1 -fullscreen -ac -accel xv:pbuffer -accel glx:pbuffer &
DISPLAY=:1
cookie="$(xauth -i nextract - :0 | cut -d ' ' -f 9)"
xauth -i add :1 . "$cookie"
exec dbus-launch --exit-with-session gnome-session


代码:
gksudo nautilus /usr/bin

找到startxgl 右键属性->权限->勾选“允许以程序执行文件”



sudo gedit /usr/share/xsessions/xgl.desktop

添加以下一段
代码:

    [Desktop Entry]
    Encoding=UTF-8
    Name=Xgl
    Comment=Start an Xgl Session
    Exec=/usr/bin/startxgl
    Icon=
    Type=Application

重启,在登录界面选择会话成XGL
头像
ipv6now
帖子: 759
注册时间: 2006-09-30 1:08
来自: QingDao
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 ipv6now » 2007-06-11 16:23

smartcar
帖子: 131
注册时间: 2006-04-07 14:14
来自: 北京
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 smartcar » 2007-06-11 17:25

谢谢!
在看到您的回复前,我参考了
post-294551.html&sid=0d28d562c66e95b3b1 ... e11ec8帖子中的
http://wiki.beryl-project.org/wiki/Inst ... with_AIGLX

说的和您的回复差不多。

我只是将1.sudo dpkg-reconfigure xserver-xorg
然后选择相应的类型为ati,其他设置默认
2.将xserver-xgl,xorg-driver-fglrx删除了,
3.然后确认了一下上面的帖子中的那些xorg设置。
然后重新启动了xwindows,就可以使用特效了,然而beryl并没有尝试,我觉得系统默认的已经很好了
dreamyfish
帖子: 79
注册时间: 2007-01-29 11:24
送出感谢: 0
接收感谢: 0

#10

帖子 dreamyfish » 2007-06-14 12:26

我也是用 NC6000 的本子阿~~~ 问题多多没解决。。。 我现在驱动都装的乱乱的。。。也不清楚目前用的到底是啥驱动了。。。
头像
Ghostboxer
帖子: 36
注册时间: 2007-06-09 15:29
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 Ghostboxer » 2007-06-15 12:51

安装受限驱动:
fglrx+xgl+beryl

fglrx+aiglx+beryl

直接用开源驱动:
mesa+beryl
dmymk
帖子: 59
注册时间: 2007-06-11 10:19
送出感谢: 0
接收感谢: 0

#12

帖子 dmymk » 2007-07-14 23:24

我的也是ATI 9600/64MB的显卡,老是搞不好,干脆用系统自带的驱动,没有装受限驱动
回复

回到 “常用硬件支持”