当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 44 篇帖子 ]  前往页数 1, 2, 3  下一页
作者 内容
1 楼 
 文章标题 : 新人老声卡:LINUX大侠请帮帮忙
帖子发表于 : 2005-11-14 8:30 

注册: 2005-11-14 7:55
帖子: 24
地址: 山东济南
送出感谢: 0 次
接收感谢: 0 次
感谢您关心此贴
我的声卡系ISA接口的Realtek瑞昱ALS 007老声卡,在WINDOWS系列里均有驱动.可我装好ubuntu后没有认到。听说LINUX对一些老声卡也支持(好像有通用的旧声卡程序)在系统管理Device Manager里显示PnP Device(@H@0001)等等
我也相信驱动程序只是时间问题,但听过朋友家的ubuntu的音效后,
实在太激动了,恳求高手指点如何安装?
我的声卡需要套用Sound Blaster的驱动吗?那么在哪里设置呢
多谢!
:cry:


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2005-11-17 9:23 

注册: 2005-11-16 18:01
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
我也遇到类似的问题, 网上疯狂找答案中,楼上如有了答案,可否贴出来.


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-11-17 9:35 
头像

注册: 2005-07-10 11:50
帖子: 191
送出感谢: 0 次
接收感谢: 0 次
http://www.alsa-project.org/

去这里找你的声卡,自己编译安装


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2005-11-18 4:57 

注册: 2005-11-14 7:55
帖子: 24
地址: 山东济南
送出感谢: 0 次
接收感谢: 0 次
多谢3楼的大侠douban热心回贴 我等了50多人,终于等到您了 向您敬个礼
您提到的“自己编译安装”是指编译内核吗?我从没尝试过,第一次弄有没有要特别注意的地方呢?
2楼的i2ubuntu我们都来试试吧,反正编译内核是早晚要接触的事,祝我们好运吧 :lol:


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2005-11-18 9:40 

注册: 2005-11-14 7:55
帖子: 24
地址: 山东济南
送出感谢: 0 次
接收感谢: 0 次
我已经完成一半啦,在http://www.alsa-project.org/ 中找到了我声卡的页面
但好像里面是些代码(是需要复制这些代码到特定的地方吗?)
请问douban
你所指的编译安装是指“仅仅针对声卡部分的设置调整”吗?在哪里啊
或者
还是指整个内核的升级?听说这样会很占硬盘空间,且很费时,老点的机器需要7个多小时,是这样吗?
我是刚刚装好的ubuntu,我需要手动升级内核吗?(好像先得下载源代码)
有劳您细说


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2005-11-18 9:56 
头像

注册: 2005-07-10 11:50
帖子: 191
送出感谢: 0 次
接收感谢: 0 次
那是驱动源码,编译驱动,不用编译内核。那个网站有详细的文档,按着步骤做就行了

http://www.linuxsir.org/bbs/showthread.php?t=45116


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2005-11-19 7:59 

注册: 2005-11-14 7:55
帖子: 24
地址: 山东济南
送出感谢: 0 次
接收感谢: 0 次
早上好douban
再次向你致谢!
我看到你的及时回复,胸中豁然开朗。准备去好好看看,有了你指点,我也不缺信心搞定它了。
ubuntu:爱,需要耐心 :P


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2005-11-19 22:54 

注册: 2005-11-14 7:55
帖子: 24
地址: 山东济南
送出感谢: 0 次
接收感谢: 0 次
请问douban
我看到DT-019X / Avance Logic ALS-007正是有关我声卡模块的内容:

snd-dt019x模块选项的如下“代码”(我这么说对吗)

# parm: index int array (min = 1, max = 8), description "Index value for DT-019X based soundcard."
# parm: id string array (min = 1, max = 8), description "ID string for DT-019X based soundcard."
# parm: enable int array (min = 1, max = 8), description "Enable DT-019X based soundcard."
# parm: port long array (min = 1, max = 8), description "Port # for dt019x driver."
# parm: mpu_port long array (min = 1, max = 8), description "MPU-401 port # for dt019x driver."
# parm: fm_port long array (min = 1, max = 8), description "FM port # for dt019x driver."
# parm: irq int array (min = 1, max = 8), description "IRQ # for dt019x driver."
# parm: mpu_irq int array (min = 1, max = 8), description "MPU-401 IRQ # for dt019x driver."
# parm: dma8 int array (min = 1, max = 8), description "8-bit DMA # for dt019x driver."
这些参数是不是该在我驱动出声卡后,才需要用到的“调节”选项啊?

我从你提供的网页:
http://www.alsa-project.org/alsa-doc/do ... 019x#notes
下面看到这段话:
copy and paste the following into the file then save it.

pcm.dt019x {
type hw
card 0
}

ctl.dt019x {
type hw
card 0
}

是否将我前面所谓的“代码”放在上面的大括号里?

我安装alsa-driver-1.0.7
alsa-lib-1.0.7
alsa-utils-1.0.7时的路径有特定要求位置吗?


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2005-11-19 23:05 
头像

注册: 2005-08-02 7:23
帖子: 773
地址: 上海
送出感谢: 0 次
接收感谢: 1
你应该不需要编译的,ubuntu里已经有这个驱动了,可能是因为是ISA的不能自动加载,你可以试试
代码:
sudo modprobe snd-dt019x

引用:
pcm.dt019x {
type hw
card 0
}

ctl.dt019x {
type hw
card 0
}

这一部分应该不需要的,新的驱动已经自带了大部分声卡的配置参数.
如果要用的话,把它放到一个文档里,取名.asoundrc,放在自己的家目录下.


_________________
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2005-11-19 23:13 

注册: 2005-11-14 7:55
帖子: 24
地址: 山东济南
送出感谢: 0 次
接收感谢: 0 次
想问douban
你在第二次回贴中提到的http://www.linuxsir.org/bbs/showthread.php?t=45116
有关alsa的内容
确实非常详尽,但好像有些终端命令执行不了,是版本低于ubuntu的原因吗?
我的是用ubuntu5.10 DVD光碟安装到硬盘上的,也升级了源(内核没敢动)
总感觉在下面的英文页面中http://www.alsa-project.org/alsa-doc/doc-php/template.php?company=Avance+Logic&card=ALS007.&chip=&module=dt019x#notes
提到的安装步骤很简洁,是这样吗? :roll:


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2005-11-19 23:21 

注册: 2005-11-14 7:55
帖子: 24
地址: 山东济南
送出感谢: 0 次
接收感谢: 0 次
谢谢9楼的
catinsnow

但为何我执行sudo modprobe snd-dt019x后,没有反应呢,
如下面
qian@chen:~$ sudo modprobe snd-dt019x
Password:
qian@chen:~$ sudo modprobe snd-dt019x
qian@chen:~$
是我还少装什么类似alsa-driver-1.0.7文件吗?

:?:


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2005-11-19 23:24 
头像

注册: 2005-08-02 7:23
帖子: 773
地址: 上海
送出感谢: 0 次
接收感谢: 1
代码:
lsmod |grep snd

看看.


_________________
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2005-11-19 23:46 

注册: 2005-11-14 7:55
帖子: 24
地址: 山东济南
送出感谢: 0 次
接收感谢: 0 次
catinsnow你还在线吗?

我按你说的试,出现
qian@chen:~$ lsmod |grep snd
snd_dt019x 10340 0
snd_sb16_dsp 10816 1 snd_dt019x
snd_sb_common 15168 2 snd_dt019x,snd_sb16_dsp
snd_cmipci 33696 3
gameport 14920 3 ns558,snd_cmipci
snd_pcm_oss 53152 0
snd_mixer_oss 19392 1 snd_pcm_oss
snd_pcm 89032 4 snd_sb16_dsp,snd_cmipci,snd_pcm_oss
snd_page_alloc 10696 1 snd_pcm
snd_opl3_lib 10688 2 snd_dt019x,snd_cmipci
snd_timer 24260 3 snd_pcm,snd_opl3_lib
snd_hwdep 8992 1 snd_opl3_lib
snd_mpu401_uart 7360 2 snd_dt019x,snd_cmipci
snd_rawmidi 25056 1 snd_mpu401_uart
snd_seq_device 8524 2 snd_opl3_lib,snd_rawmidi
snd 55172 17 snd_dt019x,snd_sb16_dsp,snd_sb_common,snd_cmipci,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_opl3_lib,snd_timer,snd_hwdep,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore 9696 1 snd
qian@chen:~$

请您点解
(注:我主板上板载的cmi8738声卡芯片坏了却能认到,当然它也不发音,不然我就不废劲搞als007啦)


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2005-11-21 9:18 

注册: 2005-11-14 7:55
帖子: 24
地址: 山东济南
送出感谢: 0 次
接收感谢: 0 次
高手们请别放弃我好吗? :cry:


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2005-11-21 14:27 
头像

注册: 2005-08-02 7:23
帖子: 773
地址: 上海
送出感谢: 0 次
接收感谢: 1
运行
代码:
alsamixer

看看有没有出错,如果不出错应该是驱动正常了,没有声音的话看是不是靜音了,按m键可以切换状态.
如果出错,再试试
代码:
sudo alsamixer

如果这个可以,可能是因为你没有加入到可以使用声音设备的组,用户和组里设置一下.
如果全不行,运行
代码:
dmesg

看看系统加载声音驱动时的出错提示,再进一步打算.
另外你的板载卡最好在bios里禁用掉,说不定是它的问题.


_________________
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 44 篇帖子 ]  前往页数 1, 2, 3  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译