当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 12 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 重大发现:死锁用户进来看
帖子发表于 : 2007-07-02 11:14 

注册: 2007-05-30 14:44
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
我的机器配置
AMD3000+
ATIx700

似乎ATI的显卡是最令人头痛的。

我装完Linux之后,都会死机,表现是鼠标键盘失去一切响应,只能用Reset键重启,但没过2分钟又会死机。
难道是X700的问题?

后来终于发现了,其实不是显卡的缘故(不用3D桌面,Ubuntu还是很稳定的)而是CPU的问题!

我发现,问题出在一个服务上了。
它叫 powernow
在init.d里,它叫powernowd,作用是用于CPU的调频。
所以,在Ubuntu里,你只要关掉这个服务就行

apt-get install sysv-rc-conf
来安装启动服务管理工具,然后用它把powernowd这个启动服务关掉。(把打X的全去掉)

对于Fedora用户,如果出现同样的问题,可以用ntsysv工具把
cupspeed关掉(和powernow似乎是差不多的东西,没有研究过)

这样,机器就不会死机了。

试试吧:)


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-07-02 11:20 

注册: 2007-05-30 14:44
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
因为这个,我重装了几十遍ATI的驱动啊,各种找,各种装
从Fedora换到Ubuntu,再又换过来,再换过去。
真不知道那些程序员怎么想的,不能用的东西,还自动加载了。
没有查到有人反应了这个Bug
本Bug有超级牛力!


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-07-02 19:31 

注册: 2007-05-29 5:20
帖子: 123
送出感谢: 0 次
接收感谢: 0 次
although i don't use amd, i still want to support you. thanks for sharing your experience with other users!


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-07-02 20:25 
头像

注册: 2007-01-15 17:15
帖子: 3766
送出感谢: 0 次
接收感谢: 0 次
顶楼上的,就要这气氛


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-07-02 22:44 

注册: 2007-01-13 22:39
帖子: 202
地址: 杭州
送出感谢: 0 次
接收感谢: 0 次
好贴,顶起来让更多的人知道~~!!


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-07-03 15:28 

注册: 2007-04-20 20:10
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
不会哦,我用的就是如假包换的……AMD Athlon 3000+

++++++++++++++++++
Biostar NFS 550 SE
AMD Athlon 3000+
Nvidia Geforce 7300GT
Kingston 512 MB
...
++++++++++++++++++

不晓得主板型号里的前三个字母写对了木有。。。。

一个多月来N次重装(N>=20)证明,ubuntu与该U相处得很好。至于重装的原因,大多是因为自己手工搞乱了系统……

另外,我还把ubuntu 7.04装到了IBM thinkpad 600E(PII 366Mhz+288 MB+2.5M 显存)上,木有问题……就是太慢,现在被我换成了FreeBSD 6.2~~~


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-07-03 16:57 
头像

注册: 2005-08-14 19:53
帖子: 3998
送出感谢: 1
接收感谢: 2
的确是3d和ati驱动的问题。一般和cpu的可能性比较小。而且我换了beryl为compiz后稳定多了

而且我记得我以前没有安装powernowd或者cpufreq的时候一样死机。其实是x死了。

你在acpi里面定义机箱power键为reboot,然后死机的时候暗一下,就自动重启。这样就避免了对硬盘的伤害。

警告:热启动多了容易把分区表弄坏的。要小心。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-07-10 17:54 

注册: 2007-05-30 14:44
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
我是CPU的关系。实践证明。不关PowerNow就是机,没有办法。
关了就是不死了。
铁证如山!
如果有人遇到同样的问题可以试试。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-07-19 15:32 
头像

注册: 2007-07-13 22:07
帖子: 62
送出感谢: 0 次
接收感谢: 0 次
那个PowerNow是干什么用的?


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-07-19 20:34 
头像

注册: 2005-08-14 19:53
帖子: 3998
送出感谢: 1
接收感谢: 2
可是这样就没有自动降频的功能了阿。。


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-10-06 23:40 
头像

注册: 2007-08-24 13:32
帖子: 212
送出感谢: 0 次
接收感谢: 0 次
顶楼主一个,这个问题自从装了UBUNTU来一直没有得到解决。我还以为是因为我的Xorg没有配置好的缘故。


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-10-07 14:54 
头像

注册: 2007-08-24 13:32
帖子: 212
送出感谢: 0 次
接收感谢: 0 次
我关闭了powernowd和powernowd.ea还是不管用,仍然要假死.......


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 12 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:MSNbot Media 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译