当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 宽屏,装完ubuntu后,启动后屏幕显示“超出显示范围”[问题]在线等(已解决)
帖子发表于 : 2007-08-02 0:34 
头像

注册: 2007-08-02 0:12
帖子: 133
送出感谢: 0 次
接收感谢: 0 次
什么显示也没有,也不知道如何退到字符界面,如何配置。每次启动都是这样,请高手指点一下初学者!!!谢谢


最后由 lifeva 编辑于 2007-08-05 11:55,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-08-02 0:43 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
ctrl-alt-f2进去,登录。
sudo dpkg-reconfigure xserver-xorg
配置下试试。


_________________
● 鸣学


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-08-02 0:51 
头像

注册: 2007-08-02 0:12
帖子: 133
送出感谢: 0 次
接收感谢: 0 次
我是nvidia的显卡,是不是驱动没有配置好?我是初次,菜鸟,还请高手不厌其烦的指导一下


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-08-02 0:57 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
你还记下另外的方法
ctrl-alt-f2进去,登录。当然,有live cd进去也可以,要知道自己挂载分区的。呵呵。
sudo nano /etc/X11/xorg.conf
把里面的
Section "Device"

#Option "Rotate" "CW"
Identifier "nVIDIA GeForce FX Go7300"
Driver "nvidia"
EndSection

改成 nv

再sudo killall gdm 2次。
再sudo gdm &运行


_________________
● 鸣学


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-08-02 1:00 
头像

注册: 2007-08-02 0:12
帖子: 133
送出感谢: 0 次
接收感谢: 0 次
sudo nano /etc/X11/xorg.conf后,里面是空的,怎么回事呢?

都是小写的,改正过了X11大写,还是空的


最后由 lifeva 编辑于 2007-08-02 1:13,总共编辑了 2 次

页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-08-02 1:05 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
你输入错误了吧。大小写注意下。


_________________
● 鸣学


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-08-02 1:48 
头像

注册: 2007-08-02 0:12
帖子: 133
送出感谢: 0 次
接收感谢: 0 次
检查过了,已经是nv了,分辨率也加上了1440*900,但是还是无法进入图形界面,我的FP95W除了黑屏还提示“超出显示范围”请高手继续指导!!多谢了


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-08-02 15:12 
头像

注册: 2007-08-02 0:12
帖子: 133
送出感谢: 0 次
接收感谢: 0 次
还有没有哪一位高人给继续指导一下啊?


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 宽屏,装完ubuntu后,启动后屏幕显示“超出显示范围”[问题]在线等(已解决)
帖子发表于 : 2008-11-03 23:20 

注册: 2008-11-03 22:59
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
lifeva 写道:
什么显示也没有,也不知道如何退到字符界面,如何配置。每次启动都是这样,请高手指点一下初学者!!!谢谢


我的显卡是ATI HD2400,解决方法如下:
1.如果已安装受限驱动的,开机进入GRUB菜单后,选内核的“recovery mode”,进入后,选“root”菜单,在命令行下,将受限驱动删除:


sudo apt-get remove xorg-driver-fgrlx

2.退出命令行,选xfix菜单修复,再选resume菜单登录到ubuntu,再安装受限驱动,记住先不要重启,再编辑xorg.conf

sudo gedit /etc/X11/xorg.conf

将xorg.conf的内容改为如下:

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "cn"
Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
EndSection

Section "Device"
Identifier "Configured Video Device"
Boardname "ATI Radeon"
Busid "PCI:1:0:0"
Driver "fglrx"
Screen 0
Vendorname "ATI"
Option "MergedFB" "off"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
Vendorname "Generic LCD Display"
Modelname "LCD Panel 1440x900"
Horizsync 31.5-56.0
Vertrefresh 56.0 - 65.0
modeline "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
modeline "1280x768@60" 80.14 1280 1344 1480 1680 768 769 772 795 -hsync +vsync
modeline "1280x720@60" 74.48 1280 1336 1472 1664 720 721 724 746 -hsync +vsync
modeline "1280x800@60" 83.46 1280 1344 1480 1680 800 801 804 828 -hsync +vsync
modeline "1440x900@60" 106.47 1440 1520 1672 1904 900 901 904 932 -hsync +vsync
Gamma 1.0
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
Defaultdepth 24
SubSection "Display"
Depth 24
Virtual 1440 900
Modes "1440x900@60" "1280x800@60" "1280x720@60" "1280x768@60" "800x600@60" "800x600@56"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen 0 "Default Screen" 0 0
EndSection
Section "Module"
Load "glx"
Load "GLcore"
Load "dri"
Load "v4l"
EndSection
Section "ServerFlags"
EndSection

3.然后,重启你的电脑,就可以解决了。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译