求助ipw3945 无线网卡不加密 ,wep or wpa加密都不能用?

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
walkingblue
帖子: 5
注册时间: 2007-07-12 23:49
送出感谢: 0
接收感谢: 0
联系:

求助ipw3945 无线网卡不加密 ,wep or wpa加密都不能用?

#1

帖子 walkingblue » 2007-08-10 9:35

现象:
无线网卡WIFI灯闪烁,没有常亮,连接不上,,也ping不通无线路由网关.
network-manager 已经更新到最新
不过如果把IP地址设成手动分配,WIFI灯会常亮,但是无法ping通路由

无论设成不需加密还是wep or wpa加密都一样,但是在XP或者vista底下就很正常,请大虾们帮忙,给一个解决方案.
或者有类似配置的,Share一下你的配置过程

配置:
Ubuntu7.04更新到最新了
DELL I6400
Core 2 duo T5500/120G/1G/ATI X1400/DVD+-RW/intel wireless3945+bluetooth355/
czopp
帖子: 161
注册时间: 2006-05-22 12:55
送出感谢: 0
接收感谢: 1 次

#2

帖子 czopp » 2007-08-12 0:51

说实话network-manager十分不好用。
我配置的时候是网络发现找到路由,选择路由,
选择配置,配置静态ip(关掉了路由的dhcp),确定后就连接上了。

intel 4965bgn wireless adapter
working with ndiswrapper.

compiling and installing intel's linux native driver....
cyysd
帖子: 12
注册时间: 2007-05-30 14:04
来自: nupt
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 cyysd » 2007-08-17 12:12

要是找不到路由怎么办?
谁能共享一下配置的过程
czopp
帖子: 161
注册时间: 2006-05-22 12:55
送出感谢: 0
接收感谢: 1 次

#4

帖子 czopp » 2007-08-19 22:24

如果你熟悉wifi的配置,那么可以放弃network manager,手动设置wlan的配置。
配置/etc/network/interface, 使用iwconfig, ifconfig就可以了。

如果你不熟悉,而使用network manager的话,建议采用如下设置。
开启路由的dhcp。
点击手动配置, Manual Configuration
点击wireless, enable roaming,就是自动漫游模式。
拔掉wired network,也就是拔掉ethernet网线。之所以这么做是因为Wireless A,B,G都没有100M ethernet
传速率高,network manager会自动使用wired network。尽管你还是可以选择无线网络,不妨干脆拔了,即使
作么做没什么意义。(虽然我是802.11n,但是n的路由太贵 ;( )
确定之后network manager自动查找无线网络。
选择自己的无限网络,设置密码即可。(roaming模式会自动侦测路由使用的认证方式,可以通过iwconfig查看)

但是,从我的使用情况来看,如果使用WEP认证方式,认证起来问题还不少。
使用WPA就没有问题了。
头像
SASCSI
帖子: 50
注册时间: 2007-07-24 12:05
送出感谢: 0
接收感谢: 0

#5

帖子 SASCSI » 2007-08-29 18:35

请问用什么工具能自动找到路由然后配置?
czopp
帖子: 161
注册时间: 2006-05-22 12:55
送出感谢: 0
接收感谢: 1 次

#6

帖子 czopp » 2007-08-29 19:24

Network Manager

配置里面点击wireless, enable roaming,就是自动漫游模式。
所谓漫游模式就是windows里面所谓“网络发现”,但是,如果ethernet连接存在的情况下
Network Manager可能不会尝试发现网络。

本来存在于panel的右上方,如果没有找到,
sudo /usr/sbin/NetworkManager就会出来了。
头像
SASCSI
帖子: 50
注册时间: 2007-07-24 12:05
送出感谢: 0
接收感谢: 0

#7

帖子 SASCSI » 2007-08-30 11:12

我看了一下/etc/network/interface,如果我用wpa tkip和手动设置IP,/etc/network/interface应该怎么改?
回复

回到 “常用硬件支持”